Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

3D Model Files Not Working

I've been trying to work with the STL files from the official ARC team, but for whatever reason they're downloading as .htm files. The file itself seems to contain STL data, but there's a bit of HTML at the bottom, and opening it in any 3D Modeling software crashes the program, even after removing the extra stuff at the bottom. Has anyone else experienced this or know what to do about it?

Example:

solid P22_HD L Multi Female Bracket_R02 (Mar 26, 2014) öÿþYøúõùA4A >â-úAuAÚ>A4AöÿþYøA4A >â-úAuA/ù=ÄAÚAöÿþYøAÒäArþaAÂAöÿþYøaAÂA> AAöÿþYøA4AöÿþYøA4ArþA4ArþðíA

AI Support Bot
Related Content
Synthiam
#1  
The issue is with the 3D model printing files that appear to be corrupted.
PRO
Synthiam
#2  
Where are you experiencing this happening? We are unable to reproduce the situation.
#3  
If it saves as the wrong file Ext try renaming it .stl , if the data is the same maybe that will fix the issue, otherwise maybe you are saving the web page instead of the model

edited for poor grammar, thanks Iphone
PRO
Synthiam
#4  
Yah i think that's what the poster is doing - right clicking and saving as rather than pushing the button to download?
#5  
No, I'm pushing the download button. The file shows up as (whatever number).stl.htm, and the computer thinks it's an HTML file with '.stl' in the name. There's also this bit of code at the bottom of the file, which is why it seems to be saving as .htm.


<!DOCTYPE html>

<html xmlns="http://www.w3.org/1999/xhtml">;
<head><title>

</title></head>
<body>
<form method="post" action="./4adea126-fdc8-4816-adc2-a1182f35e742" id="form1">
<div class="aspNetHidden">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="/wEPDwULLTE2MTY2ODcyMjlkZDNgYzOx8OXzI65o9rolQJhMjmFS7tWXE8lN4jnoM1bh" />
</div>

<div class="aspNetHidden">

<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="5F06ECA4" />
</div>
<div>
</div>
</form>
</body>
</html>
#6  
I too have tried to download and run several .stl files ( Six & JD) and I am unable to open any of them in Cura.
If the files are ok then what am I doing wrong for future reference.

Thanks
#7  
Hello all,

Great discussion so far! :) Thanks for all the help.

My observations:

1. When downloading any file from the Community 3D Printing store, the .stl that is downloaded after clicking the "Download STL" button results in an .stl file being downloaded, but named incorrectly. Below are some examples of the file intended to be download vs. the file that was actually received:

A. Hexapod Dome.stl -> 4adea126-fdc8-4816-adc2-a1182f35e742.stl
B. P207 A-01.STL -> 86819d3a-aa3d-4d20-a6d6-0a39f7191ee9.stl
C. P6 A-01.STL -> 513c837e-1cee-4997-936c-bf1eef667edb.stl

2. When attempting to open these files, I receive these errors in the following programs:

A. Windows 3D Builder: Couldn't load that (Error code: 0x80004005)
B. MakePrintable: Unable to load file
C. NetFabb: FAILED: failed to load mesh (invalid STL file)

3. I've attempted to download the files using the following browsers:

A. Google Chrome
B. Firefox
C. Internet Explorer

The combination of the hashed name when downloading, the inability to open the file across multiple 3D modeling programs, and the consistency of the issue across browsers leads me to believe there must either be an issue where the file is hosted. I'm able to download and successfully open .stl files from other sources (thingverse / grabcad / pinshape).

Let me know if there's anything else I should be trying -- or maybe something simple that I'm missing:)

I appreciate the help,

Brian
PRO
Synthiam
#8  
Are you using a downloaded browser extension? We are unable to reproduce this situation with any browser we test with. All tests of downloading and loading stl files work on our end. Let’s find out what you got running and get you roboting:)

What extensions? Firewall? Proxy? What links are you downloading from? Etc etc
#9  
I am able to download/open the .stl files on my laptop but still unable on my workstation.
Both are using the updated version of Foxfire and both firewalls where turned off for the test.
I have noticed, and do not understand why, that on the workstation the downloaded file ends in .stl.htm extension?
It can't be within the browser as CCHSGATE has tried others.
Puzzling!
#10  
@Herr and @CCHSGATE you both are you downloading from the Website directly, as you go to: https://www.ez-robot.com/Community/Revolution/

Then to the Hix Six Dome: https://www.ez-robot.com/Community/Revolution/EZBitDetails.aspx?guid=30a4fd0d-a026-4c95-8b16-ef372a0e1f68

Then you click on the "Download STL" buttom for the dome and the popup should come up with the option to save the file as a .stl file
User-inserted image


When you click the download button you should get a pop up from Windows, clike "Save As" to select the location and so you can view the file name and type:

User-inserted image


I have Simplify3D as my default viewer for "Save as Type", but if your computers have something else set it might be trying to save the type as something other than .stl and adding the .html extention, which is why you need to check to see what that is, or change it to "All Files" and make sure ".HTML" does not get appended to your files.

If you clicked on just "Save" then the computer would just save the file using it's own smarts and you would not get the option to see the full file name, set the type or pick the path as you do with "Save As".

Also, have you tried renaming the files you have already downloaded to removing the ".html" appendage so the file ends with just ".stl"?
#11  
@ JustinRatliff

This just keeps getting weirder and weirder ... lol.
Today I was trying to figure out what could be the problem and Ba Bam, the .stl files downloaded and opened ... ?
So I went back to the files I downloaded for the past 2 days (same files) and they still will not open.
I did no changes on the computer today for that to happen.
You did mention that once the download button is clicked a pop-up box should appear, giving you the option to save the files in a certain extension but that does not happen, either on my workstation or laptop?
My problem is fixed now but I have no idea how or why ... lol.

Don't you just love these things called computers ...:(

Thanks for the help ... at least if someone searches for this same problem in the future, they will have a good read ...:(
#12  
@HerrBall, Yes in deed! I'm glad it is working for you now.

Your browser should always give you the popup to save a file, but if you just click "save" your computer will use it's auto smarts and IF it had some sort of setting or app that thought "Oh these files need to be saved in .html - I'll help you by doing that for you and appending .html to the end - even though I'll screw up the .stl files (hehe)"

I actually remember myself having a problem like once under Windows 8.

But when you select "Save As" you get to see what the file name, extension type and location will be and get to control those incase there is an issue.

@CCHSGATE - how are you doing with the issue?
#13  
Whatever the issue was, manually saving the file as a .stl seems to have fixed it. Thanks for the advice!
PRO
Synthiam
#14  
Computers are a mystery! Always keeping us on our toes:D