EZ-Builder Release 2012.10.27.00

Download and install the latest EZ-Builder robot programming software to experience these updates.

Download EZ-Builder
This isn't a huge update, but it does contain some GUI changes. It is a suggested update.:)

Changes
- New GUI user controls for servo positions and config menus
- Auto Smart Arrange (can be disabled)
- Connection control contains Refresh button to refresh port lists
#2  
Hi DJ,

Did you find a problem in the GUI that was stopping me from disconnecting and such because the multiple Radar scans are working good now.
#3  
Hi DJ,
Again, nice touch on shinning up the GUI.
You mention the Smart Auto Arrange can be disabled. How do I do that? I love the way it arranges things but once it's done I'd like to turn it off. After the arrange process I do a little tweaking and then next time I add a control the Auto arranger Un-tweaks me.

Dave Schulpius
Canada
#4  
@Putt_Putt Glad it is working for you now... might have been something in the re-installation?

@dschulpius in the lower left corner of the Add Control window there is a check box for the auto arrange.

@DJ I know this was mostly a GUI fix, but unfortunately there is still an issue with HTTP.
(1) Image view doesn't work - no image preview or streaming.
(2) I still have to refresh the controlling browser after every mouse click in order to get the next click to be acknowledged on the hosting EZ-Builder. Doesn't matter what PC I use for host or what browser I use on the remote PC (or smart phone) or what network I am linking through.

I think the servo control is a little less intuitive, but I like that the control windows are the same size now, easier to lay out:) just not as quick and easy to adjust with a single click:( I have to drag my mouse right across the screen for a full sweep from 1-100, sometimes re-positioning to finish the sweep.

Thank you for the Connection Refresh:D
Synthiam
#5  
@Gunner
1) Image view has been "work in progress" for 6 months. It will be listed as a change item when it is completed
2) I do not experience the issue you refer to. It's on the list of items to look at in time.

There are over 100 items on the list.
#6  
Thanks gunner, I missed that little check box.

Dave Schulpius
Canada
#7  
@DJ Thanks for the feedback and info... all I really had to go on was your video that implied all was working. Obviously I missed some other details buried in the forums somewhere *blush*

As for issue (2) might I suggest that, when you do get a chance you check, if what I am experiencing might be related to my lack of touch screen devices. I have tried too many totally different systems and isolated networks to believe it is just me:P (As a long term tech myself, I do test and re-test before I comment:))

Sorry your 'roundtoit list is so large... unfortunate cost of such a successful and popular product:P

Thanks again, your efforts have totaly rejuvenated my future career plans into robotics:D