Asked — Edited

Large File Bug

Hello, I have had problems with ez-saving project builder, I have installed the latest versions of ARC and filmware. After adding the function "recorder" menu scripting and recording a sequence of movements of servos, saving the project went well, but I went to open it again this message User-inserted image I have also noticed on other occasions it was not possible to record on a project a sequence of movements of the "recorder" of ARC , I mean that when I opened the project and the recorder did not appear in it. I tried opening the project in my pc and my pc laptop with the same result, both windows 7, I attach the project file that has this error: cabeza.EZB Appreciate any help, thanks stress

Skip to comments


Upgrade to ARC Pro

ARC Pro is more than a tool; it's a creative playground for robot enthusiasts, where you can turn your wildest ideas into reality.


Okay, I updated my other robot filmware and have proven again, confirmed, receive the same error message when I save the project after recording a sequence of movements with the option "recorder". So you can not save a project with the sequence of movements recorded? You have to record the sequence in "recorder" every time you open the project or is some kind of software error?


Hmm, i cannot reproduce the issue. I'll look into it more for ya


Hi DJ, Have you had a chance to look at the Recorder file saving issue? I have experienced same problem than R2D2, and my case after triying to save it becomes impossible to reopen the project file. stress


I upgraded to new software ARC and filmware today. and I re-tested on PC desktop and laptop pc and the error is the same. Same error message and can not be opened after the project. I have windows 7 on my two computers and have done all kinds of tests on the way to record or save the file, it is quite frustrating after so long, any solution DJ? Thank you.stress


Large recordings will cause your computer to run out of memory. There's an item on the list to look at a different way of storing the information.


DJ Sorry do not understand, no memory? the laptop is a Core i3, and 6GB of ram. Any suggestions on settings of windows 7? No wonder that the two computers do not operate the recorder? confused


Besides the recordings are not great, I've proven with my recordings of 3seconds of time and one servo.


S.O.S Having problems with this one confused Not sure what you mean DJ ?


I just tried saving a project recording Bob moving a few meters as part of my next Project.

I get exactly the same error message as you guys.

DJ please look into this code error on this and get back to us. :) mad


Large recordings run out of memory in saved files. There is an item list to use an alternative storage method.


These are not large files - Are saying is that we cannot save recordings ? sick If there is an alternative - SHOW US HOW IT WORKS..please confused


Recordings currently create large files. There is a bug with large files in recordings. There is an item on my to-do list for this. However, repeated questions on the same subject thread occupy my time and prevent me from working:)

If you could please refrain from repeating the same question, items will be addressed in their order.:)


Dear DJ, the wonderful things that you have enabled us to do with our robots (talk, see, read, tweet, move etc) are nothing else but miraculous! I deeply appreciate your efforts to fix the bug and have faith that not only you will but also CAN do it in way that will exceed all our expectations as you always do.


Has anyone got some least now we know it's a bug ! I will stop trying different things from my end ;) ;) ;)


Use the latest ARC and resave your files to the cloud. The large file up to 32mb has been resolved.

Old broken files will not work


Thanks Dj for its efficiency and speed, I'll prove it tomorrow.:P :)


Thanks DJ for squashing this bug so fast! I was able to test it last night and was fascinated to read "saved" on the screen! I have also noticed that as you mentioned, older project files build with the previous version of ARC will not save. This gives me an opportunity to start afresh. I did observed though that it will not save recordings of the Movement Panel even with a new file. I am certain that you, more than anyone else, are aware of this limitation and will address it in due time. As besides, like any great inventor, you keep perfecting your design.;)


I'm using the Hbridge 4 wires movement panel.


That should record also. I'll take a look but it should be fine hmmmm


Unfortunately I do not work, today I updated ARC and filmware and have proven to records 2 seconds of time and the error message is this:

User-inserted image The message appears when I try to save the file: Error generating the XML document


Do you have any specific language characters in the project? We work with the english language, so perhaps there are issues with different languages within the project.


@R2D2: Did you try saving a brand new project made with the latest version of ARC? I have noticed that if the project is not brand new it will not save it.


@R2D2: How many servos were involved in the recording? Last night I also realized that it will only save if no more than one servo is involved.


Dj: the file does not have language specific characters, I have proven with names as simple as as a.ezb or rb1.ezb. Nicolson: I created a new file with the latest version of ARC, a simple file with only one panel of the recorder servo horizontal and even the recording of only 2 seconds to avoid a possible saturation of memory, but I been not successful. I would like to work, but I have no hurry, my projects take a great time to complete and is not an urgent issue, but I like to be taken into account in future find a solution that Dj without a doubt. The next test will be updated ARC on my other computer and try again, I will keep you informed, thanks.

DJ: I fully understand your lack of time, and I deeply appreciate your dedication, I am sure you have a thousand things on your list, so do not be overwhelmed with this issue, Greetings. ;)


Agree R2D2. I was just pooy because I wanted to use recorder to get Bob to follow his tracks to the kitchen and back but it's not important. I now realize that's way to much memory. My expectations are extreme and I'm sorry about that.

Take a break DJ, there is no way we expect you to cover all this stuff. :) :) :)


Already checked with my laptop and the fault is the same, it is not my machine, it's a shame because the recorder works great as long as you do not save the project. It would be a silly solution or rare a copy and paste of the positions and time recorder that records and paste them into a script and then run would require a conversion of the lines of position on the recorder to the EZ-Script commands? I hope that the translation is understandable. :)



I have the same issue with 'XML doc' error, when trying to save a file, after recording a mouse movement.

I read the entire thread, but since not very technical, maybe missed the solution for the problem.

What should i do?

Thanks, Roi.