Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Germany
Asked — Edited

Windows Phone App, Ez_B.Dll Wontt Work

Hello,
I am trying to make an Windows Phone App for my Robot.
I am working with Visual Studio 2013 PRO and if I click on "Verweis hinzufügen" (normally add an .dll) theres an error :
"Dem Projekt kann kein Verweis auf eine höhere Version oder eine inkompatible Assemlby hinzugefügt werden"
Means that EZ_B.dll is not running on windows phones?

Thanks for answering,
Patrick

PRO
Synthiam
#1  
From the Windows SDK page, which you downloaded the SDK from...

Quote:


EZ-SDK for Windows Version 2015.05.20.00

The powerful EZ-SDK Framework enables C#, Visual Basic or C++ programmers in Windows 7/8/8.1/10 to control the EZ-B v4 Robot Controller for streaming audio/video, sensors, servos, and more. Your custom program will communicate with the EZ-B Robot Controller over a TCP/IP WiFi connection from your Laptop or PC. The SDK exposes every powerful function that is included in our graphical ARC application.


We had a face to face with Microsoft last week and they introduced Universal - which we are now developing a new SDK for. In fact, I am developing it as we speak.

Stay tuned for a Universal SDK appearing on the Software page tonight or tomorrow.
#2  
Okay, thanks for answering :)

It would be really nice, so keep it running.If it´s online i will try it:)

I only thought that it may run on Windows Phones cause many other dll´s works also for WP, which are designed for PCs.
Patrick;)
PRO
Synthiam
#3  
I just finished the first version of the windows universal SDK. I'll publish it now
PRO
Synthiam
#4  
You can find the latest Universal Windows Platform SDK (UniversalBot) here: http://synthiam.com/Products/ARC

This will run on all Windows platforms - including Windows, Windows Phone, xBox, Raspberry Pi, and more...
#5  
Hi:)

Thanks for reply.
But if I wanted to open it with Visual Studio, it says taht this project isn´t supported.

I tried the projects in the folders (Visual Studio 2013 and 2015) with Visual Studio 2013 Professional and Visual Studio 2015 RC. Both the same error message.

Error message:
TestApp\TestApp.Shared\TestApp.Shared.shproj: Die Anwendung, auf der dieser Projekttyp basiert, wurde nicht gefunden. Klicken Sie auf diesen Link, um weitere Informationen anzuzeigen: http://go.microsoft.com/fwlink/?LinkID=299083&projecttype=D954291E-2A0B-460D-934E-DC6B0785DB48

*confused*

What do i have to install? Or which Visual Studio versoin would I need?
Thanks for answering
PRO
Synthiam
#6  
Re-download the zip file. I believe you had downloaded the first draft which only supported VS 2015. The latest zip supports 2013 and 2015.
#7  
Hi,

I have downloaded the new File, and there are two folders for VS 2015 and VS 2013, but there is the nsame error emssage. With both VS.
Which specific Version of VS are u using?
PRO
Synthiam
#8  
The folder VS 2013 is created with visual studio 2013

The folder VS 2015 is created with visual studio 2015

Do you have UWP support in your VS 2013 installation?
#9  
Hi,

my VS 2013 not, but VS 2015 have UWP supported. But it wasn´t installed.
I´ll install it now, and I´m sure it will work. Thanks!:)
PRO
Synthiam
#10  
I believe UWP support for 2013 comes in a few flavors. The UWP that I am using in 2013 is from xamarin. There may also be a downloadable addon from microsofts msdn website.

If you're using 2015 anyway, no need to worry:)

I find 2015 very buggy - but it is a great approach from Microsoft. When it is stable, it will be a great new ide and UWP is welcomed by me.