Welcome to Synthiam!

Program robots using technologies created from industry experts. EZ-Builder is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.
Get Started

United Kingdom
Asked — Edited

Windows 10 Tts Question

Some of you may have seen my recent post and video on the cortana/pandorabot and would have heard the completely horrible TTS voice. This morning I installed a Cereproc voice (Giles) on that PC but got the problem that EZ-Builder does see it, but will not actually load the Giles TTS and the awful (slow) Hazel voice continues.

I have followed Steve G great tutorial hoping this would allow me to start using Giles, but the problem is that the 4 files Steve suggests to delete, cannot now be deleted and a TrustedInstaller note appears which stops the delete. This must be something that has occurred in the latest win10 software upgrade (anniversary edition)?

Can anyone advise how to get around this? Thanks.

Tony

United Kingdom
#7  
Well, I spent all morning and followed up on Bob's lead/advice (and thanks also to MadRocker) and I finally got some decent TTS - basically I have had to change all speech and language to English US from English UK (which is where I am) going through the steps MadRocker linked us to and I then managed to get both William and Giles Cereproc voices working in my cortana pandorabot program and I can also now change the speed. The trouble is that my speech recognition is now US and not UK - but the cortana SR is so good that it is still working around 99%!

Alan, you are right the TTS part of EZ-Builder seriously needs to be looked at.

Tony
#8  
DJ,

Here is working source code for selecting the installed voices. I was able to compile this in VS2015 Community edition. It had some warning, but worked and I can select any installed voice.

There is also a lot of sample code on MSDN for the various speech manipulation functions under dotnet, but I didn't see downloadable samples and wasn't ready to put in the time to figure out how to write a full sample app.

http://deepak-sharma.net/2013/01/31/text-to-speech-using-c-sharp-in-windows-forms-application/

Alan
#9  
@Toymaker,

I wonder if the reason I can't get Cepstral Lawrence to work in Cortana is that it is a UK voice and I am in the US with US settings. I can get it to work in the two apps I listed above.

Alan
#10  
Good to hear it worked out for you Toymaker. I was wondering if you were to uninstall then reinstall the UK speech engine would that correct it since 2 engines are now loaded.

@thetechguru I don't have EZ Builder on a 10 machine, but I do use UK hazel with US Settings/ Region on a different machine. Cortana's voice is UK when testing it. Maybe adding the stock UK English engine will get Cepstral Lawrence working.
#11  
@Madrocker, I may try that just to experiment. I am not actually as concerned about Cortana as getting it working correctly in EZ-Builder. I just found it interesting that Microsoft can't get their own stuff right....

An off topic side comment.... I am very pleased to welcome you to the forum. It is rare for us to get someone who joins, apparently reads all the tutorials and back posts, and starts providing valuable hints and tips so quickly (I see you joined a couple months ago, but your activity seems to be mostly very recent). Your input the past few weeks has been very refreshing.

Alan
#12  
@thetechguru, Thank you for the greeting. Lurking in the background and reading has helped me Learn quite a bit, though I still have a ways to go. I do enjoy reading the back posts to help me with that process and use to use them as reference points when I'm unsure. This seems like a great community to me so I felt a lil obligated to try and help if I could. That's what makes good communities great in my mind.

Ed