Welcome to Synthiam!

Program robots using technologies created by industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation, and artificial intelligence easy.

Get Started
Asked — Edited

Wifi Not Working

Hi, I keep reading you can use wifi but tried it and no luck and don't know of anyone who got it to work. I asked Dj for help but no reply,did anyone get it to work and how
thanks

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
#7  
just got new wifi but it is auto mode tried hyper terminal and even tried this from other post and no luck,


Posted at 7/5/2012 1:44:46 PM #4
I am sure following the instructions should do it. Simply connect the wifi to the ttl usb then open arduino next set the serial port to the specified com that the ttl is on. open the serial monitor type in +++ and hit send. You should receive +ok as a response, this should remove it from auto mode. From there you can use the wifi software to programm the wifi card.
#8  
Ok almost got it working,do i want auto mode?
#9  
When the WiFi board is powered up it will not identify itself with the ip address you have obtained during your initial testing of the board and will not use the password needed to handshake with your router unless it is in the auto mode.
#10  
what ip address and port # should i use for auto mode,the same that i used for wifi card network setting ip
#11  
There was a step in the documentation downloaded from the website for the initial setup of the USB WiFi that had you type in a command to obtain the ip address your router assigned when it first discovers the WiFi board. The port assigned is 8090. The ip to use is the same one that you sent the ping command to.
#12  
Ok several days of trying and here is where i am at. My new WIFI came in(USB-TTL module was bad on old one) all drivers loader and with help of this
POST
I did this setup

SETUP LINK
get to setup auto mode and here is what i get
~~~server address~~~
0.0.0.0 stays connected to router
192.168.1.1 cycles every 10 seconds
192.168.1.139 does not connect
i can ping fine when connected to router.

a free virtual serial port thanks @robotmaker
virtual serial port
but won't connect with any settings i put in server address and yes every thing is all set to 9600.
also set port forward 192.168.1.139 to port 8090

Don't know where to go from here,wish i was smarter *stress*
United Kingdom
#16  
I've only seen the last few posts and not read the instructions for the wifi board and this is purely assumptions but shouldn't it be set to server not client? What happens then?

I'd also put a timeout in there, 120 should be fine but up it if you feel you need to.
#17  
havent got that board,but looking to get it,one i got is little different but has same output
i havent tested it yet on EZB waiting on RJ45 protoboard board to come in to have both WIFI and wired network on EZB,i think both should work ok
only thing i check that the virtual port shows up on EZB as com 5 and on my computer
may be your board it bad or ?
have you tested it with the software from elechouse
#18  
also might check your firewall to see if you have that port added,if not can add one easy
United Kingdom
#19  
just had a quick (and I mean really quick) search on this and everything I come across showed it being set to server not client



User-inserted image
#20  
1~virtual port shows up on EZB as com 5 and on my computer ( yes )

2~have you tested it with the software from elechouse ( yes )

3~ it being set to server not client ( ok i will check that )

thanks this is driving me nuts and can't put computer on rc robot.If i get this to work (make me happy) and @Dj will have a new way to sell his product that we all love.
#21  
couple of other things to check i see it needs 5 volts for that board check the voltage on EZB

other item check your EZB again with bluetooth to see if your EZB is ok
another item last resort switch the pins tx and rx
there are other tests to try,i forgot the name right now but you need to tie tx and rx on wifi board and use term program
second is you wifi on your computer setup and wifi board on computer shows it listed
at networking i am very good at it
United Kingdom
#22  
@pittom did you get it working? I'm looking at using the same board for my build as bluetooth isn't good enough for the range I need
#23  
so so, i got it to connect but ez gives me some data (some readings on voltage monitoring ) but that's all, my scanning servo won't even move. I think data is supper slow,rechecked ez with bluetooth and works.@richmr2 was wright i had it in clint not server mode.

Still trying
#24  
SO how its in the setting,you should get near 54mbps
#25  
I couldn't login to the free single virtual port GUI so found one that does the same thing but costs $99 a port. I still can't access EZ-B, here's what I get:


User-inserted image



Found a fix, When using independent battery supplies to power the WiFi board and the EZ-B, the batteries need to share a common ground.


User-inserted image
#26   — Edited

Quote:

Ok several days of trying and here is where i am at. My new WIFI came in(USB-TTL module was bad on old one) all drivers loader and with help of this
POST
I did this setup

SETUP LINK
get to setup auto mode and here is what i get
~~~server address~~~
0.0.0.0 stays connected to router
192.168.1.1 cycles every 10 seconds
192.168.1.139 does not connect
i can ping fine when connected to router.

a free virtual serial port thanks @robotmaker
virtual serial port
but won't connect with any settings i put in server address and yes every thing is all set to 9600.
also set port forward 192.168.1.139 to port 8090

Don't know where to go from here,wish i was smarter *stress*
 :DThanks for the manual, I managed to repeat your path and with the server assignment and virtual serial port everything worked as Rich advised