Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Lebanon
Asked — Edited

Wifi Connection Ez-B And Hp

Dears,

I am facing a problem with my wifi connection on my laptop.
I am using the HP and been trying to establish the connection but not working although if i do connect my iphone to the device, it works and accepts it.

I kindly ask your help!

Thanks *stress*

AI Support Bot
Related Content
Synthiam
United Kingdom
#1  
There are known problems with RALink Wifi adapters installed in a lot of Compaq and HP machines. I had the same problem some time ago trying to connect an EZ-B in AP mode to a HP laptop. I use an Acer now with no trouble at all. There is some information on connection troubleshooting you can read about here. What you can do is use a WiFi dongle, or if you use a wireless router for your home network, you can connect to "Client Mode" using another Internet enabled device like your iPhone, to begin with. Once client mode is set up you can use the HP laptop again. I have written you out a short "How to" guide below to help get you connected to client mode.

Here's how to connect to "Client Mode".

1) Power up your EZ-B, then connect to the ezb with your iPhone or a tablet/other PC which should be visible in your WiFi list.

2) Open your iPhones (or other device's) search engine program, and in the web browser at the top of the screen, type in... http://192.168.1.1

3) The ezb web server will come up.

4) Locate the Client Wifi button on that web page and click on it.

5) It will ask you to enter your SSID (network name) and router password (which is case sensitive).

6) Press "save", and you're done with using your phone/tablet/other PC. This will reboot the EZ-B and the LED will start flashing green. You should now be in client mode.

7) Now go back to your HP laptop, and open ARC then use the scan tool in the connection control icon that looks like a mini cell phone tower to locate your ezb.

8) If it finds your EZ-B's IP address you will hear a chime. Press "Stop" wait a couple of seconds for the address font to become bold, then press "Select", then "Connect". You will hear the EZ-B chime again to confirm it's connected.

It could be your antivirus software (if you have any). You can disable it and try again, but it's more than likely the WiFi adapter issue that's causing the problem.

Hopefully some of that will help.
PRO
Synthiam
#2  
When attempting to connect, the message asks if you would like to view the debugging procedure. Have you viewed the debugging procedure before posting this message? If not, please review the procedure. The instructions will help us to help you.

Specifically check the network adapter. Also check if a virus scanner is running. Those details and more are provided to you in the debugging procedure.
#3  
Thank you steve!
This was very helpful .. I will try to use a wifi dongle and i'll let u know what will happen.
I doubt it is a matter of antivirus since i've removed it while trying.

Thanks again
United Kingdom
#4  
No problem. Good luck.
PRO
Synthiam
#5  
If anti virus has been removed, that will be good. Even disabled is a good thing. Many virus programs think that the ezrobot is harmful because it isn't well known.

I believe the network usb dongle should work for you.
United Kingdom
#6  
@DJ.

Isn't well known... Yet.;)
#7  
DJ,

I don't think it is actually because EZ-B is not well known, it is because you use port 23 (Telnet) and Telnet is inherently insecure when used between computers so many anti-virus applications block any app that tries to communicate with it. (Since the computer is initiating the connection, and the EZ-B is not a general purpose OS,I doubt there is any actual vulnerability).

Any decent AV/Firewall app allows whitelisting so once someone determines that it was their AV causing an issue, they can probably turn it back on and just whitelist ARC.

Alan
#8  
Dj,

I've tried a usd dongle "dlink" but still the same. I even used a toshiba laptop!
Do u think there is a problem with the ez-b? I have just received it from maker shed !
Antivirus disabled also! *stress* *stress*
United Kingdom
#9  
What colour LED do see when you power up the EZ-B, and do you get the verbal greeting message? Also, have you pressed the reset button (small hole on top of the EZ-B with a pin) and tried to re-connected it? After resetting it, you should see a blue LED and hear a verbal message saying that it is resetting the network.
#10  
It starts white, than the greeting than blue led starts blinking.
The rest button i have tried it many times and it also gives u a notification that is resetting !
United Kingdom
#12  
Okay, it does sound for the miment that the EZ-B is working fine. What you ran the troubleshooter on Windows to see if there are any recognised connection issues? If so, post a picture of the diagnostic report. Also, a few other things that you may or may not have tried. Disconnect the power and reconnect it and try again. If you are powering it with a battery, is it fully charged? Also have you tried disabling Windows firewalls?
PRO
Synthiam
#13  
1) Submit a diagnostic report: http://www.ez-robot.com/Tutorials/Help.aspx?id=220
Let me know once it has completed and i will take a look for you.

2) Can you connect to the EZ-B v4 with your tablet or mobile phone? If so, can you connect to the internet web server of the EZ-B v4 by typing 192.168.1.1 in the browser and tell me the version that is displayed?

Thanks!

PS, is Lebanon south of the equator? Everything is upside down:D
#14  
Dj,

I have replaced the batteries by new ones.
Even i have tried to connect to a usb D-link wifi dongle but without success.
The device connects directly to an iphone and as per you request, the web server 192.168.1.1 has connected directly.
Below some pictures showing windows troublshooting and web server link:

User-inserted image



User-inserted image



User-inserted image
#15  
Oh btw, Lebanon is next to Turkey, on the mediterranean sea facing Greece and if u r looking for a nice vacation, u'll find very nice chicks google it man!:):)
United Kingdom
#16  
Have you got any network cables plugged in to your computer connecting to your router? If so, remove them and try again.