Asked — Edited

Why Won'T Rolli Follow The Arrows On The Controller?

Why Won't Rolli follow the arrows or obey the controller? When you press the arrows on the controller, Rolli will go forward or backward while slightly turning. Then when you press the up arrow he will roll forward a bit then make a clink sound like something broke. I have checked his battery but there's no signs of damage. ARC is not working on my computer and I haven't had a chance to re-download it. I don't know what else might be faulty so I am posting on here for ideas. His fuse was changed in March, I believe.


Upgrade to ARC Pro

Elevate your robot's capabilities to the next level with Synthiam ARC Pro, unlocking a world of possibilities in robot programming.


Sounds like something is binding or one of the motors is dragging and pulling too many amps? Maybe this is what blew your fuse in the first place? Can you check and see if the motors are spinning freely and nothing is caught in the wheels/treads (like sting)? You may have to use Contact Us to help resolve this...


One side moves freely the other side won't budge when i hold it in the air. It just barely moves on the carpet. So where should I look or be on the look out for? The wires wrapped around something?


So I re-downloaded ARC and It won't let Rolli connect to the software on my computer any suggestions?


Use the learn section to follow connection directions. When ARC prompts that it can't connect, it also asks if you want to view the tutorial. No one can answer your questions better than the tutorial.

The roli may be turning slightly because the pwm speed controllers are not equal speeds

Also, sounds like you're using a very old mobile app for roli. Connect to wifi and press the update installed apps button to update installed apps.


Here's some additional tips...

Also, you just update ARC. The version you are running is from 2017.01.10.01, which is many many months old. Press the update button when ARC loads. Or visit the software tab on this website and download ARC.

Also, you are loading the Six hexapod project and not Roli. Those are different robots. Please load the roli project as the instructions describe in the learn section.

Also, when prompted to download ezbits, you must say Yes. Because when you don't, a mesage about the software being unstable is presented. You have been ignoring that message. Do not ignore messages.

Here's your diagnostic log, showing missing ezbits, and a very old software version.

4/2/2017 11:45:55 PMMissing EZ-Bit: 4/2/2017 11:48:29 PMObject Recognition Initialized. 4/2/2017 11:48:30 PMCamera Initialized: EZB:// @ 320x240 4/2/2017 11:48:30 PMObject Recognition loaded. 4/2/2017 11:48:31 PMEZ-B v4 Camera Error: System.Net.Sockets.SocketException (0x80004005): No connection could be made because the target machine actively refused it at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult) at System.Net.Sockets.TcpClient.EndConnect(IAsyncResult asyncResult) at EZ_B.EZBv4Video.hRhf8p8rfO(Int32 , Object ) 4/2/2017 11:48:32 PMC:\Users\Public\Documents\EZ-Builder\Examples\SIX.ezbCamera Disabled 4/2/2017 11:48:59 PMC:\Users\Public\Documents\EZ-Builder\Examples\SIX.ezbScreen Resolution: 1366x768 (96x96 dpi) 4/2/2017 11:48:59 PMC:\Users\Public\Documents\EZ-Builder\Examples\SIX.ezbVersion: 2017.01.10.01


I have updated everything but now rolli won't follow the remote at all. His camera feed reads but he won't move at all. I checked everything. I haven't been able to connect to ARC on my laptop yet.


So I have gone through every tutorial and all the videos nothing worked. He won't even respond to the remote now. I have tried the diagnosis button but so far the only thing that works is the sound and the PO #2 so one side. The one side that doesn't move makes the sound but just don't move. I have no idea what to do and this robot needs to work by Tuesday.


Thank you for all who responded I finally fixed him


@jleigh1231 What did the problem end up being? Great that it's fixed though...


Well first the gear in on of the wheels slipped off. Secondly the tire treads had weird sticky stuff on them that was making hard for rolli to move. Thirdly the battery had to be replaced because it wasn't charging. However when I did diagnostics of him through the computer it showed nothing was wrong.