Asked — Edited
Resolved Resolved by CochranRobotics!

Whats Wrong Whit This?

Error on line xx: Missing ) in Expression when I run this:

Exec("c:\Program File(x86)\RoboRealm\RoboRealm.EXE")

Skip to comments


Upgrade to ARC Pro

Unlock the true power of automation and robotics by becoming a proud subscriber of Synthiam ARC Pro.


Try this

$roborealmpath = "c:\Program File(x86)\RoboRealm\RoboRealm.EXE"

The issue is that the EXEC command doesn't like the (x86) piece of your path.

I would also recommend launching the .robo file instead of the exe. The exe is linked to the .robo file (or the other way around) and it will open the .robo file in roborealm. This will allow you to launch different .robo files depending on what you are doing within RoboRealm.


Put another ) at the end and see if that helps.

Edit, never mind. tired


@David same error when I run: $roborealmpath = "c:\Program File(x86)\RoboRealm\RoboRealm.EXE"

@Dave Try to add () at different places with no success


Try this,

Launch Roborealm and build your project in RoboRealm. Save the project to your my documents folder or wherever you want to store these, and then use that path to launch it. This is how I do it and how I setup @fxrtst's to work last night.


@David I did move my file elsewhere and now it works Tanks


You bet. Let me know if you have any questions about roborealm. I have become fairly good with it.