Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Canada
Asked — Edited
Resolved Resolved by CochranRobotics!

What's Wrong Whit This?

Error on line xx: Missing ) in Expression when I run this:

Exec("c:\Program File(x86)\RoboRealm\RoboRealm.EXE")


ARC Pro

Upgrade to ARC Pro

Your robot can be more than a simple automated machine with the power of ARC Pro!

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
#1  
Try this

Code:


$roborealmpath = "c:\Program File(x86)\RoboRealm\RoboRealm.EXE"
EXEC($roborealmpath)


The issue is that the EXEC command doesn't like the (x86) piece of your path.

I would also recommend launching the .robo file instead of the exe. The exe is linked to the .robo file (or the other way around) and it will open the .robo file in roborealm. This will allow you to launch different .robo files depending on what you are doing within RoboRealm.
#2  
Put another ) at the end and see if that helps.

Edit, never mind. *tired*
Canada
#3  
@David
same error when I run:
$roborealmpath = "c:\Program File(x86)\RoboRealm\RoboRealm.EXE"

@Dave
Try to add () at different places with no success
#4  
Try this,

Launch Roborealm and build your project in RoboRealm. Save the project to your my documents folder or wherever you want to store these, and then use that path to launch it. This is how I do it and how I setup @fxrtst's to work last night.
Canada
#5  
@David
I did move my file elsewhere and now it works
Tanks
#6  
You bet. Let me know if you have any questions about roborealm. I have become fairly good with it.