Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Visual C Sharp Is Stuck

I cannot get the EZB_Connect to work. When I drag the EZB_Connect into the form and then run the program it just get stuck. Visual C# 2010 Express just hangs, nothing comes up.

Hoping For answer.
- Egil

AI Support Bot
Related Content
Synthiam
#1  
" Mixed mode assembly is built against version 'v1.1.4322' of the runtime and cannot be loaded in the 4.0 runtime without additional configuration information. "

on the line

"this.ezB_Connect1 = new EZ_B.EZB_Connect();"
#8  
Did a fresh install of Visual C# express 2010 but still the same error *confused*
Yes, I have added the EZB.DLL file
And the only thing I have added in the windows form is the ezb_connect tool.

- Egil
United Kingdom
#9  
I get the same errors.

I once got the Omnibot examles in the SDK to run many releases ago but have had no luck for awhile now.

However the ARC platform is becoming a whole language of its own and requires some thinking about as it offers so much versatilaty
PRO
Synthiam
#10  
I can't imagine what the difference between our systems are. Have you tried setting the project to use .Net 3.5?
United Kingdom
#11  
Yep tried that

*confused*
#12  
Yes I have set it to use 3.5 and then when it ask me to save the project it just hangs again.

EDIT: Wow, 39 secs after your post !
#13  
I haven't had a chance to try the last few builds - been focusing mostly on hardware. I'll update and fire it up tomorrow to see what happens for me...
#14  
Just downloaded and configured the latest SDK. Thus far I haven't experienced any errors loading the projects...

This is the process I use to get the SDK running on my systems:

(1) Add the following references to all projects:
EZ-B.dll
DirectX.dll
DirectX.DirectInput.dll

(2) Select Clean Solution from the Build menu

(3) Select Rebuild Solution from the Build menu

Also, I have a fairly large number of development platforms, frameworks and SDKs installed on my systems for work-related projects and everything was working prior to adding the EZ-B goodies. I'm wondering if something is missing from the systems experiencing errors?


Note: I add the DirectX references to get rid of the unmanaged code debug warnings. SlimDX please? ;)
PRO
Synthiam
#15  
I considered slimdx, but the performance is limited due to the abstraction layer for interop calls. I also would have to take a peak at their licensing for distribution.
#16  
Hi im new to Visual C#, and this EZ-B platform.
Im stuck in trying to run any of the sample code. not sure what to look for?

I have visual studio C# 2010, on win7. Using "Test - Servo"
1) Ez-B board is powered on. ARC is closed.
2) double click "Test - Servo.csproj" , the program converts it to the VS C# 2010 format.
3) I've add references to EZ-B.dll, DirectX.dll, DirectX.DirectInput.dll, from the projects/Addreferences/browse area.
4)clicked "build>Build solution", no errors, no warnings.

now what do i do to run this code?

I double-clicked /C#/Test - Servo/bin/Release/Test - Servo.vshost.exe and nothing happened.
am i suppose to have ARC running in the background?
i looked around "Form1.cs" "form1.Designer.cs" "program.cs" and i did not modify anything.
Netherlands
#17  
Hi there,

Try the next few things :

first
open a project.
make sure you have added the ezb.dll
add the reverence -> ezb.dll
for x64 you have to change the Active solution platform to X86 -> configuration manager
in debug make sure u have disabled the loaderlock -> debug, exeptions -> managed debug assist.

That did it for me.
#18  
*confused*
All Hi,
Issues with running the C# example code, to specific the "servo-Test" program.
1. See attached file.

Thanks
Netherlands
#19  
what is the problem and where is the attachment ?
PRO
Synthiam
#20  
Please follow the instructions in the included readme.txt file in the sdk package.:)
#21  
I did to the letter before i wrote to you about the issue. Maybe you should read what i wrote?? anyway after repeating the entire procedure there was no change in the outcome. I will continue to debug the issue. thanks for your help.
George
PRO
Synthiam
#22  
@garober, all you wrote was this:

Quote:


All Hi,
Issues with running the C# example code, to specific the "servo-Test" program.
1. See attached file.

Thanks


If you can provide me more information, i'm certain i'll be able to help. My suggestion is to follow the README.TXT file. That will provide you with the necessary configuration steps to compile. From that point, anything in the SDK ZIP will compile:)
#23  
hi I am trying to learn C# and I got to run the tutorial or atleast no erros show but I can not see the code. Now in form I get to connect the EZ-B but still the buttons to do forward or reverse dont work and I can not see what ports I need to connect the servo.

User-inserted image


Please could any one guie my to the next step.

coljc85
Canada
#24  
Hi Coljc85,
I think this is what you are asking for, click this button and you should see the forms code:

User-inserted image



User-inserted image



My advice if you want to learn C# is to check out the online tutorial sections that you access from the visual studio IDE or just google it and microsoft has a ton of good beginner stuff.
#25  
I am new to C# and programming... When I am trying to open the project in EZ-SDK... I am getting the following problem...


User-inserted image




I added the reference and still have the problem...



User-inserted image




Please help me out...
PRO
Synthiam
#26  
Delete the EZ-B reference with the big yellow exclamation mark that says "this reference cannot be located":)
#27  
Thanks a lot @DJ... It's working fine now...

:D;):D