Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
United Kingdom
Asked — Edited

Vertical Servo Question

Hi, i'm have a bit of problem with the vertical motion of my servo.i am using an DAGU Pan and Tilt Kit with mini Servos, i have the horizontal working fine and have it tracking me around the room with the camera and everything works apart from when i try and get it to track something vertical. it kind of nodes up and down like it's fighting it's self then just goes all the way up or all the way down and stays there till i move it using one of the other controls.
i've tried adjusting the servo speed, the red lines, inverting the controls, plugging it into a different port and even new batteries but with no luck. the servo (Pan and Tilt Kit) works perfectly with all the other control's but not with the face, colour and motion tracking.
please can someone help?

Simon

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
United Kingdom
#1  
Check the settings in the camera config. Make sure your min position isn't greater than max position and make sure it is set right for inverted or not.

Every control has a question mark next to the close X button. Pressing the question mark button will direct you to a tutorial page for the respective control.
United Kingdom
#2  
Yep I've done all that. I've even had it so it can only go vertically and the same happens. I would say it was the servo but it works fine with all the manual controls. Could it be a software problem? I'm running the latest version on windows 7. I've reached a dead end :-(
United Kingdom
#3  
Can you upload your project? (Use the attach file to the left)
United Kingdom
#4  
Okay cool :) if you can look at it that would be great.day1.EZB
United Kingdom
#5  
I'll take a look and check it later when I can get my bot down to hook up to ARC.

I hada quick look, X axis is set to N/A, what is this usually set at? And what is Y axis on too (project indicates D0). Just want to make sure you hadn't accidently set both to the same port or something like that.

Initially it looks like it should work though but will check properly when I get home later.
United Kingdom
#6  
Yep that's right I put the x axis on n/a just so I can see if I can get the y axis working. But even with just the y axis it still just nods up and down then goes all the way up or down and stays there. It does see my face, red ball ect but it just can't lock on and nods away. But thanks for looking at it for me hopefully you might see if or what I'm doing wrong.
United Kingdom
#7  
I forgot to mention the x axis is D1.
United Kingdom
#8  
Config wise it looks the same as my pan/tilt which works fine.

I'm unable to check it on my EZB as it looks like I forgot to switch off my robot when I moved it out of the way and drained my LiPo. When I get a chance I'll try it if nobody else steps forward to test your project or spots something I haven't seen.
PRO
Synthiam
#9  
Usually when it nods away, that means the Invert option needs to be set for that one servo.

On a side note... Your post has made me very happy:) ... I noticed your filename is "Day 1". That tells me you have already been able to achieve so much in one day. I'm excited to see how quick people embrace EZ-Robot. Makes me smile!
United Kingdom
#10  
Yep it's really easy to pick up. I'm not a programmer or anything like that. if I need to learn something I just watch your videos. Plus The ARC is really intuitive.
United Kingdom
#11  
if fixed it :D I had the Pan and Tilt kit on backwards :-/ so after a bit of tinkering it following me around the room. Thanks for trying and help me ;)
Once i've finished his head i'll put a few pictures up.