Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by ptp!

Using Httpget Command With Foscam F19831p Wifi Ip Camera?

DJ,

I have a newer Foscam F19831p Wifi IP Camera and am trying to control the PTZ functions using HTTPGet Command. I type in the following and looking in the debug screen it appears to be connecting as there are no errors but the camera does not move:

HTTPGet("http://192.168.x.x:Port/cgi-bin/CGIProxy.fcgi?cmd=ptzMoveRight&user=username&pwd=password")

I also tried the following and I got server connection errors in debug:

HTTPGet("http://192.168.x.x:Port/decoder_control.cgi?command=6&user=username&pwd=password")

Command=6 is the command to move the camera right.

My camera is a newer model so the first sequence appears to connect to the server but no actions. Also just for grins I changed both the password and username in the first script and it still seemed to connect. The only reason I say that it connected is because there were no errors in the debug screen.

Any help would be much appreciated. Never have been able to get the camera video to show in the camera control after putting URL in video device box for control?

If you can view the Foscam Camera in ARC PC can you also view the foscam video in the Mobile App or can you just view the video from the ez-robot camera in the Mobile App?

Any help with this issue would be much appreciated and I have read all the threads regarding Foscam IP Cameras although I have seen nothing on my particular model as it is a newer version. I bought it about 2 years ago. I have found different foscam command documents and the first script above that appears to connect was from the lattest version as far as I can tell. Thanks Again ! Rick B.



:)

#2  
Hello ptp,

This is the same as I tried without the port number. I have already tried this with no success. When leaving port number off I get a connection error 404. Any further help is much appreciated ! Rick
PRO
USA
#4  
Rick,

let's start from the begin following the manual the default http port is 88:

so if you go to a browser and open the following url:

Code:


http://192.168.17.11:88/cgi-bin/CGIProxy.fcgi?cmd=ptzMoveRight&usr=USER&pwd=PASS


first:
1) ips 192.168.x.x are private so is not a security issue if you post your camera IP
2) please change the camera password to something easy to test: e.g. password, or 123456

if you try it on a browser, what is the result, error code, error message etc.

in case of error post the URL without any change e.g. (xxx.xxx)
#5  
If this camera wasn't $80 on Amazon and didn't have bad reviews I would order one just to help figure this out. I need a new night vision camera because the cheap USB one I used to use doesn't work on any windows version higher than XP. But the company that used to provide US support for Foscam (Foscam.us) is so fed up with their business practices (and I suspect the horrible software) that they are changing their name, selling a different brand camera, and referring customers to Foscam in China or other distributors if they want help....

Alan
#6  
Hello techguru,

Actually the foscam F19831p is a great camera and was pretty cheap and works great with with my android app I have that supports this camera. I don't use the foscam app for my phone. It is also powered by +5volt supply. I suspect the bad reviews are from people that don't know what they are doing or they are using the foscam software apps. For the money I would give it a try. I may pick up another one for another application. Let me know what you think......Rick
#7  
Hello ptp,

I will give this a try soon. Have been really busy and will let you know what I find. Thanks for your continued help ! Rick
#8  
Hello ptp and techguru

Yes, before I read your post in the other thread, I discovered that it should be "usr" instead of "user".
After I changed it all is well with controlling not only the pan/tilt functions but also turning IR LEDS on and off. I have verified the following commands (cmd=):

ptzMoveLeft
ptzMoveRight
ptzMoveBottomRight
ptzMoveBottomLeft
ptzMoveTopRight
ptzMoveTopLeft
ptzMoveUp
ptzMoveDown
openInfraLed (Turns IR Leds On)
closeInfraLed (Turns IR Leds Off)
setPtzSpeed (0=slowest, 4=fastest)

There are many more commands available but these are some of the main commands. Again thanks for all of your help ! I think it would be awesome if thetechguru would come up with a plugin for this camera ! Rick


:)
#9  
@Rick

Tiny Cam Monitor is definitely better than the Foscam software. I am glad you and PTP got this working because I wound up with a huge todo list today so I might not have gotten it figured out.

I think it would be pretty easy to make a plug-in for controlling this. I'll put it high on my list (unless PTP wants to tackle it before I get there).

I think it is possible to put one of the substreams into mjpeg mode instead of snapshot mode. Might get better performance in the EZ-B camera window. It is also possible to use VLC or ffmpeg to live transcode from the h. 264 rtsp stream to an mjpeg stream.

Alan



Alan
#10  
Techguru,

That sounds awesome. It would be cool if the plugin would allow it to work with the mobile app also. Anything that would improve the speed of the video in ARC would be great ! Rick:)
#11  
Hello ptp & techguru,

I tried using the setPtzSpeed command by using the following in the HTTPGet statement but it does not appear to change the speed: cmd=setPtzSpeed=1

The speed can have a value between 0-4.
Changing the value doesn't change the speed. Is there some kind of syntax error I am missing?

Can multiple commands be included in the same HTTPGet statement?

Thanks again for all the help ! Rick:)
#12  
I'll test the setPtzSpeed command after work today. I did notice when reading the cgi commands manual that every command used by any Foscam device is there, and some are not applicable to every device, although this one seems like it should be supported by the newest top if the line devices.

You can only send one command per HTTPGet.

Note: to test any command, it is best to try it in your web browser before trying it in ARC because you will be able to see the response.

If the response is "0" then the device at least thinks the request was valid.

I don't know all of the responses (probably in the manual, but I just scanned it yesterday), but I know a "-3" is one type of failure.

Alan
#14  
Thanks techguru and ptp,

I tried cmd=setPtzSpeed&speed=4.........and it did not work. Next I tried cmd=setPtzSpeed&ptzspeed=4 and it worked. Also in the command document it says zero is the slowest speed and 4 is the highest speed. I have found just the opposite to be true. Thanks again for your help ! Rick :)
#15  
They don't make it easy when the documentation is wrong.....

Alan