Asked — Edited

Uart Wifi

Hello,

After unsuccessfully trying the UART WIFI suggested by this website, mainly because of power issues though I could have it to work and run for a little while, I tried another UART WIFI which seems much, much, much more reliable and user friendly since it has its own AP mode which allows you to configure it through web interface directly (you do not need to connect it to USB TTL module) and a quite efficient factory restoration process in case you input the wrong settings.

The model hardware name on Amazon is "Embedded Wifi To Serial Module RS232UART WIFI Board Module External Antenna"

I can get a connexion to EZB using both methods : typing directly the IP address + port into ARC's connection or through serial emulation.

However, when I use serial emulation (HW virtual serial port) I get a repeating message such as : "Disgard incoming buffer (This should never happen)"

And if I connect through IP address directly I get something really weird : it says that I have to upgrade the EZBoard firmware and, most of all, it shows different versions numbers : 24.x , 14, 17...

Here is the full debug report in cas God (DJ) took a look at it. I remember someone had ordered the same device so I'm posting this in case he found the proper settings. I set the module to 9600 bauds, TCP server mode. Let me know if you need more details.

Here is the debug report.

EZB 0: TCP Server stopped Camera Disabled

EZB 1: TCP Server stopped

EZB 2: TCP Server stopped

EZB 3: TCP Server stopped

EZB 4: TCP Server stopped

Attempting connection on 192.168.0.10:8086 Connection Failed: System.Exception: Controller Not Responding at EZ_B.EZB.Connect(String hostname, String tcpPassword, Int32 baudRate) Disconnected Attempting connection on 192.168.0.10:8086 Connection Failed: System.Exception: Controller Not Responding at EZ_B.EZB.Connect(String hostname, String tcpPassword, Int32 baudRate) Disconnected Attempting connection on 192.168.0.10:8086 Connected to 192.168.0.10:8086 EZ-B reports EZ-B Firmware V14.5 Connection Failed: System.Exception: Invalid Firmware Version. Please Upgrade. EZ-B Reports v14.5. This copy of ARC requires v16

Would you like to view the help tutorial with instructions on how to upgrade the firmware? at EZ_B.EZB.Connect(String hostname, String tcpPassword, Int32 baudRate) Disconnected Attempting connection on COM8 Connected to COM8 at 9600 EZ-B reports EZ-B Firmware V24.5 Connected Disgard incoming buffer (This should never happen) (...) Disgard incoming buffer (This should never happen) Disconnected [by user]


ARC Pro

Upgrade to ARC Pro

ARC Pro is your gateway to a community of like-minded robot enthusiasts and professionals, all united by a passion for advanced robot programming.

#1  

I have also ordered this same model. Thanks for this post. I should be receiving mine this week. Are you powering it from the EZB? (3v3 pin from the EZB) or are you using an external converter? I sure hope you manage making a stable connection. I am sure a bunch of questions will be posted with regards to your wiring (TX,RX,GND,etc.). How about photographing the EZB and WIFI UART so that we can see how you hooked it up and maybe someone will spot something.

#2  

Do you have a link to the user manual for that one? I looked at it, but was concerned that the description only mentioned RS-232 and not TTL (they are similar, but the voltages are different. If there is not a way to tell it you are using TTL, you will need an RS-232 - TTL adapter).

I ordered one from Roving Networks, which shipped yesterday and I expect to receive it on Tuesday. Quite a bit more expensive, but an excellent user guide, low power consumption, and made by a US company with real customer service.

Alan

#3  

Hello,

You'll find sofwares and documentation following this link : http://www.elfege.com/english.rar

I did not realize that I had to use a RS232 to TTL converter ! Thank you.

@Compilot : the voltage from EZB seems to work fine.

Elfege

#4  

It seems the documentation has been translated loosely from Chinese to English. Nevertheless I could make out that the voltage levels are TTL levels. (REF page 38)

#5  

Let's be honest, I'm lost. What do you mean ? Do you mean that the wifi module itself doesn't send the information through TXD and RXD in the same "language" than the EZB needs ? Does it mean that it sends RS232 signals instead of TTL ?

Concerning the voltage I had no trouble in connecting the wifi module to my network and access the web interface while powered by the 3.3v from EZB.

#6  

I received the same WiFi device from Amazon. This unit draws about 200 ma when optioned for full power. I get the same error complaint of incorrect version number and disconnect.

User-inserted image

I've used several different Uart timing settings but they all fail.

United Kingdom
#7  

I think baud rate needs to be 9600 for the EZ-B.

#8  

I had it set at 9600 when attempting connection to the EZ-B. The screen shot was just after changing it back to 57600 for connecting directly to the Roomba which it does quite well.

The EZ-B is supposed to autobaud to 9600 no matter what the connection speed is at.

I also tried setting the UART autoframe to Disabled and still got the erroneous version 8.5 & 21.0 failures.

United Kingdom
#9  

The only time I had a firmware 8.5 error was when I didn't use common ground for it's power, the tx and rx may also have been round backwards but I didn't check that out since I was only testing something out and forgot about common ground...

I have read the firmware 8.5 error can be caused by the soldered connections on the board, have you checked everything is OK on the board? Just trying to go over any possible cause really. Have you ever been successful with that board? Did it work OK on bluetooth?

The settings look fine as far as I can tell.

#10  

I tried same settings and I get all sorts of Vxx versions numbers failures depending on modifications I make to the settings.... with an EZB that works fine on bluetooth otherwise.

#11  

No matter what settings I use, the results are consistent with a "connect" message then V24.5 is displayed and a "disconnect" message. I have a ground lead connecting the WiFi battery power and the EZ-B power pack.

#12  

This is all sad news. So pretty much everyone who tried connecting this module to the EZB has failed?

#13  

It would help if it were known what data should be typed into the Box that appears when the "connect" button is clicked.

User-inserted image

United Kingdom
#14  

Isn't that for the password? At least on mine it says Enter Password in the title

#15  

I guess the question becomes "which password" the one for the WiFi Admin pages, or some unpublished password required by the EZ-B firmware.

#16  

Have you tried the default password set on the wifi module : "admin" ? I tried and this is when I had a different version error message.

United Kingdom
#17  

You may not need any password, the box comes up when connecting to another instance of ARC, which can have a password but doesn't need one. If none is used just clicking OK or cancel works.

#18  

What I disdcovered is that when any charactors are typed into that block, you get an error and the Version number changes to other versions like 4.1, 7.2, etc. I finally got one of the two WiFi boards from Amazon.com to connect by only using the virtual comm port.

User-inserted image

PRO
Synthiam
#19  

If the device is configured correctly, there is no reason why it should be an issue. The EZ-B is TTL (3 or 5 volts works). The EZ-B is not RS-232. The EZ-B will automatically adjust baud rate between 300bps and 115,200bps during connection.

By default it is recommended to use 9600 for best use of ARC control timing.

Some suggestions:

  • 9600 (not 57,600 like your screen shot)
  • Disable Local Echo
  • The "password" is only if the device you are connecting to requires one. By default it should be blank (empty)
  • 8 data bits
  • parity none
  • 1 stop bit
  • ctsrts disabled

As for the UART timing settings - I have no idea what those are. I can't even understand what they could be?

#20  

Thanks for the tips DJ, the WiFi board from Amazon.com is powered using a 3.7vdc LI-ion pack and the communication is at TTL levels not RS232. The WiFi admin page was changed to 9600, 8,N, & 1. No option for local echo and CTS, RTS were turned off. Success was achieved only by the virtual comm port.

#21  

Would you send me the name of this board or, better, a link to the amazon product ? I'm eager to finally have a wifi working on my project. Can you also let me know which port redirector you're using ? Is it HW ? If so, what are the settings you picked in the settings tab ? Thank you.

#22  

@elfege, I have the same board you discussed on the first page of this thread.

Here are the HW serial port settings:

User-inserted image

User-inserted image

Here's a pic of the WiFi board

User-inserted image

#23  

And it works through com forwarding ? You gained control of the EZB ? because I did the same... and it didn't work. I'll try again and see what I might have missed. Thank you !

#24  

Sorry to bother you again but would you send a picture of the wifi WEB app config ? Because I still get "disregard incoming buffer issue".

#26  

It's ok, it works on my side too now ! Thanks a lot.

#27  

The WiFi board seems to handle a few screens that are real time hogs.

User-inserted image

#28  

I just received my Roving Networks WiFi device, and I hope to have time to test it tonight. I'll update here with results.

Alan

#29  

Looking forward to seeing the result! Thank u for sharing

#30  

Grrr. Frustration number one is that the headers on the board are for RS-232. For TTL I am going to need to solder wires to through holes on the board. Not a big deal, but means I probably can't return it if it doesn't work for me.

Alan

#31  

I guess i need some soldering practice. I soldered the necessary wires on, and I got the board hooked up to my USB Uart and was able to communicate with it and get it configured for my network.

Moved it to the EZ-B, and I could telnet in, but could not see the EZ-B from ARC either direct or with HW virtual port. After wasting a couple of hours I went back to the USB Uart, and I could receive data, but not send any serial data. After again spending way too much time, I realized that the transmit wire was much more flexible than the other... Just before it broke off the board. (once again teaching me to always always always break out the multi-meter at the first sign of trouble, and maybe to stop trying to work on my robot late at night).

Too late to mess with it more tonight. Maybe tomorrow night, but I am getting frustrated with trying to wifi enable my EZ-B. Spent too much money for too many problems.

Alan

#32  

With the Roving Networks device, I am having the same kinds of issues (EZ-B reporting the wrong firmware, not connecting with direct TCP connection and needing the virtual comm port). I believe I know what may be causing the wrong firmware errors. When I make a Telnet connection to the device, whether or not it is connected to the EZ-B through the TTL connection, it gives its own greeting "HELLO" before connecting. I believe ARC is seeing this and mis-interpreting it. On the Roving Networks device, this greeting can be changed, but it can not be removed.

Unfortunately, despite replacing the RX wire and having good continuity, the board no longer seems to be able to receive data over TTL. It still sends, and I can connect via Telnet and interact, but neither the EZ-B serial terminal, or another serial app I have can connect through my USB UART and it seems the EZ-B is no longer able to send it data either.

I am putting this project aside for a while until I get the rest of the robot functional, and then will call the vendor to see if I broke the board or if I accidentally turned off receive or something (although I did a factory reset and it still can't receive, so I suspect another $80 down the drain, and Bluetooth is actually good enough for this bot. I only started playing with WiFi to try and help you all, and because I did want it in my second bot).

I don't think this is a total waste though because the Roving Networks device has a lot of other capabilities as a remote sensor device that I may put to use (and those functions don't need TTL).

Alan

#33  

Hello Alan, I'm sorry to hear you wasted your time and money.

Let's hope that DJ and his team will think of the following improvements :

  1. have the server option to work through port forwarding so we can connect one ARC to another one from anywhere and not only from local network.
  2. A new firmware for EZB that would allow wifi shields (I too had no one working otherwise than through serial port forwarding software : I tried 3 different modules).

Best, Elfege

United Kingdom
#34  

Server should already work over WAN if port forwarding is set up correctly. I've not tested it but in theory, if your router is set to forward traffic for port 6666 to 192.168.0.8, using your WAN IP or a DDNS service you should be able to connect in from another ARC on your LAN or over the internet.

#35  

Theretically, indeed... but I couldn't when I tried to work it arround last time. I should try again. I wonder if anyone did it already. I think it's possible only if ARC sets works as a vpn, as it is supposed to do for the http server for example.

United Kingdom
#36  

I can connect via telnet from my phone running on mobile data to my LAN over the internet which I believe is what it's based on. If it didn't work for you I would check your port forwarding options on your router.

#37  

I connect everyday to my lan over the Internet : 3 ipcam a NAT based hard drive + other features. Can you telnet your ARC's server from your Iphone ?

United Kingdom
#38  

ARC Debug window User-inserted image

Phone User-inserted image

#39  

Grrr... so what's going on in my config ? Seriously! I must have something such as firewall blocking outside coms to this LAN for certain protocols... I don't get it. It's like my ip cam that I can't connect to EZB while you can, using the same model...

#40  

Hello,

Using HW I can connect over the internet to my EZB using the SR232 module we were initially talking about. The problem came from either my ethernet adapter on my pc or from Hamachi VPN network that was running. i suggest you turn off all VPN and network adapters running on your computer and try with another adapter if you still have the buffer error message. If it still doesn't work then change the port settings in port forwarding. Another thing I did was to set a different external and internal port (not using 80 port at all) in my router for the wifi module.

United Kingdom
#41  

Remote connection from ARC (at work) to ARC (at home) works...

User-inserted image

You'll have to take my word for it that behind the black mask is my home IP

#42  

Hello,

For some reason that I still have to find out (and thanks to you I got that there's something to find out) my current network config doesn't allow me to do it that way. However the fact that I can connect through WAN IP with HW from outside is a sign that I might have had two problems, and one fixed for now, one on my network config and one coming from my ARC installation. I remembered messing up some days ago with some windows services and this could also be the cause of my other pb (JPEG stream error message that we discussed recently). On the other hand I also think it's actually more likely to be another network / router issue since this happens on all my computers. I'll look into once I have the time to do so.

@Alan : at least you know that you can connect with the module we had gotten from Amazon, now.

Thanks for your help, again;

#43  

does it take time to connect ?

United Kingdom
#44  

Not a long time at all, I was surprised at how quickly it connected to be honest.

I'd say it's a network issue, no doubt something to do with the router (it usually is, routers can be a nightmare depending on what it is). With the cameras do you use UPNP or have you manually set up the port forwarding?

Networking can be an absolute nightmare on some hardware. I made a point of changing the router my ISP gave me for something much better (I highly recommend something that can run DD-WRT firmware - Buffalo routers now come with this as standard). That said, it may be due to a VPN, I tend to avoid VPNs when possible

#45  

Excellent news about the adapter you found working. I am going to contact Roving Solutions support about mine that is no longer receiving and see if there is any warranty coverage, or if they can look at my config file and see if I somehow turned off UART receive, but at least if that is a dead end, I know what I can do when I am ready to try WiFi again.

Based on this discussion, I uninstalled Hamachi VPN (which I virtually never use anymore anyway), and it appears to have resolved a problem I have been having on my Windows 2003 server where any internet downloads were acting like it is on dial-up speeds even though I have 25 mbs FIOS. Other things besides downloads worked fine. I could even stream decent video over RDP from it.

Alan

#46  

@Rich : I use my own port forwarding for the ipcam. I'm gonna first work arround this possibility since changing the router would be frustrating since 1stly it would mean I cannot find what's really wrong while these cams work fine otherwise than with ARC and 2ndly it would be frustrating since it's an expensive a/c 200$ router that I made to myself as a christmas gift, so there's some psychology involved :).

@Alan : Have you tried to hard reset it ? I personally did it by hooking it up to an arduino board with ethernet shield and an I/O switch program accessed in browser. I could not hard reset it using logical signal from EZBoard. If my memory is good it worked only while I sent low signal for little more than 1 second to the nload pin DURING BOOT UP and then returned to high signal. But I also remember having to mess up a little bit with it before it kicked in. one Other thing (I need to double check on that but I'm almost sure) : the connection worked only by connecting TXD to TXD and RXD to RXD on the EZBoard...

Elfege

#47  

The roving networks board has a hard reset jumper, which I did use which is why I am contacting the vendor. The board is totally dead (totally my fault, so I won't be contacting the vendor.

Alan

#48  

@elfege how did you make the first connection to the card in order to set it up? I have tried setting the IP on the computer but could not make any connection.

#49  

You have to connect your computer wifi to the module. It appears as an adhoc network. You may find all details in the manual.

#50  

It was the power. For some reason I can't power it from the EZB.

#51  

@elfege Sorry to bother but could I ask you to post screenshots of all your settings in the wifi WEB app config?

#52  

Just look back in the history of this thread, there are screenshots posted already. For the power, you must power it from 3.3v port, just where the bluetooth took its power from. It works for me.

#53  

I have seen those screenshots but I must be missing something as it is not working for me. I would really appreciate a full set of screenshots so that I might easily and quickly find the issue.

#54  

What is not working exactly ? Can you access the web interface ? Have you double or even triple checked your connections ? As I said in a previous post you must connect TXD to TXD and RXD to RXD and not, as it is usually supposed to be, TXD to RXD.

Use the doc named USR-WIFI232-X-V4-en.pdf in the cd-rom provided with the device. It shows all the screenshots you need.

Best, Elfege

#55  

For info : TXD pin is the one right above the ground pin on the wifi module.

#56  

Sorry : you may need to read two docs : USR-WIFI232-start-en.pdf for the screenshots and web config ; and USR-WIFI232-X-V4-en.pdf for all technical details such as pins labels, etc.

#57  

YES! You are right! I did miss something... I neglected to change mode to STA. I can confirm it works perfectly. I think I am the 3rd person to confirm that this UART WIFI module works with the EZB. I have purchased this unit from EBAY for $32: http://www.ebay.com/itm/221209202883?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649

Thanks elfege! and thank you Robot-Doc for the HW serial port settings.

#58  

Just a question of curiousity : did you also have to connect TXD to TXD and RXD to RXD ?

#59  

@elfege YES! I did! RX to RX, TX to TX. But that was not my issue. I could not connect to the unit once it was connected to my network... and the issue was that I did not switch it to STA and kept it on AP. Once it was on STA I could easily connect to it. When I saw an error I tried switching between the RX and TX.

#60  

Indeed, as long as you had not set the STA mode you could not use the server mode through your router. I just wanted to make sure that my serial connection was not due to a singularity of my EZB. Thanks for the answer. Happy you could connect through wifi. By the way, you can now connect any remote computer with ARC and HW virtual serial port installed, provided that you set up your port forwarding properly. Don't forget to set a different port number on external and internal ports.

#61  

It looks like Roving Networks is going to replace my device, but given that it is twice the cost of the one now being discussed in this thread, and a good bit more complicated to set up (if it will work at all for this use, which I have not yet shown) I am not going to recommend it as an EZ-B solution. I will be ordering one of the ones discussed here for my WiFi robot needs and use the Roving Networks device for another project. It supports connection to several sensor devices and can auto-sleep, wake up and deliver sensor data via web or ftp and then go back to sleep, so there are a bunch of ideas I have for it.

Alan