Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
United Kingdom
Asked — Edited

Trouble Connecting 2 Ezb's

I'm trying to connect two v4's in one project, but no dice. I know someone had this trouble before, but can't find the thread.

They are both set to client mode, and the both connect individually. I've...

Reset the router,
Turned off firewalls,
Restarted EZ Builder,
Restarted my PC,
Disabled antivirus
and batteries are fully charged,

but none of that makes any difference. I have one board connecting to #0 and the other on #2. When I run a board search, only one will show up which I think is the last one that successfully connected. When I kill the power to one of the v4's, the other connects fine. As some of you probably know, I'm no networking expert by any stretch of the imagination, but I'm sure I've done right.

Any help would really be appreciated with solving this.

United Kingdom
#10  
Thanks Richard.

I just tried it again but still no joy. Funny, my router won't let me change the third set of numbers (mine being "0" and yours "255"). Don't know if that makes any difference. And I just realised what I said about "one board in client and another in AP", which wouldn't work anyway. This is a royal pain in the butt.

I guess it's back to the SSC then.
PRO
Belgium
#11  
if you connect one on number 0 and the other on 2 it worked for me
United Kingdom
#12  
@nomad.

That's exactly what I tried (mentioned in post #1) as I remember a post you made a while back saying as much.

Thanks anyway.
#13  

Quote:

They have 192.168.0.3 and 192.168.0.18 but the same thing happens,


make one of them 192.168.0.2 and the other 192.168.0.3. Always start the one with 192.168.0.2 first. don't use the EZ-B search, just type 192.168.0.3 for the second one. As long as the first board is "2" whether your router responds first, or the first EZ-B responds first, the second one will be "3".

(the 3rd octet that you can't change would be changed in a different place in the router. Every device on the router needs the same 1st three octets -called the subnet- no need to change it though).

Note: you can have on in client and one in AP and still have internet access, but you need 2 wireless adapters in your computer and they can't be on the same subnet. Since your router is on the 192.168.0.x subnet and the EZ-B in AP mode is on 192.168.1.x, that would not be an issue.

Alan
United Kingdom
#14  
I tried changing the last numbers to 100 and 200 and connected as you mentioned above, but the same problem persisted.

I also set one board back to AP but I was still unable to connect it to ARC, with the same "timed out" error showing. I'll try your advice again tomorrow with a clear head and see if I have any better luck.

Thanks again Alan.
United Kingdom
#15  
So I tried again this morning following Alan's steps. I changed the IP reservations for both boards to .2 and .3 and nether connected. I then changed the reservation ip for board one so the v4's IP was 192.168.0.20, run a ping test which returned the correct info. I connected it to ARC and that was fine.

I then powered up the second board, changed the IP to 192.168.0.30 and ran the ping test again for the new IP, and got the following results (both boards saying that they "are now connected to your network")...

User-inserted image


I'm not at a loss of what to do now. Is there anyone else using a Virgin media Superhub 2 with multiple boards who can help?

I'm thankful for the help offered to me so far, but I'd also appreciate some input from EZ robot on this, as it really shouldn't be this difficault to connect multiple boards. I'm now aware that there is a bug that Alan mentioned, but other people are managing to connect more than one v4 to their projects and I also know of members who have had trouble too, and as I mentioned, I know little about networking and routers. This reminds me of the trouble I had connecting a HP computer to an EZ-B when I first started.

Steve.
#16  
@steve,

i rode your post, but i must say i only know FritzBox or Netgear Routers.

But also a "Virgin media Superhub 2" must have a webinterface (like 192.168.1.1)
and there mustbe wlan or Lan Settings.

And there normaly you can "add" new periphery. Normaly must open a popup window where you can fill in the data you want.


User-inserted image



Then you go to the ARC and search for this two EZB4

(First you must connect the EZB4 Controller to new WLAN Net, but i think this you already have done)
United Kingdom
#17  
Thanks for the reply Boris.

I think what you're refering to is the "Add Reservation" as it's called on the Superhub 2. That is where I enter the data such as a divice name, MAC address, and enter or change the IP address, similar to your screen shot. Unfortunately this didn't work for me.
#18  
@Steve


another test:

if your EZB4 (no1) has 192.168.0.30 (and is connected to your WLAN) so write to your Internet-Explorer this Adress. If you see the EZB WebInterface is ok!

if your EZB4 (no2) has 192.168.0.31 (and is connected to your WLAN) so write to your Internet-Explorer this Adress. If you see the EZB WebInterface is ok!

If you see all two Web Interfaces, the EZB4 are correct connected to yur WLAN.

Boris

PS:

Then the problem must be somewhere else
PRO
Canada
#19  
Hey @Steve G,

I have done some tests with different router brands but I've never had access to a Virgin media router. Personally I've had lots of success with D-link routers.

One thing to keeping in mind is radio interference between ez-b's, you'll want to keep them at least a couple feet apart when pinging for them.
United Kingdom
#20  
(This should be post #22, but the post have jumped out of order.)

Thanks for the reply Jeremie, I appreciate it.

With the amount of routers available on the market, I get why haven't tried a virgin hub. I have to say though, I'm not about to purchase a new router just to fix this issue as I hope you'll agree, I really shouldn't have to.

The distance between boards is interesting though. With different IP's, I wouldn't of though that would have made a difference. I'll have to give that a try.
United Kingdom
#21  
I think I did it right. Both boards are showing up, but still only one or the other v4 returns a ping result and connects to one project. I'm now at a loss of what to do now so I've ditched using the second board and going to use an SSC32 controller instead as I have been delayed enough, I've got rather fed up with trying different ways of getting these two to work together, resetting my router multiple times (quite time consuming and a pain), and not wanting to risk changing any other router settings as like I've said already, networking is not a strong point for me.

Im really not happy about this as it really should not be this difficault to achieve. The way I see it, not everyone (including myself) is well versed in networking, and shouldn't have to go through all this just to connect multiple v4's to one project which ARC is made to do. It's great that some don't have an issue using more than one board, but for the rest of us, it's a pain in the neck to say the least.

I'm still on the look out for a solution to this, but for now I just want to say a huge thanks to Alan, Richard, and Boris for you help. I am greatful even if it didn't sound like it in previous posts here. I'd still like some kind of input from the EZ Robot guys to hear their thoughts to why I'm having hear problems.
#22  
@Steve, my router cost me $34 (CAD).... It's a dlink and works perfectly.... I had connection issues in the past but my dlink fixed them all... Anyway, we're all basically playing with toys here (that we call robots)... no need to get so worked up about it. It's just a hobby for most of us... Have a beer and chill...
United Kingdom
#23  
You are right Richard, it is a hobby for me too, and something I like to do and enjoy to help take my mind off the stress of every day life I seem to be going through recently. It's just frustrating when something such as this issue, that should be seeming simple, doesn't work the way it should, and frustrates me more when I spend hours troubleshooting without a solution which ends up being not so much fun as it should be.

I still refuse to get another router for now at least just for this problem on princible, even if there are others that may be better and reasonably priced. It's enough that I had to buy a new laptop just so I could use AP mode on occasions due to the HP wireless adapter issue which I know is not ezrobots fault. I don't have a such disposable income now that I used to due to having to give up work for family reasons, and I've spent quite enough getting stuff for my latest project as it is.

Anyway, I (as always) appreciate your and the others help and advice, and I'll keep checking if a solution presents itself for this topic.

Cheers "Clink!". ;)
#25  
@Steve.... Remember there is always a workaround.... Most of my good ideas came from dead ends and a nap believe it or not.... I either break something or get frustrated because something I think I need badly doesn't work.... I lay down for a nap or just take a break and out of nowhere I get an even better idea.... Here's the thing... I wouldn't have come up with a better idea if I didn't hit a wall in the first place... The cliche is... "One door closes, another one opens..."
#26  
@Steve, I feel your pain. Before my ISP replaced my router a couple of weeks ago with one that responds very fast to DHCP requests, I actually had 3 routers in my network. My ISP's router, which I disabled WiFi on because it didn't support current security standards or high speed. Then plugged into that, two wireless routers.

One was my main network for all my computers (192.168.1.x subnet) and the other just for EZ-B's (192.168.0.x). I added route tables so the routers could see each other so a computer on the 192.168.1.x subnet could see the EZ-Bs on teh 192.168.0.x subnet.

The EZ-B router was a travel router powered by USB, so I could unplug it and take it with me if I travelled with my robots and not need to reset them to AP mode or connect them to different networks (I still have it configured with the same credentials as the main router for just this reason, but it is unplugged now).

I still needed to start the EZ-B's in the right order because once one was running, it would hand out IP addresses to the additional EZ-B's, but it was consistent. If EZ-B-1 was 192.168.0.2, then the next EZ-B to start would get 192.168.0.3, the next would get 192.168.0.4, etc.... (I traded my additional ones for wheelchair motors, so just have two now).

If you were in the US so that shipping wouldn't be an issue, I would send you a router that I know works this way, since I have ended up with several spares (I am an occasional Beta tester for one of the router companies). They all are slow to hand out addresses, so don't mask the EZ-B DHCP problem, but they do work with the workaround I described.

Alan
United Kingdom
#27  
@Richard.

I'm usually the same in regards to having a beer, sleeping on it and getting new ideas. It's just over the past couple of days, I've been fresh out of them (ideas that is, not beers). Anyway I'm in a better frame of mind today and hooked up my SSC and scripted some of my servos thanks to your tutorial, so I'm kinda back on track.

@Alan.

That would have been a very kind offer and I really do appreciate the thought. Thank you.

I'm sure one day I'll get around the multiple board issue and may even consider getting a replacement or additional router for future projects that will use more than one v4.
#28  

Quote:

I'm sure one day I'll get around the multiple board issue and may even consider getting a replacement or additional router for future projects that will use more than one v4.


I am still hoping that DJ gets a solution from the WiFi board manufacturer, and one that can be done without replacing the board. it should just be a command (technically, it should know to turn off DHCP when given the command to go into client mode, but there are reasons for having a DHCP server on a device other than the router, so it is probably configurable).

Alan
United Kingdom
#29  
@Alan.

Same here. I hope that a solution presents itself form the manufacture soon. I'm certainly not getting a new router any time soon just for this. Only if I need a new one for some other reason as well.