Hong Kong
Asked — Edited

The Question Happened While Creating My Second Plug-In

Hello everyone.

I am kind of frustrated because of this problem. So please forgive me if it turns out to be a stupid question. :)

Yesterday I followed the plug-in tutorial and successfully made my first unpublished plug-in. It could be tested in the ARC , and everything was good.

Today, I have started to create another plug-in. Try to make a plug-in for my own purpose. I think I have carefully followed and checked what the tutorial asked me to do. The class library could be compiled and built with no error.

Then I started debugging. The ARC popped up as expected. However, I could not find my second plug-in in "Beta" or "Plug-in" category in "Add" in ARC. Why? There was only the first plug-in made yesterday. I spent my whole afternoon checking and still had no clue.

Could anyone kindly help me for this issue?


Upgrade to ARC Pro

Stay on the cutting edge of robotics with ARC Pro, guaranteeing that your robot is always ahead of the game.

Hong Kong

Moreover, I just downloaded the zip file of the example plugin from DJ's tutorial. I loaded it and started debugging.

I still only have the first plug-in that I have created. What prevents me from seeing the new plug-in that I have created?

I am very confused now.


I suspect it has something to do with these two steps in the plugin tutorial:

  1. Edit the plugin.xml to ensure it has the friendly name, description, dll filename, version and GUID of your plugin
  2. Specify the compiled output folder of your project to the ARC skill plugin folder and the name of the GUID

Each plugin needs to internally have a different name and GUID.



The plugin tutorial has trouble shooting, please check it here: https://synthiam.com/Tutorials/UserTutorials/146/11

Hong Kong


Hello Alan.

The problem still not solved.

I think I have succesfully followed the two steps that you mentioned.

Here is the screenshot for my xml configuration:

User-inserted image

The following is my output path setup: C:\Users\Public\Documents\EZ-Builder\Plugins\05c8047e-09c0-40cc-a914-8eb20c76a252

And I have found corresponding dll file, pdb file and xml file generated in that folder.

However, I have noticed the followng messages popping up while debugging the project:

Could not find schema information for element 'PluginV1XML' Could not find schema information for element 'DLL_FILENAME' Could not find schema information for element 'AUTHOR_NAME' etc...

Could anyone help me with my problem?



The tutorial can be found here: https://synthiam.com/Tutorials/UserTutorials/146/1

The plugin filename must be plugin.xml not "humidity plugin.xml"

I would recommend following the tutorial when creating a plugin. Filenames are important because if the filename is a random name, there's no way for the software to know what it is.