Asked — Edited
Resolved Resolved by Rich!


I'm having some problems figuring out how to get the soundservo (EZB) to work. I've got soundboard (EZB) working well. I plugged in a servo to a port and opened up the soundservo menu. I can hear/ see the servo go as I adjust the min/max settings, but when I play a sound from the soundboard area, nothing happens. Is there something else I need to do?

Also, on a separate note, is there a way to always have the same IP address set for the EZB? I had to search again and it also reset the low battery warning, which I wish I could keep turned off.




Upgrade to ARC Pro

ARC Pro will give you immediate updates and new features needed to unleash your robot's potential!

United Kingdom

To give the EZ-B a static IP you need to set it in your router settings. This will vary for every different router available.

There is nothing special that you need to do for the sound servo control other than possibly play around with the settings to make sure it picks up the sound and moves enough (or not too much) for the sound.


Thanks. I've played around with the update speed and scalar, but nothing happens. I was thinking that if I press play on a soundboard (EZB) sound, and I hear it ok, it'd trigger things in soundservo to move the servo around. Is that how it's supposed to work? If so, is there a way to troubleshoot this further?

thanks again,


United Kingdom

Sound servo works on volume. The louder the sound the more the servo moves.

Add the variable watcher control and check the value of the $Soundv4Value (or whatever you may have renamed the variable if you have altered the settings). You should see it moving if there is any sound detected.


Thanks. It turns out that soundservo doesn't do well with my short 4-5 second speech sounds (it did well with longer clips, particularly the one with near constant beeping/ computer-ish noise). I also found that the voulme needs to be set just right at the soundboard.

I'd really like to get it to work for a short sentence / phrase, but so far I can only get a little movement at the beginning of the phrase. I'm guessing that scalar controls the amount of servo movement, but there doesn't seem to be a sensitivity setting-- you have to turn the volume up. If there is on sensitivity setting, this would be good to add in a future update.