Welcome to Synthiam!

Program robots using technologies created by industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation, and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Dunning-Kruger!

Scripting Ezb V. 3

I have been attempting to get back up to speed using the EZB,V.3 controller. I am making no head way unfortunately. I have tried the following simple script:
Servo(D0,50)
ServoSpeed(D0,5)
Sleep(2000)
Servo(D0,10)
Sleep(2000)
Servo(D0,50)
Sleep(2000)
Servo(D0,90) (Note: script stops here!)
Sleep(2000)
Servo(D0,50)
Release(D0)

I am connecting with the EZB, on COM Port 3
It does indicate that it is connected.
I am using Windows 8, O.S.
I added a horizontal servo on D0
Min. is set to 10
Max is set to 90
Clicking on CENTER does center the servo.


I have tried different ports as well as rewriting the script.
Is there something simple I am missing?
Any assistance will be appreciated.
Lloyd


ARC Pro

Upgrade to ARC Pro

Synthiam ARC Pro is a cool new tool that will help unleash your creativity with programming robots in just seconds!

#1  
Does the servo move at all? Is the led light on the V3 solid or flashing? Remember, If you set you min to 10 and your max to 90 then the servo will centre at 50... For the ezb3 the min is 1 and the max is 100... so centre is still 50... for the EZB4 min is 1 and max is 180... so centre for the V4 is 90...
#2  
I had a similar issue using an EZB(4). I could not get the script to run more than once, "until" I deleted the Release command.
#3  
Yep, Doc is right... The release does do that... I know there is probably a reason, I just never got around to asking why it happens... In order to get my servos moving again I had to reset speed to 0 then set a position for the servo after that... But if I use release I have to reset again...
#4  
Thank you both, Doc and Richard, Deleting the "Release" command did the trick. I can now proceed with the script. It would be interesting to discover why the release command causes the problem. I'm sure DJ would know. Thanks again gentlemen,
Lloyd