Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
United Kingdom
Asked — Edited

Screen Resolution Question

I have just bought a Surface Pro 4 and have been trying all afternoon to set up ARC but just cannot get the resolution to look right - I tried dozens of settings, but all I get is bunched up text as jpeg below.

User-inserted image


I have had big screen resolution problems before on my Windows 7 Asus slate tablet which also never worked properly with EZ-Builder, is it just me or is there a problem with the way ARC handles screen resolution?

If anyone can help it would be greatly appreciated!

Tony

#14  
User-inserted image


This panel the vertical size of the listbox followed the borders but the horizontal size did not. They are not anchored correctly.


User-inserted image


This panel even the vertical size isn't anchored properly.
Please can't someone in the software fix this simple problem?
#15  
Is it safe to say Tony opened a can of worms here? :P
PRO
Synthiam
#16  
Everyone, please follow the setup tutorial mentioned in this post as the instructions are clear. Set resolution to 1080p and configure text size to 100% or 125% but no higher.

Again, the link is: http://www.ez-robot.com/Tutorials/Help.aspx?id=207

It can also be found by clicking ARC manual on the download page.

@billPlays, your usage log resolution reads: 3840x2160 (96x96 dpi), which is not recommended for ARC. Please use the following link to configure the display settings for ARC: http://www.ez-robot.com/Tutorials/Help.aspx?id=207

@Dave, you will find the instructions (http://www.ez-robot.com/Tutorials/Help.aspx?id=207) mention how rebooting is necessary.
#17  
Yep. Did the trick for me. I guess the secret is to follow directions to set up your system for ARC. That and having a system that falls into spec of what ARC is made to run on.
PRO
Synthiam
#18  
Any computer manufactured in the last 10-12 years will be able to run the minimum resolution specified for ARC in the instructions located here: http://www.ez-robot.com/Tutorials/Help.aspx?id=207

The challenge isn't resolution when you have older PCs... the challenge is operating system at that point. Anything below Windows 7 is not supported.
United Kingdom
#19  
ARC and Surface Pro 4 do not get along with each other!

DJ, I carried out the tutorial to the letter

I first tried the tutorial recommendation of 1920 x 1080 text size 125% then rebooted - same problem top lost

I then tried 1920 x 1080 text size 100% then rebooted - same problem top lost

I then tried 1024 x 768, 1152 x 864, 1280 x 600, 1280 x 720, 1280 x 768, 1280 x 800, 1280 x 960, 1280 x 1024 - same problem!

I then tried Daves 1600 x 900 text size 125% then rebooted - same problem top lost

I then tried 1600 x 900 text size 100% then rebooted - same problem top lost

I then tried other settings and none work.

I am absolutely gutted, I have a major ALTAIR robot presentation next week so I bought a grands worth of tablet which would be nice and easy to transport - now I am going to have to strip down one of my main PCs and large monitor to be able to do the presentation. My main Windows 10 PC has no problem with the ARC software everything works as it should, it obviously just does not like tablets!

Why the heck is ARC software so hard to use! It (to me) is really sad that such a great product is being let down by this sometimes seemingly unusable software. I am now very disillusioned!

Tony
#20  
Tony,

I am at work where I have Windows 7, so I can't give specific instructions, but Windows 10 has a "Tablet" mode and, when a keyboard is attached (can be Bluetooth), a "Desktop" mode. Have you tried changing to desktop mode?

Windows does all kinds of strange formatting things in tablet mode, and it may be related.

(I don't disagree that only ARC seems to have these formatting issues with Windows 10 at different resolutions. I have dozens, if not hundreds of different apps, and the only one I need to be particular about my screen settings to get to work correctly is ARC. Some may not look good at full screen, but all will work fine in windowed mode, if a little small.... Sorry DJ, but I think you need to stop blaming Microsoft and start looking at the ARC framework and fix this. As more of us get high resolution portable devices, it is only going to get worse).

Alan
United Kingdom
#21  
Thanks Alan, you help and advice is much appreciated on this.

I agree DJ should stop blaming Microsoft, I see this problem as a big flaw in ARC - seriously if I had not invested years of work with EZ-Robot this would have made me give up on the whole idea of using ARC!

I have spent 2 days trying to get EZ-Robot to work on the Surface Pro with no luck - I thought it was supposed to be easy robot, well it seems that it is not very easy to get it to work on tablets.

Tony
PRO
Synthiam
#22  
The top having blank space with arrange controls is a known issue that I have been struggling to fix since the beginning. If it was that easy, it would be done. This is due to the Control model of ARC by having each control in a window within a window and having a scroll bar. The closest solution I can find per documentation is to disable the scroll bar and force virtual desktops. That isn't an ideal solution but it may be the last hope.

In your current situation, using the virtual desktops is the best option. Right click on the headers of each control and move them to virtual desktops.

As for your original topic, which is font sizing. Please follow the tutorial to adjust font sizing here: http://www.ez-robot.com/Tutorials/Help.aspx?id=207

The font sizing adjusts the size of the text in Windows. Each software application on your computer has space allocated for text. If the font size is increased, the space allocated for the text doesn't fit. This is not an issue limited to ARC and no additional development will be allocated to supporting 150% font size because it will affect those using 100% and 125% font sizing.

The font sizing can be resolved by following the tutorial here: http://www.ez-robot.com/Tutorials/Help.aspx?id=207

If you purchase a tablet or PC that has 150% font sizing, simply follow the instructions to change the font size to 100% or 125%
United Kingdom
#23  
DJ, please fully read my post #20 - I have done everything over and over from the tutorial http://www.ez-robot.com/Tutorials/Help.aspx?id=207, so the tutorial obviously does not work for a Surface Pro.

As I also explained in the post, I have tried all the permutations of font sizes (100%, 125% etc) for all the screen resolutions and all this has made absolutely no difference!

Tony
PRO
Synthiam
#24  
The issue i read in post #20 is there is spacing on the workspace above controls, is this correct?
United Kingdom
#25  
As soon as I save the project and reload, the top controls all all lost (like the connect window etc) the right sidebar does not allow the top controls to be enabled/seen. The only way round this is to auto-arrange then the whole thing comes back but with the window/controls all messed up. Saving this again and the whole process starts over where when loading back the top is gone again.
PRO
Synthiam
#26  
Please read responses in entirety.

The situation that you are experiencing with the top spacing can be resolved using Virtual Desktops. Right click on the header of controls and move them to a different desktop.
United Kingdom
#27  
This just goes from bad to worse - moved all the controls over to Virtual Desktop 2 and still same errors/malfunction with the top disappearing - tried all the suggested screen resolutions and font sizes. In my humble opinion, no decent software should put users through unending loops like this!

I am going to give up on it now, I cannot waste any more time trying to get this to work, because until its fixed I personally do not believe that the Surface Pro will ever work with ARC.

Tony
PRO
Synthiam
#28  
EZ-Robot has education customers using Surface Pro tablets with ARC successfully, so I have faith there is a solution if you are willing to continue working on solving the issue?

Can you provide me with an updated screenshot of both Virtual Desktop #1 and Virtual Desktop #2?

Also, is there a way I can get access to your project to test with?

I do not have a Surface Pro to fully test with - but I'm hoping that settings in the Windows OS should be able to resolve any screen rendering issues on any hardware. I am limited to having access to only a handful of computing devices for testing.
#29  
Tony, before you leave could you answer one question? When you're controls dissappear does it look like my screen shot I'm my post #14? I'll lose 1/2 my controls until I do a smart arrange. This happens on screen 2 when I reload.
PRO
Synthiam
#32  
Don't thank me yet, it may not work for you. It's a battle I'm been fighting for 5 years
United Kingdom
#33  
DJ, I tried the update and initially it looked good as the project came in ok with the top part showing correctly. I then saved the project then loaded it again and the top part was still there so I thought the problem was solved. I then tried to move one of the controls to below the lower controls shown on the display, once this is done the whole problem starts again as if you then save and load again the top part has gone again presumably under the menu bar. So with this version everything is better until you add any new windows/controls that expands the screen.

Dave, it is exactly as your post#14 the top controls look to be being pushed under the menu bar.

Tony