Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Australia
Asked — Edited

Sabertooth Red Error Light

I seem to be having trouble with one of my Sabertooth/kangaroo motor controllers. The red error light is on and the the motor will not work. Up until now it has been working fine. I suspect what may have happened, (not sure if this is a thing or not), I had the motor/encoder unplugged from the sabertooth and had run the initiation script while testing other things on the robot. I have tried re-auto tuning but this does not help. How do I reset the red error light? Everything seems to be connected. I cant see an obvious reason for it not to work.

Steve


ARC Pro

Upgrade to ARC Pro

Unleash your creativity with the power of easy robot programming using Synthiam ARC Pro

AI Support Bot
Related Content
Synthiam
#1  
The red light comes on for a couple of reasons... one is if you are trying to pull more current than the sabertooth can provide. If your motro(s) pull too much current the sabertooth will shut down and the led will flash red...
Australia
#2  
Load isn't the problem. Its a 2x12 Sabertooth and the motor draws only a couple of amps. The red light is on as soon as I turn on the power. I don't even get a chance to run the motor
#3  
Doesn't have to be the motor causing the over current. It could be a short in your wiring causing the sabertooth to shutdown?... If not maybe the sabertooth has "given up the ghost"? Re check your wiring... disconnect the motor leads at the sabertooth side and see if the red light goes out or not...
Australia
#4  
I have unplugged the motor and the red light is still on *stress*
Australia
#5  
Okay now I'm even more depressed, I have absolutely nothing connected to the Sabertooth except for the 12 volt supply..... Red light remains. I then removed the Kangaroo in case that was causing the issue........... red light still comes on. *tired*
I'm thinking the Sabertooth has met its maker
#6  
Magic Smoke ... The great Sabertooth spirit has left the building.
#7  
Steve, it very hard to kill the Tooth. You may still be ok. Recheck all the dip settings on the Sabertooth and the Roo. I once hooked up a Roo without setting the Tooth's dips and got a solid red led. Taking the roo off with the dips set a certain way may cause a red led also but I'm not sure.

Also make sure your motor is working and not damaged, recheck all your wiring and connections. Without a complete and working circuit you may also get a red led. Did you accidentally swop the input power input wires? That will kill your Tooth dead.

Hope you find the issue. If we lived closer I'd send you a new 2x12 Tooth. I've got 6 new one's sitting here that I never used because I upgraded to the 2x32. I wanted to get away from having to use the dump battery for the regeneration power off of the tooth.
Australia
#8  
Well it seems I've managed to make something hard to do look easy.... but not in a good way.

I have checked all the wiring and there is no shorts. I have taken the radar off and run the motor with a battery, that works fine. The motor is rated at 5 amps stall current and 0.3 amps free run when supplied with 12 volts. I tested it with a 6 volt battery and it drew about 0.3 to 0.4 amps while turning the radar for load. The Sabertooth is rated for 12 amps and 25 amps peak so that motor load is well within its capabilities.

Whats strangest is the radar motor has been working fine for a while, I got a good tune first shot, set the ramping parameters with the Dimension Engineering software, and it was working great. I haven't touched the connections to the motor or the sabertooth, It simply just stopped working.

I don't know if this could have caused the problem, but I have just tested the battery I use for dumping the re-gen power into. Its a sealed lead 12 volt battery. I just measured it and it's only putting out 5.5 volts, so along with the Sabertooth, it seems this battery is also buggered... (an Australian term for not working, or stuffed,....another Australian term with the same meaning). Could this buggered battery have caused the death of my Sabertooth?

This "buggered" battery is there for dumping re-gen power from the radar motor and the bubble lifter linear actuator. I have another battery the same in the leg section for the sabertooth that runs the waist motor. I have three Saberteeth in total (I think that's the plural of Sabertooth ;)) The other battery is measured at about 11.5 volts at the moment. If the dump battery IS in fact the cause of the problem, I'm thinking I might have to upgrade all three Saberteeth to the 2x32 and use a resistor for the re-gen power to avoid future issues.

One question, If I do upgrade the Saberteeth, and re-use the existing Kangaroos, will they all need another auto tune?

Steve
#9  
The other battery is 11.5V? If they are SLA batteries then if you don't charge this battery soon you're going to lose it too... Have you not been periodically charging these sla's? ..They are not going to get charged from power occasionally being dumped back into them... which by the way is not very much anyway...
Australia
#10  
The battery's are connected in parallel with the 12 volt power supply, so whenever the robot is turned on, I presumed the battery's should be charging. I must admit though I don't know much about battery's and how they should be charged. Maybe this set up will not work with regards to battery life.

I should also point out that I have connected the battery's and the power supply using Dave's MOSFET and Diode circuit so the Sabertooth is not back fed by the battery when the robot is switched off thus draining the battery and still allows a path back to the battery for re-gen voltage if the motor is rotated while off.

If I upgrade to the 2x32 Sabertooth I can forget about the battery's.

Steve
#11  
Power supplies are not battery chargers... You need a proper SLA battery charger...
Australia
#12  
So is the failed battery the likely cause of the sabertooth failure?
#13  
Not sure, but I do know your battery died from the lack of charging....
Australia
#14  
Do you know if I replace the Saberteeth and reuse the already tuned Kangaroos if I will need to redo the auto tunes?
#15  
Hi Steve, What an odd issue.

I can say this, I've had this same setup in the leg section in my B9 with a 12v SLA battery for the past few years in my leg section and have never charged it. It's charge level stays at about 11v and I have no issues. Before I switched over to the 2x32 sabertooth in the torso section I also was running this setup for a long while with no issues. I never charged them and they stayed about 11v by just receiving the regen power from the Sabertooth.

With that said, RR is right about SLA'a needing to be charged. Lead acid batteries must always be stored in a fully charged state and be periodically recharged even when not in use. Leaving them discharged is a sure way to ruin them. Continuous over charging or under charging is the worst thing for a SLA battery. It's possible in this setup that you overcharged this battery. However like like rr said there is really very little Regen power going back into the battery. Again, how much is to much?

Now, we'er not talking bout discharged batteries here. You "are" charging them and if your other circuit and my setup is any comparison to go by the level should stay about 11v on a 12v battery. This has been a constant in my system for years now and I've never had a battery fail. I'm not sure that just one volt low or high will really make a big difference in the battery life (but I'm not 100% sure). I would say there is more risk of overcharging in this system.

Also, something else to keep in mind when thinking this through. There's a lot of talk now everywhere and on this forum about LIPO batteries. Don't confuse the two. SLA's don't have the same issues as LIPO' s when you discharge them. With LIPO's they certainly die when you drop below a certain level. This is not an issue if you kill a SLA once on a while. I cant tell you how many times I've had to jump start a completely dead car battery that's been drained from the cold or a short somewhere in the car and have it last for years after that.

I really think you have something else going on here that has nothing to do with discharged batteries. If this was a undercharging issue I'd think the battery would fail over a longer period of time. The flag for me is that you have a very low voltage reading on your SLA. The other SLA in your other system is preforming nicely and has been. Here's my thoughts on possible causes:

*You battery just failed on it's own. This happens. Do you have a battery store near you? We have them here (Batteries Plus) and they gladly test suspected failed for you and give advise. If you end up getting a new battery make sure it's got a "minimum" capacity of at least 1.3Ah.
*If the battery has failed (or even if it can be saved) it could have been caused by a short. I know you said you checked for this but what about the cutoff circuit you built? Could something in that be shorted or have a failed part?
*The Sabertooth failed on it's own. I've been reading posts from people that have recently had one fail. Unless you accidentally shorted out the power input I don't think there is anything your little setup could do to kill this tank of a controller. It protects it's self pretty well.
*The Kangaroo failed. Same as above. Just a note and question here; Do you have 5v feeding "into" the 5v port on the control side of the Roo? This is a 5v "out" port and you'll kill the Roo if you feed power "into" this port.
*There is something shorted in your circuit or power supply. Battery, homemade shutoff circuit, wiring, power supply, Sabertooth, Kangaroo. Dont forget to check the wiring between the Roo and the EZB.

Try removing or replacing parts of your setup to see if you can get the red led to go off. I'd start by making sure everything in the circuit is attached and ready then :
*Removing the homemade shutoff.
*Replace or remove the battery.
*Move the Roo then Sabertooth one at a time to the working circuit. When you move the Roo and attach it to the other Sabertooth did it's LED turn red? When you move the Sabertooth in question to the new circuit does it's red led go off? When you attach a known working Roo to the Sabertooth in question does the red LED got off? Be advised that when swapping around devices that may be bad you may cause damage to something in the working circuit. However because of the nature of this circuit and the protection built into the Roo & Tooth I think this is unlikely. Still if the red led comes on when it shouldn't remove power as soon as possible.
*Try running the Sabertooth without the Roo attached. You may need to place the dip switches in the proper setting.

In the long run I would advise replacing all your Saberteethes 2x12 with the 2x32's. I loved being able to remove the SAL's and not have to worry about things like what your going through, a failed battery down the road or ever an acid leak. Running a power resistor across the power input/output of the 2x32 as a voltage clamp was so much cleaner and less hassle. The hardest part was finding the proper value to use. That was more or less trial an error. :)

EDIT: One more thing to answer your question; I've found when ever you change anything including adding a different Sabertooth you need to do a re-tune of the roo. This may not be the case if you swap out like for like between 2x12's. My experience was when I upgraded to the 2x32. I'd advise to see if your motor is acting as it should after the swap and before you re-tune. You might get lucky. I never did though.

Good luck ad have fun!;)
#16  
Standard charge level for a healthy 12V sla is between 12.4V and 12.6V... 11V is too low... eventually it will croak from not being charge as opposed to old age... If you don't believe me Google it...
#17  
I never said I did't believe you RR. Don't be so sensitive. I actually said in my post that I'm not 100% sure if only 1 volt would be a battery killer. I'm not a battery guy. I did google before I answered the first time just to be sure and there is some question here. I've seen some real heated discussions on this subject. Seems in the end that 1 volt is the drop off point and anything below there and the battery will die quickly. Multiple trips below this level will shorten life faster.

OK, let's say at 11v we can assume the battery is empty. If it's just empty the red LED should't be on because Steve's still feeding the circuit with a 12v power supply. I guess it's possible if the battery is hosed and shorted on the inside or if the bad battery is sucking all the available power from the Sabertooth and creating a brown out.

This is why I suggested first removing the battery from the circuit to see if the red led goes out. If this is the cause I still think the Sabertooth will be OK and not damaged. If the Sabertooth is bad I don't think a low voltage on the battery is what caused it.

I still cant get past the fact that I've been running this setup for years with three Sabertooth's and with their own dump batteries and have never had this issue. Maybe it's because I have better quality batteries then Steve. Maybe it's something else. I don't know, that's why troubleshoot methods need to be preformed. I've also measured my dump battery voltage levels many times that are in parallel with the power supplies after the robot has been powered up and after the Sabertooth was doing it's thing. After power down my battery level is always 12v. I'm not saying this is the right way to charge a battery. I'm just stating what I personally found in real life.

I still feel Steve has something else going on here. It could be something as simple as a bad battery that just puked on it's own. It could be something more sinister. He should check out the other parts of the circuit just to be sure. In the end I still feel (if people can afford it) that it's best to use the 2X32 Sabertooth set up with a voltage choke when you want to supply power with a AC to DC power supply and be done with all this.
Australia
#18  
Hi Dave & Richard,

Thanks Guys for all you're input with this problem.
Dave, I have tried some of the things you suggested already, but not transferring known working parts to see if the problem follows or disappears, I guess for fear of damaging other working components. With the Roo, I don't have any connection to the 5V terminal, only Ground, S1 & S2 to the EZB. I didn't think however of the home made battery switch possibly being the cause. I have tried disconnecting everything including the Roo from the Tooth leaving only the 12 volt supply and the red error light remained. In saying that though, I didn't think, as you suggested, as it is still fed via the home made switch there could be a bad component on that. I have tried with the battery disconnected from the switch with no success but not with the switch disconnected as well.

I must head out now, but I will look into this further tonight. I am probably going to replace all the Teeth with 2x32s anyway, but I would like to know what caused this in the first place.

Thanks again and I will keep you posted :)
Australia
#19  
Ok, so I'm sure the Sabertooth is no longer with us. I have completely pulled it out and applied 12 volts to the input terminals only and the red error light is still on.
User-inserted image

User-inserted image

I have tried to figure out if the home built switch is to blame but my results are inconclusive... mainly because I am not very knowledgeable with trouble shooting electronics. I think I will just buy the 2x32 Teeth, remove the dump batteries, remove the home made MOSFET switches, rewire everything and be done with it. This robot owes me well over 10K to date, and he's not finished yet, so whats another $600,.....right? No sense taking short cuts..... right? I just need to order them when my wife is not looking ;).... Actually, she's pretty cool with the my whole B9 Robot obsession...... I might have to buy her another pair of shoes though

Steve
#20  
Granted I haven't read all the posts in this thread, so I am not sure what you have tested and what you haven't... Just out of curiosity did you check the output of the power supply? Did you check the sabertooth with another power source like a known good battery?... Maybe your power supply is duff and not the sabertooth?
Australia
#21  
The power supply in the pictures is not the one from my robot. The one in my robot is a 30 Amp 12 volt unit still fitted in the robot which is powering everything in the torso section just fine, including another Sabertooth. I have another power supply in the leg section feeding the waist rotation motor via another Sabtooth. The power supply in the pictures above and below is one I use for testing and It puts out a nice clean 12.03 Volts.
User-inserted image
#22  
What I'm seeing here is that Status 1 LED is green but there is a red error LED. The status 2 LED is dark. According to the manual In most cases Status 1 acts as a power indicator. In R/C mode, it glows dimly if there is no RC link present and brightly if there is an RC link. The red Error LED illuminates if the Sabertooth has detected a problem. It will light if the driver has shut down due to overheating or overcurrent.

It looks like your dip settings are 1-4 Off (down), and 5 & 6 On (up). According to the manual If switch 6 is in the UP position, then the Sabertooth is in standard R/C mode. It enables a Timeout Failsafe, which will shut down the motors if the Sabertooth stops receiving correct signals from the receiver.

It looks like you have this set in RC mode right now. If dip is up and you don't have a signal from a RC receiver the failsafe is shutting down the Sabertooth. This could be why your getting the Red LED as it sits now. I'm not saying this is your problem but your not getting reliable information from the Tooth's LED. I'd suggest switching dip 6 to Up and seeing what happens. If you still get the red LED then add the Roo and set the dips on the Sabertooth to 1 & 2 Down (off) and 3-6 Up (on). If you still get the red LED i'd say your Tooth has failed.

Why did it fail? We may never know. It may just have given up the ghost. However, maybe there's a short in the battery or somewhere along the power train.
*Remove the battery, the sabertooth and the power supply and do a continuity check between the power supply and the ground side of the circuit for a short. *Make sure your battery is good. Use a battery charger to see if it will bring it up to full power and hold a charge (or take it out and have it checked). Some chargers know if the battery is bad when you hook it up.
*If all this checks out you may have accidentally shorted out the circuit somehow. Most likely it's a manufacture defect and the Tooth just failed.

When things like this happen we normally ask yourself "What did I do?". Sometimes the answer is "Nothing, it was something else". ;)
Australia
#23  
Hi Dave,

The dip switches are set 1 & 2 Down (off) and 3-6 Up (on). Its a bit hard to see in the last photo. Its easier to see in the closeup on the previous page. The dip switches are mounted upside down in relation to the text printed on the PCB. Looks like it is in fact dead. I have ordered the new 2x32 Teeth to replace the three 2x12s I have now. I may have to pick your brain if that's OK, when it comes time to work out what size resistors I need for them

Steve
#24  
You are going to be voltage clamping so you need to figure resistance and not power. So look at your Ohm values and not the Watts. So go ahead and get a few each10 ohm and 20 ohm - 10w Wirewound Ceramic Cement Resistor. You start with the 10 ohm and if the PS supply doesn't kick out and the resistor doesn't heat up too much you will be good. If not move up to the 20 ohm. For example for the little motor that runs my crown motor and the car power window motor I'm using to move the B9's arm in and out of the torso, I'm clamping voltage with a 10 ohm, 10w power resistor. For the Windshield Wiper motor that moves my arm elbow and lifts all the weight of my arm I'm voltage clamping with a 20 ohm, 10w power resistor. I may have been able to get away with a 10 ohm for the elbow motor also because the PS was not kicking out but the 10 ohm resistor was heating up more then I liked. I also have the resistors mounted right onto the heat sinks of the Sabertooth to help with any heat dissipation if needed.

Let me know how that works for you. :)
Australia
#25  
Will do, Thanks for all your help Dave :D
Australia
#26  
OK, so I've finally had some time to install two of the three new Sabertooth 2x32s into the Robot and of course, this has not been a straight forward operation. I cant get one of them to do an auto tune. I have set the dip switches on the troubsome Sabertooth 1 & 2 "Off" and 3 to 6 "On" as per the Kangaroo Instruction sheet. I have set the Dip switches 1 - 4 on the Roo all "On" as I am using an encoder for feedback. I have tried connecting to the Roo with the DEScribe software and reset the Roo to default settings. I also checked that both the Roo and the Tooth are set to 9600 baud. I am using limit switches so I am trying to do a #2 Auto tune and after it should start there is no movement and I get an error code on the roo. (six flashes) which according to the manual is a limit switch fault. I have checked and rechecked the limit switches (normally closed) and they seem to be fine, I'm now wondering if the roo is faulty. This is the roo that was connected to the faulty Sabertooth 2x12 I replaced with these new 2x32s

Does anybody have any suggestions?

Steve
#27  
Well, If this is the same roo you used with the sabertooth you were having trouble with then maybe your problem was a bad roo all along? If you move this roo over the other working system does the problem follow?

Can you remove the limit switches and use one of the other tuning options and have it do a successful tune?
Australia
#28  
Hi Dave,

I am hoping to have some time tonight to swap the roo's around to see what happens. I'm not sure if the roo was the cause of the last issue with the Sabertooth because the Sabertooth had the red error light on with nothing else connected to it..... unless..... the roo IS faulty and it damaged the tooth.... doesn't seem likely though.

I'm planing to move a known working roo to the non working tooth and see if that fixes it. I'll let you know how that goes.

Steve
#29  
Also make sure you have continuity all the way through the connectors and switches of the limit switch circuit. If the roo doesn't see a signal traveling through from pin to pin them it will think there is a open somewhere. Could be a badly crimped connector, broken wire, miswired or bad switch. Disconnect the circuit from the roo and do your testing apart from the roo. A continuity tester is one of the most variable testers you can have. Most multi testers have them. ;)
Australia
#30  
Thanks Dave,

I have confirmed the limit switch circuit continuity already. I checked the plug connections for tightness, broken terminals, the limit switches themselves for correct operation and the whole circuit by checking across both sets of limit switch terminals on the rear of the Roo with everything plugged in.

I still haven't had a chance to investigate any further and it looks like I will have to wait until tomorrow for another go at it. Too busy at the moment with other stuff and my poor robot is having to take a back seat *tired*

Thanks again for your thoughts Dave.

Steve
#31  
Cool, sounds like you're doing all the right things.

If this is a old roo that you have already did an autotune on (or tried to) you may want to try to get into the software and do a reset. You may be picking up the old limit switch limit settings.

Once in the software try to tune it from within there. You'll find it easier to see what's going on and make adjustments.
Australia
#32  
Well ya learn stuff every day. I didnt know you could auto tune while connected with the DEScribe software. I might try that too.

I already tried resetting the roo back to "Default" with the software, I could have sworn that was going to work....... but no dice.

I also was thinking of trying the "Teach" tune, but I have my doubts that will work because I still suspect the roo is faulty. I will confirm that by swapping them around on the weekend.

Steve
Australia
#33  
Believe or not, I am only marginally closer to an answer to the problem I've been working on with the sabertooth not tuning. I am nearly at the point where the men in white coats will come and take me away. I've changed everything more than a few times. I swapped around the Sabertooth and kangaroo and proved all three of them to be working, except for one roo which seemed to be faulty. I replaced the roo but the fault remains. I also replaced the gear motor / encoder, also no luck. I have lost count how many times I have checked all the wiring and the limit switch operation.

Now that I have a spare motor, I tried connecting it directly to the sabertooth and plugging the encoder directly into the roo and simply bridging out the limit switch terminals to simulate N/C contacts. This worked and I was able to start a tune and indicates there might be a problem in the permanent wiring in the robot. I then took out the bridge on the limit switch terminals and plugged in the limit switches I have been using in the robot and I was still able to start a tune. This proves the limit switches and wiring are OK as well.

The encoder wiring has been extended from the motor to a plug that's mounted on the top of the CSS and then continues to the roo mounted in the CSS. I have checked continuity of the encoder wiring via the plug with a multi-meter because I was thinking there may be too much resistance due to cable length and the plug, but I only got a reading of about 0.15 ohms on all cores. I'm not sure if this is the cause of my problems or not, but I figure the only way forward is to rewire everything and also try a better quality plug

This problem has been really frustrating because up until the original 2x12 sabertooth died, everything was working perfectly

Steve *tired*
#34  
Crap Steve, this sucks. What encoder are you using? Some require a pull up risistor it the cable length is too long.

Have you tried completely removing the limit switch circuit and trying to do a Teach Tune?

In the end you may be right. Most issues I've come across in troubleshooting all kinds of devices end up to be connector or wiring related. :(
Australia
#35  
Hi Dave,

Yeah, I've tried the Teach tune several times. It still comes up with another error code
(2 flashes - "System Range. The system can’t tune in the range provided or reached one of the limits. Make sure you started the tune in the center of motion"),
even though the limits are not even connected.

If the motor works when directly connected to the sabertooth but not when connected via the normal wiring installed in the robot, then there must be a fault in the wiring or plug. Its so frustrating because it was all working with the wiring the way it is with the previous sabertooth

Anyhow, I'm off to work now, Catch ya soon mate

Steve.
#37  
Ahh, this is a Hall effect encoder. I have no knowledge of these. I'd suggest contacting the manufacturer to see if the distance you're running your wiring is an issue for this encoder. If so they may have a solution.

If I remember correctly, everything works outside of the robot (and with shorter wiring )? When using the robots wiring this is when you get the errors?

On the other hand, the roo has different error codes for feedback and limits. You could give DE a call and get their advice.
PRO
Synthiam
#38  
I don't have anything to add in regards to the saber tooth configuration / however, I would recommend checking the grounds. All grounds must be common and shared amongst any electrical device that is connected together. Many issues with unusual electronics are due to lack of common ground.

Just a thought:)

Also, as Dave said it might be worth contacting DE
Australia
#39  
I am at the end of my rope with this sabertooth issue. I have completely rewired the whole circuit. I have replaced the plug in the middle of the circuit with a 15 pin VGA plug and socket hoping for a better quality connection. I have replaced every other component including the motor, sabertooth and kangaroo. I have confirmed the continuity of each wire and every in the circuit while all plugged together. I have confirmed the operation of the limit switches by measuring across the terminals on the rear of the kangaroo to confirm the limit switches are closed and then operating the limit switches and confirming the limit switches then open.
User-inserted image


User-inserted image


User-inserted image


User-inserted image


The error I get when I try to auto tune is six flashes on the kangaroo which is according to the kangaroo manual is a limit switch is fault but I have proven the limit switch circuit is fine by disconnecting the new motor and connecting a second identical motor directly to the sabertooth ( this is the original motor I was using but replaced with the new one in the hope that would fix this problem ) With the motor connected directly to the sabertooth/kangaroo, and the limit switches in the head section still connected to the roo and the auto tune will start. While the motor was connected directly to the sabertooth and the auto tune works, I extended the encoder wiring with 1 metre servo extension leads thinking the issue may be encoder signal voltage drop, but it still worked.

I have proven the new motor itself in the head section works by disconnecting the wires from the sabertooth motor terminals and connecting across a battery and the motor runs.

I am clutching at straws here, but the wires from the VGA plug are connected to the motor wires by in-line twisting and soldering with heat shrink over the join. This doesn't sound possible to me but, is it possible the soldered connections are causing the issue with feedback from the encoder?

There has been mention of the possible need for a pull up resistor, Does anyone know if this will help and how and where to connect it?

I hope someone can help me as this thing is doing my head in. *stress*

Steve
#40  
Ah man Steve. I was hoping that not hearing from you meant that you got this worked out. I guess not.

This may be just a stab in the dark but I see you have a big speaker mounted right next to where your wiring from the encoder passes. If your using a Hall effect encoder maybe that big magnet from the speaker is messing up the signal. Try removing the speaker and any other magnetic devices and see if that helps.

I'm sure you will get this fixed. You have a very solid and well built system there. You just need to figure what is keeping the dam auto tune to work.

Do you have your old working tune saved? Maybe you can load it into the new roo and manually adjust some of the settings if needed in the DeScribe Software. That way you don't even need to do an auto tune.
Australia
#41  
Hi Dave,

The delay in re-posting is mainly due to being really busy with home stuff and I haven't had much time to work on the robot. That and I am fast becoming really frustrated with this issue and I had already exhausted all known avenues over and over, (well, avenues that I, as an electrician can understand. Electronics are a bit of a mystery to me). I found myself having to walk away from it to collect my thoughts, calm down and try and think of something I hadn't already tried 20 times already, .......such as removing the speaker to see if magnetism is causing the issues. Thanks Dave, I'll give that a try. Why didn't I think of that? I've had issues in the past with EMF while working on the waist motor and the 240 volt fluorescent task light I was using to see.

Unfortunately I didn't save the original tune from when I was using the 2x12 Sabertooth, good Idea though.

I going to try removing the speaker right now and I will let you know how it goes

Thanks Dave, for all the help you've given me

Steve
Australia
#42  
*tired*
Sorry to say Dave, but removing the speaker didn't work.
Back to the drawing board I go.......
*tired*

Steve
#43  
Okay, let's stay on the EMF path for now. I see you have power cables running in the same conduit as kangaroos feedback wearing. Are the red and white wires the power fed to the radar motor? Try moving the power wires as far away from the feedback circuit as you can. Do this from the kangaroo all the way to the motor.

If you are able to start a tune with the motor out of the robot there's a reason why you can't start one when mounted in the robot. Something is keeping the feedback signal from getting back to the Kangaroo or causing it to be confused. The error message that the kangaroo shows is usually spot on on my experience. Trust me, I've caused most of them to trigger. Lol.

You said you tried to get a tune to start when you disconnected the limit switches and tried a Teach Tune? Did you get the same 6 flashes?
#44  
Would twisting the signal pairs help prevent EMF like it does in Ethernet and long telephone line runs?

Alan
#45  
Yes Alan, great call. At the very least it couldn't hurt. I'd also twist the power wiring. Another method that could be tried is to wrap each signal wire around its own FERRITE ring.
PRO
Synthiam
#46  
Are the signal wires free floating? They may require a pull up or pull down resistor - based on the type of sensor. Does the sensor have a pull resistor?
Australia
#47  
Thanks guys, I've been thinking that I may need to try running the motor power cables separately......all last night...Its keeps me awake at night. I kept putting it out of my mind because of the low current the motor draws and the fact the power and encoder wires are all together as a loom as they leave the motor. That and I'm a neat freak and I wanted everything all contained in one neat lead and plug. I think you are right though Dave, I have no choice but to pull it all apart..... again ;) and try with the motor power wires run separately. I have to head off to work now, so I will keep you posted. Thanks for so much for not giving up on me. :D Means so much to me and keeps me motivated.

Steve
Australia
#48  
Sorry DJ, missed you're post while I was typing the last one.
There is no pull up or down resistor in the circuit. If required, where and how would that be connected?
PRO
Synthiam
#49  
First, let's check if you need one.

- keep the sensor connected to the roo
- use a multi meter and set the voltage for DC
- probe the signal wire against the sensor's GND and tell me the voltage
- probe the signal wire against the sensor's PWR and tell me the voltage
Australia
#50  
PRO
Synthiam
#51  
That's the issue - there should only be 5 volts through the encoder. The wiring to the encoder is incorrect - as it should be connected to the +5 of the kangaroo

I'm not certain of the kangaroo can support more than +5 on the encoder logic input pins. It may be damaged.

1) The motor wires of the motor/encoder should be connected to the HBridge pins of the sabertooth

2) The encoder power and signal wires of the motor/encoder should be connected to the encoder input of the sabertooth
Australia
#52  
I have the motor and encoder connected as per this diagram. (only one motor connected to Chanel 1 and the 0V, S1 & S2 connected to the UART port on the EZB)
Also I have omitted the index wire.

User-inserted image


Is this incorrect for my application?
#53  
GND to A = 15.00 volts
GND to B = 15.42 volts

I think DJ has something here. The above voltages to A&B of the feedback from the encoder seems very high. I don’t understand why if you are feeding 5v to the encoder (as your reading show, 5v to grd) your getting 15v back on pins A and B.

I need to think about this, go over some specs and test my roo pins to see what I have. My first impulse is there's a short or miss wiring. Dont know how you can get 15v though. The other possibility would be that you can't get a good and understandable read from these pins because of diodes or caps in circuit.

Edit: it's hard to see by your picture but how do you have the dip switches sat on the kangaroo? They should all be in the on position for your application. It kinda looks like they're in the off position. Please confirm this.

Edit again : according to the specs below your encoder input voltage can be as high as 20v so I doubt you damaged it by overvoltage. Double check your wiring to make sure your wiring color map to the proper pins as shown below :

Channel Hall effect encoder is used to sense the rotation of a magnetic disk on a rear protrusion of the motor shaft. The quadrature encoder provides a resolution of 64 counts per revolution of the motor shaft. To compute the counts per revolution of the gearbox output, multiply the gear ratio by 64. The motor/encoder has six color-coded, 11" (28 cm) leads:

Color Function
Black motor power
Red motor power
Blue Hall sensor Vcc (3.5 20 V)
Green Hall sensor GND
Yellow Hall sensor A output
White Hall sensor B output
Australia
#54  
Hi Dave,

Just confirming the dip switch positions on the roo, I have to head off to work soon. This is a zoom of one of the photos of the roo from an earlier post, sorry its a bit fuzzy as I dont have time till later to take a better one. It shows all dips are on.
User-inserted image

I am going to try changing motors again and re-measuring the voltages at the roo tonight to see what that shows

Steve
#55  
Steve,

I just do some testing on my roo's encoder pins.

After power up I get:
5V to GND = 5.00 volts
GND to A = 0 volts
GND to B = 0 volts

After command is sent for motor to turn one way:
5V to GND = 5.00 volts
GND to A = 2.5 volts
GND to B = 0 volts (this could be wrong. Could be 2.5 also)
Values change slowly as the motor turns the encoder

After command is sent for motor to turn the other way:
5V to GND = 5.00 volts
GND to A = 0 volts (this could be wrong. May be 2,5 also)
GND to B = 2.5 volts
Values change slowly as the motor turns the encoder

These are ruff voltage readings. I was twisting around trying to stick the probes in tight places. It could be that A&B both jumped to 2.5 volts but I was having trouble getting a good reading. The thing that sticks out is that when A&B pins tested to ground show zero till a command is sent then the voltage reading jumps to life. Looks like each pin gets 1/2 of the 5 volts supplied to the encoder.
Australia
#56  
Very Interesting..... I wonder what the hell is going on with mine then.
I wonder if it makes a difference if I have no tune saved in the roo.
All I did to take the measurements was to turn the power on and measure the pins. I also cant understand how I get 15 volts out of the signal pins when the supply to the encoder is only 5 volts. The power supply feeding the whole robot is only 12 volts *confused*
Looking forward to doing some more investigation after work

Thanks for going so far above and beyond the call of duty Dave

Steve
PRO
Synthiam
#57  
There's a short or a misconfiguration in the wiring. The kangaroo cannot output 15 volts - and that 15 volts is most likely from a 12v battery.

Good news is that is the problem - there is a short or wire connected incorrectly. This could be inside the motor encoder, or simply a wire of incorrect color to the wrong place. So you do have some direction to take.

Bad news is it's pretty difficult for us to help diagnose the wiring, it's up to you:D

What you can do is disconnect the motor/encoder entirely from the kangaroo. Then probe the wires at the kangaroo without the encoder hooked up. You should get 5 volts and 0 volts, never 15.

Also probe the motor encoder wires unhooked from the kangaroo. If you get 15 volts, then the issue is at the encoder.
#58  
I'm happy to help Steve. I know how frustrating this stuff can be. When I first started to use the Kangaroo I had many weeks of trial and error getting my first tune to complete. The problems always ended up not being in the roo but in my system. Wiring or connector problems mostly.

Oh, that reminds me, Double check your crimps at the molex connectors that attach to the encoder and limit switch pins on the roo. I found one or two that I thought were good but actually crap squeezes by me and caused problems. I've made a thousand of these connections over the years but once in a while I squeeze a bad one.

OK, I also asked myself why you're getting 15 volts at pin A&B. Wish I knew. Only things think I can think of:

*You're testing wrong (sorry)
*Bad tester (low battery?)
*One of your circuits is shorted to your 12v circuit somewhere and back feeding through the encoder to the roo.
*God only knows

Too bad you didn't save your last working tune. You could jump start your roo with it. Don't fee bad I made the same error at first. Cost me a lot of time to get back to where I was. I've attached a zip file with my working tune of my radar. You can install into your roo and it may help get you started. Before you start it up your going to have to load it into the DeScribe software and change the feedback from Analog (Pot) to Digital (Encoder). Your using a different motor then me also so the other settings wont work well and the end points will be wrong. However this will be a way to see if your set up at least starts up. Let me know what happens. ;)

Radar2.zip

EDIT: I see DJ answered while I was typing and getting the ZIP file ready. He as usual is giving good advice and in a more elegant way then I could. Good luck. :)

Another Edit: If you are in fact back feeding 15v into the roo's A&B pins you may have damaged the roo. *tired*
Australia
#59  
Hi DJ,

There is no battery in the robot at all, just a power supply that puts out exactly 12 volts. I'm certain as I can be the wiring is connected correctly, but stranger things have happened and I will check it all again for the umpteenth time ;).
I am intrigued to measure the voltages of and find out what the second motor will return, (which is actually the original motor I had in the robot and swapped to try and fix this problem). Maybe the brand new motor/encoder, which is in the robot at the moment has a faulty encoder.... hard to imagine though as the same problem was there with the original motor too, but the original one is the one that works if I connect it directly to the sabertooth...... ARRRRH, my brain is melting. I will do some more testing when I get home tonight and keep you guys posted. Thanks for all the advise.

Steve
Australia
#60  
OK, here's where I'm at, With The original motor encoder connected to the roo, and the original motor power wires connected to the tooth M1 terminals, and the limit switches in the robot connected to the roo, I can get the auto tune to start. Of course I have to pull the fuse to stop the motor as it is not running the radar, it is just sitting on the CSS. I measured the terminals on the rear of the roo and the results are as follows. (All voltage results are with the power on and the motor NOT running)

GND to A = 12.3 volts
GND to B = 4.98 volts

Keeping in mind that this motor works with the tooth/roo, I'm still very confused. No zero volts in sight.

To further my confusion, I lengthened the encoder wires with 1 metre servo extension leads. The motor still will start an auto tune but with the longer leads, the voltage measurements are slightly different.

GND to A = 13.47 volts
GND to B = 4.97 volts

Not sure why the voltage goes up on the GND to A pin. I would have thought if anything it would have gone down with voltage drop caused by the thin gauge longer wire.

I have also tried unplugging the encoder on both motors and with the multimeter set to ohms, I measured from the VCC pin to both the A and the B pins and the readings were the same for both motors

VCC to A = 5.08 ohms
VCC to B = 5.10 ohms
A to B = 10.19 ohms
GND to all the other pins = 0 ohms

I'm going to have to resort to dismantling the radar section, yet again and cut all my hard work to remove the new motor.., again, and first see if it will work connected directly to the sabertooth as the other motor does. If not I will have to put the original motor back in the radar and try to get it working by temporarily connecting it and then trying the permanent wiring a section at a time.

*tired* Steve
#61  
If you're only taking voltage readings while the motor is running then according to my tests you should see voltage at these two pins on the roo. When the motor is stopped and the Roo is powered up you should see 0v at each of these pins. I don't think the different voltages on each pin is a problem and may be proper. However that 12v+ reading is still blowing my mind. It really seems like you're somehow getting the motor's 12v power feed through the encoders 5v circuit feed from somewhere.

Did you try DJ'S suggestion of pulling off the connection at the roo and voltage testing both encoder side and roo side while energized to see what your voltages are? That will tell you what direction the problem is at least. However I'd be surprised if you got any voltage from the encoder side because it should get its power from the 5v pin of the roo. But that is what testing is all about.

Did you see my previous post where I attached a zip file with a working copy of my Radar roo tune? Try adjusting it like I suggested and uploading it to the roo to see if you get any changes. Don't forget to power cycle the roo after the upload. If you can get this tune to move the motor at least you can have a little control hopefully.

One last thing for now. Take another look at the limit switches. Physically discount them from the roo, clip on a continuity tester and physical open and close them. Watch and listen. Make sure they are operating properly with clean open and closes. I've had more than a small share of new micro switches malfunction. Old switches will fail like this more often after a few thousand operations. I'm always replacing micro switches on my pinball machines because of this. ;)
Australia
#62  
Hi Dave,

I was only taking measurements with the motor not running.
I did try DJ's suggestion to remove the encoder signal wires, I removed them from the plug that plugs onto the roo while leaving the +5 volts and ground wires in the plug so I would have supply to the encoder and I could read what was coming back from the encoder on the signal wires. Unfortunately I didn't wright down the results at the time and now I cant remember for the life of me. It definitely wasn't zero, it was something high again. Wish I could remember but this fault is really beginning to get to me and my brain is beginning to shut-down, possibly as some sort of self defense mechanism.

Thanks for the Zip file of your radar tune. I haven't tried it yet, if all else fails I will have to try and work out how to load it into the DIScribe software and adjust it for my needs and see if that will work.

As for the limit switches, I have proven their functionality with a continuity tester multiple times and I also have by-passed them by putting a direct short on the limit pins on the roo by using a modified 4 pin plug with shorted wires to simulate NC contacts

I'm just about to start ripping the new motor out of the radar and I want to test it out of the robot to see what happens. I'm starting to wonder if this is all just because kangaroos just don't like Hall Effect encoders.

Steve
#63  
Can't write much as I'm getting ready for work after a good night's sleep. Lol.

I truly understand the flusteration you're going through and feel for you. Been there and done that. I'm impressed by how you're sticking with it. Understandable why you shut down sometimes. Keep up the good fight. Your not only helping yourself but others down the road.

I'm not sure but I don't think you should be getting a higher voltage back from the encoder. You may be right that the roo doesn't like that type of device. Have you tried calling DE yet? They may have some answers.
Australia
#64  
Hi Dave,

I'm quietly..... (very quietly), confident that I may have found the gremlin in the system..... I think..... I hope. I removed the new motor out of the radar, the one that refused to work. I connected it directly to the tooth/roo and it worked. So with that in mind I wanted to see if EMF is the culprit. I connected the encoder and limit switches using the VGA plug and the power to the motor run completely separately and it worked. If I reconnected the motor power through the VGA plug, it stopped working. It seems it was EMF after all.

I'm now going to redesign the disconnect-ability of the head section ... again and plan to use separate shielded cables and plugs for the encoder and power. This time I'm going to do some bench testing to confirm that shielded cables will work as they will still need to reasonably close to each other inside the collar so I don't have tangling problems with the other cabling in there for the ears and brain lighting which needs space to move when the radar turns and the bubble goes up and down.

I'm afraid I'm not going to have much time to work on the new design till next week but at least I think there is a light at the end of the tunnel with this problem. If it works I will finally be able to start moving forward again. YAYYYYY.

I will keep you posted on how it works out. Thanks for keeping me from loosing my mind ;)

Steve
#65  
Steve, I read this a few days ago and jumped for joy. This is indeed good news. It always seems that something so small always ends up causing the most problems.

Before you do anything try, one just more thing. Do a continuity test from pin to pin on that big connector. Maybe you splashed a little solder between them and caused a short.

I'm really looking forward to seeing your final post where everything starts working for you. :)

Once you get a good and successful tune make sure you save that thing. *eek* Do the same for each roo.
Australia
#66  
Hi Dave,

The 15 pin VGA plug and lead is a molded factory made pre-terminated extension lead I bought from the local electronics shop, I simply cut it in half and used the cut ends to connect to all the components. You're still right though, factory made doesn't mean that it cant be faulty. I will buzz between all those cores out and see if there is a problem in the plug itself.

Thanks Dave :D
Australia
#67  
Well, no shorts in sight. I buzzed from each pin to all the other pins and also to the metal body of the plug itself. I did this with both the male and female plugs. Looks like EMF is still the culprit
#68  
Ok, we can scratch that off the list. Too bad, that would have been easier to deal with.
Australia
#69  
Hi Dave,

I can finally call this issue "resolved" :D
The problem was definitely corrupted data due to EMF from the motor power wires. I completely rewired the radar section, installed metal shielded plugs and used Category 6A shielded cable and earthed the shield and plugs. Once installed I tested the system, and you wouldn't believe it, I got the same error. at that point I had to just walk away or I was going to explode with frustration.

A few days later when I was in a better frame of mind, I did a bunch of testing and fiddling It seems the only way I could get it to work was to use the shielded cable for the encoder and NOT use the shielded cable for the power cables. If I just used normal unshielded cable on the motor power it worked.... Cant explain it.... it just did. So I rewired the power wires permanently, selected the expropriate Auto Tune...... and off it went. But... the first tune failed half way through so I separated the cables some more and I got a successful tune....Finally

Next problem....., I had issues getting both the waist motor and radar motor to run with my existing ARC initiation script. The bubble lifter worked fine though. The bubble lifter uses a potentiometer and the radar and waist use encoders and need to "Home" when initiated. The problem was that I needed to fiddle with the homing speed and also with the initiation script a little and I finally got it all working. YAAAAAYYYYY

Hopefully this is the end of this issue but It's taken me so long to fix, and tested my patience so often, I'm not 100% convinced its over. I still keep expecting to see that FU@*!/# error light. Fingers Crossed

Steve
#70  
Yah! I'm really happy for you and releaved. I've been thinking of you often these past weeks knowing what you'er going through. As you know I've also spent weeks working through Auto Tune issues with the Roo. However if it makes you feel better once the tune was a success and set like I like, it's ben a solid and almost bullet proof system. Now that you've worked through all this I think you and the robot could work at NASA. :D

Your solution is fascinating and curious. So just to be clear; you had to use unshielded cable for the power and shielded for the signal. When you had the power cables running in shielded cable were they running side by side and close to the signal cable? When you say you separated them to get them to work what were you separating them from? I wish I knew what the actual issue was with the EMF and where it was occurring. If you had to separate the + & - of the power cable to get them to work that should not have mattered. If you had to separate and move the unsheilded +& - power cables away from the signal cables then you were still getting emf interference. Either way it was still bleeding over somewhere. Maybe at a connection point? I hate to keep beating a dead horse and put this out into the universe but all that moving cables could have reconnected a bad wire or connection somewhere. I hope I'm just full of crap on that last statement. It's just nice to know what the actual cause of these things are for the next time something like this happens to us.

When you recover from this traumatic event (LOL) would you be willing to take a few pictures of your wiring setup from Roo to motors to power supply? That is if you don't have him all buttoned up yet.

So I'll keep a positive attitude and be sure this issue is behind you. Thanks for including me in your process. It was great to watch you work through this to success. :)
Australia
#71  
Thank you Dave for all your support and help :)
I will add some pictures tonight with explanations. It's such a relief to be able to move forward. I felt I couldn't move forward at all by working on another part of the robot knowing this issue was still there.
I must head off to work now ....at NASA ;)

Steve
#72  
I know the feeling my friend. I'm glad your free to move on.

Three, Two, One..... Blast Off!:P
Australia
#73  
Sorry Dave, I had a big day at NASA today and my wife has plans for me tonight so I won't have time to add pictures of my setup tonight. I should be able to in a few days.

Steve
#74  
No Hurry at all Mr. Armstrong... err.... Neal, I'm mean Steve. ;) Take your time. The wife's plans come first and in front anything robot related. That is if we want to stay happy following our robot dreams. LOL. It's good to know nothing is different even if you live on the other side and at the bottom of this fine earth. Damm, I think I hear my wife calling. Later.............
Australia
#75  
Hi Dave,

Here's a few photos of my setup with regards to the radar motor and ear motors
User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image
#76  
Thanks for the pics with the labels Steve. Man, that's one clean build! Very impressive and I'm kinda embarrassed with my messy wire filled CSS now. I'm so glad things are working now for you.

I have a couple off topic questions if your willing to answer;

Have you had the torso in place with the CSS and the EZB sealed inside? If so have you experienced any connection problems? I see your EZB is mounted on the second shelf down. That would place inside the torso and depending on your WIFI signal direction you may have lots of metal and devices between it and your router. I was afraid of this same issue so I have my two EZB's mounted on the top shelf to get the most unobstructed signal possible. One EZB is for all the torso and head robot functions along with sound streaming. The other EZB just runs both arms. I was also worried with two EZB's being so close to each other that the WIFI radio signals would interfere with each other. I have each mounted about 5 inches apart and there seems to be no issues with interference. However I was having trouble at first with one EZB connecting and not the other. I set a static IP address for each EZB in my router and also have and Engenius Access Point that they attach to. That gives me very strong signal strength close to the robot. Once I did these two things I have had no issues with connections. :)

The second question; When your radar rotates back and forth (along with the bubble lifter pipe that runs down through the CSS) do you exuberance the collar twisting with the movement and unlocking it's self? I see you have a hook latching system for your collar to lock it down the CSS. I assume you set the collar down on your CSS and twist it in place to secure it. My Collar tend to move a little when the radar rotates and after a while I need to re-lock it in place. After viewing Chris P's HD pictures on his DVD I see the orignal B9 had a clip and screw in the very rear where the collar joined to the torso. I bet it's there to keep this from happening when Bob May used his head to move the radar back and forth and bubble up and down. I plan to add this clip and screw to keep my collar in place.

Third question. What are you using in the center of your CSS to guide the Bubble Lifter pipe. It looks like a PVC fitting. I'm also using a PVC fitting but it's much more bulky and bigger. I had problems with binding and had to do a lot of sanding and aligning from level to level. It was a pain but is heavy duty and solid now. I'm not sure if it was really necessary to go that HD and was a pain in the but. LOL.

User-inserted image


Anyway, Nice work and please keep in touch. I'm very interested in your path.

Have fun!
Australia
#77  
Hi Dave,

I haven't forgotten about you. :) Been busy again. I took a bunch of pictures last night to help answer your questions but i need to sort them and label them yet.

I should be able to spend more time to upload the pics and answer your questions tonight.

Steve
#78  
Thanks Steve. No worries my friend. No hurry either. :)
Australia
#79  
Hi Dave,

With regards to the EZB mounted inside the torso, yes I have had the torso on with seemingly few problems with connection. Sometimes It does disconnect from the router but the router is installed way up the other end of the house and the robot is down the other end. I do want to upgrade my router and move it to a more central location in the house as I have had some problems with the laptops in the house disconnecting or having a poor signal also from the router. This sort of leads me to question of my own. Every time I run the INIT script, It wont connect. I then have to scan in the Connection box in ARC to find the EZBs and the addresses always have changed since the last time I connected them (From one day to another). I think you may have answered this question in your above post when you said you set a static IP address in the router for each EZB. Not sure if this is the answer or even how to do it.

My radar doesn't seem to loosen the collar from the CSS with radar movement. Just luck I suppose. (More unicorn than class). My collar has three locating blocks which fit into slots cut into the top shelf of the CSS and they fit snuggly between the torso top ring and the CSS. Also the metal hooks are snug as well and when I locate the collar onto the hooks I need to give the collar a quick twist to lock in the hooks. Seems to be firm enough not to twist off.

EDIT: (more unicorn than class).......? Wait.. What? That's not what I typed... rhymes with class though... Laughed my unicorn off!

The center guide in the CSS for the neck tube was again, more luck than good planning ;) I originally had a piece of PVC pipe that fitted perfectly through the hole in the radar and of course use that for the neck tube of the bubble lifter. I was however going to have to make some sort of guide for the neck tube in the CSS as I couldn't find anything to fit the pipe which would allow it to slip through. I also had made my own neck bracket from modified PVC pipe fittings and acrylic that fitted the pipe. I mounted a plastic Brain cup, (From Fred B.), to that and a beautiful laser cut metal brain, (made by a local B9 Builder). I have since decided to replace the plastic brain cup and neck bracket with a Norm S. aluminum ones... but the new neck bracket was too small to mount properly into my PVC neck tube. *tired* So I bought some slightly smaller PVC tube for the neck (I did need to heat it and stretch it to fit the Norm's neck Bracket), but this change in pipe brought about an unexpected bonus. Before with the larger pipe, I couldn't find anything to fit it for the center guide in the CSS. With this new pipe, I found a flange that fitted it perfectly with enough clearance to allow the pipe to slide up and down with no binding. I have two of them, one in the CSS and one in the radar. I spent ages in the hardware store fiddling with pipes and fittings until I found parts that would work together. The flange was intended to fit into a larger pipe, (not have a smaller pipe pass through it), and the pipe was from a different range of pipes. Some pipes use internal measurements and some use external measurements. I just mixed and matched until I found something that would fit all my needs.

Anyhow, I think I have waffeled on long enough :D Here are some pictures of some of my work

Steve
User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image
#80  
Holy cow. I'm speechless. The CSS and everything that has gone into it is a work of art. You're a very talented guy. It's a shame you will be bottling it all up inside the torso. The for-planning that had to have gone into this must have taken you a very long time. You obviously know what our doing.

Thanks for sharing. :)
Australia
#81  
Thanks Dave *blush* but you're way too kind.
I am proud of how he's coming along so far but there are still plenty of things I would like to improve on. I've lost count how many times I have re-made, re-mounted, replaced or re-wired something because I wasn't happy with it. I still now go to add something to the CSS only to find out that it will impact or clash with the placement of something else not previously thought of and again, the snowball effect happens all over. I try so hard to think of everything that will be in the CSS and how best to locate everything for functionality, space saving and aesthetics, but despite all that thinking, I still run into lots of hurdles... but in saying that, this B9 is a labor of love and I get a tremendous amount of satisfaction from it.

Your CSS on the other hand, in fact the whole robot is world class and I can only imagine how much time and effort has gone into it. In my opinion, your robot would have to be the best autonomous B9 in the world. Truly a work of art and an inspiration to the rest of us B9ers, especially me. Whenever I need inspiration, I just watch some of your videos. Just incredible

I will try to make a video of the radar and bubble lifter in action today and then try even harder to work out how to upload it ;)

Thanks again for the kind words Dave

Steve
PRO
Synthiam
#82  
Maaaaaaaaaaan is that ever clean @steve. Wow! You're putting us all to shame:D

I don't think i've ever seen a robot build with so much care in the wiring - that's an entire project just in itself. Amazing
#84  
OK Steve. that left me feeling like I wanted a cigarette and I don't even smoke. LOL

Seriously though, The lifter action is so smooth. That actuator is a lot faster then I thought it would be. Seems like a very natural and human speed. Are you able to stop it at different positions and control the speed? Are you using the Sabertooth and roo to drive this? Sorry if you have already shared this info with me and I forgot. Heck somtimes I cant remember what I had for breakfast. LOL.

If I had to rebuild my lifter I'd go your route. I'm not entirely happy with my servo driven fork design.

I really did enjoy that vid. Thanks for sharing. ;)
Australia
#85  
The actuator is connected via a Sabertooth and roo and can be stopped in any position and any speed. I simply wrote a quick script to run it full up and full down on repeat so I could video it moving, It uses a 100mm slide potentiometer for feedback. You can see it in the last 20 seconds of the video
#86  
Dude, say what you will about me (and thanks for your kind words, by the way. My wife thinks your eating to much Vegemite) but your work rivals mine in every way. Your work gives new meaning to Thunder Down Under. LOL. ;) I'm seriously thinking about scrapping my entire bubble lifter and rebuilding it as a copy of yours. I've always worried a little about how long my setup would last. Mostly worried about the expensive HD servo wearing out. Its also complex needing two extra servos to pull resting support blocks out of the way when I want the bubble to move all the way down to the radar. However your design really looks wonderfully simple and bulletproof. Using that liner pot is brilliant. I had read that they weren't all that reliable but it looks like it's working well and the Kangaroo likes it just fine. Also I love the roller ball between the actuator and the neck tube. What a great stress relief point and way to separate the motor from the rotating load. Where did you get this roller ball fitting? I see ServoCity sell them but yours looks better. At the very least I'm going to adapt this roller design into my system. If your willing to guide me with the proper parts, where you got them and how you installed them I would be grateful. It almost looks like there is a fitting that slips up into the neck pipe and you have it fastened in place with countersunk pan head screws or bolts.

Thanks for showing off. ;)
Australia
#87  
Wow I'm so flattered but we'll have to agree to disagree. Your'e still far and away the Master B9 builder in my book.

I cant take credit for the neck tube roller ball castor idea. I saw in in a video by Greg Logue showing his new and improved Bubble Lifter design.
https://www.youtube.com/watch?v=BOICtuLYBoA
You can see the ball castor at the 2:22 minute mark. I was thinking to do the same as Greg and use a motor with an off-center wheel but decided to go with a high speed linear actuator instead.

The roller ball castor, I bought it off ebay. Here's a link to one the size I used but there's heaps of choices
http://www.ebay.com.au/itm/2-4-10x-32mm-Wide-Screw-Mounted-Furniture-Trolley-Rack-Ball-Swivel-Caster-Castor-/401044714205?var=&hash=item5d6020b2dd:m:msE1VXcFDlouHeIhgD8eZUg

I was planning to pull the neck tube apart tonight to show you how I made it but yet again I have run out of time *tired* I will endeavor to get it done for you in a day or two

Steve
#88  
Steve, Please don't take apart your creation. You have enough to do and I think I have a good idea how to do this. I hate to see you dismantle your hard work. No need to do build it twice.

Thanks for the links they really help and are a pleasure following.
Australia
#89  
Hi Dave,

Too Late :D But really, It's no problem Dave, It comes apart easy. I went back to the hardware store to take photos of the bits I bought as well. The tube I used, (I'm afraid this is all in millimeters ;)) was 40mm light duty. There is also a 40mm high pressure version but the walls are thicker and I couldn't find any fittings to fit inside snugly that I could modify to support the ball castor, either too big or too small. I ended up using a couple of 25mm caps that are designed for 25mm high pressure pipe (measured internally) They fitted quite tightly inside the 40mm LD pipe. I cut one of the caps right down to make a support for the ball castor, thinking about it now, I should have simply filled it something like Bondo and sanded it flat. Instead I pressed into the cap a bit of 25mm pipe and cut it off to make the walls thicker to give the castor more to sit on than just the cap walls. As you can see it it looks a bit crappy as I took to it with a Dremil tool to recess the castor a little to hold it in the center when the second cap is pressed over it to hold It in place. Anyhow, there's probably a million (better) ways to mount the castor in the end of the tube but this is how I did it.
User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image


I too was worried about the linear pot not working well with the sabertooth but it seems to work fine. Something I do need to test though is the linear actuator with some weight on top of it. I need to add about 5Kg to it, (my head section weighs about 5Kg), and test it with that. The actuator is apparently rated to 10Kg according to the specs, so I'm hoping it will do it with ease. Time will tell.

Steve