Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Rich!

Rgb Unit On Humanoid Head

Are the i2c ports on the board auto sensing or is each one of the 3 a specific address?

I found what looks to be the address range 0xA0, but I've also found V0 virtual ports or AX0 Dynamixel ports, it is currently set to N/A. What should it be set too does it matter which of the i2c prey's it's physically plugged into?

Thanks in advance for your help.

United Kingdom
#5  
Open your project
Click Merge (next to load and save)
Choose the example JD project
Select the RGB Animator control from the list (and any others you want) by putting a tick in the box.
#7  
Merged just fine thanks Rich!

Another problem now when I attempt to run one of the merged sequences the robot disconnects every time. Once in a while the software will also lock up.

This has happened a few times with speech recognition as well but not every time as it's currently doing with the RGB commands.

I'm not using direct network connection at this time currently using client DHCP connection.

Thanks
#8  
Is you battery good? If the ezb "browns out" and or too much current is requested (especially from a weak battery) the ezb will arbitrarily disconnect....
#9  
I will recharge the battery and try again, but according to the battery monitor its good over 7.0
*confused*
#10  
But that can quickly drop when a load is placed on it.... Are you using servos? 7.4 is the nominal value, however fully charged it will be over 8V
#11  
Yes I'm using servos it's basically a six with a body and humanoid head.


No arms arms attached yet waiting on the shoulders servos still.
#12  
That could be your problem... Servos draw a lot of power.... 90% of all disconnects are because of a low battery....
#13  
Ahh I see then for testing purposes I will try the RGB unit alone.

If this fails what are the chances the hardware is the issue.

Can the network be the issue direct client vs AP connection?

The humanoid head also processes sound as in speech recognition and my voice?
#14  
Yes, so the next step( if it is not the battery) is to test individual components... open a new project and add components\controls one at a time to see what does what...
United Kingdom
#15  
Check it is plugged in the right way around. Check it is plugged in properly. If there is an I2C error the EZ-B will freeze.

If you have the six body with battery inside, and it's fully charged, there should be no problems. In fact, if it isn't saying it has low battery and you haven't disabled or changed the battery warning then the power supply isn't going to be the problem.
#16  
Well it might be hardware I have tried without servos on a fresh project only the RGB animator, debug, and connection running it falls as soon as I run any command from the animator. EZ- builder locks up my board goes from green blue light to green blue and red.


User-inserted image
PRO
Canada
#17  
Hi @Cheko

You could try moving the RGB Eyes to another I2C port on the ez-b and see if it works (essentially all you would be doing is re-seating the connection). You could also re-seat the connection inside the Head as well.

As @Rich said if you try to use I2C communication and there isn't a good connection the ez-b will lock up, this is the nature of the ARM chip inside.
#18  
Thanks for the suggestion jeremie. I have re-seated the connection on the board tried all 3 ports and also in the head unfortunately it hasn't help.
United Kingdom
#19  
Have you checked the connection inside the head? Make sure that is connected properly too.

You mentioned to start with that virtual ports etc. which there is no reference to in the animator control. Which makes me wonder if you have changed the I2C port on the animator at any time? If you have and you attempt to control something on 0xA0 which you changed earlier to something else this will cause the EZ-B to freeze.

Can you post your project you are using? I'd like to check you have the control set up correctly.
#20  
Yes I check inside the heads it looked okay.

I can upload the project later when I get home thanks for the offer to look over the controls Rich

The virtual ports I mentioned in the beginning was in reference to the a design area. I came across but can't recall right now how where exactly I came across it, but I also recall some other options "Dynamixel" I left it as it was N/A and canceled out from what I can recall.
#21  
I just uploaded the file and made the file public

It's called Six W/Head

Thanks
PRO
Canada
#22  
Hello @Cheko,

Took me a little while but I found your file:)

Everything works fine on my end, so I'll leave it to our customer service team to take care of a warranty replacement.
PRO
Canada
#23  
Figured I'd quickly check if you have another set of LED eyes at all, just in case you did. It would make it quite easy to troubleshoot if the issue is the ez-b or the LED eyes if you had another set.
#24  
I unfortunately do not have another RGB array so my trouble shooting is limited, as I do not have a know good device. Yes this will need to be taken care of by customer service team since I can't determine with certainty if it's the board or array that are the issue. Thanks for looking over my ezb file.