Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Asked — Edited

Relative Servo + Invert Option Question

can any confirm the relative servi control is working properly? please.

i can get it to work but when i try to invert the motion one servo goes dead

ive tried clicking on the invert on both the master and seondary servo but nothing....

ive tried doing the multiple servo control and inverting there, same result.

i guess i can write a script, but thats sucks. (esecially when the freaking control is specificallymade for that motion)

i know its me missing somehting, just ran out of ideas.


ARC Pro

Upgrade to ARC Pro

Unleash your creativity with the power of easy robot programming using Synthiam ARC Pro

PRO
Synthiam
#1  
The invert option works great. Perhaps you are setting the MAX value lower than the MIN value.

MIN is short for Minimum, which means lowest. It must be lower than the MAX.

For example, if the MIN servo position is set for 10, the MAX must be greater than 10.

Correct:
- Min 10
- Max 30

Incorrect:
- Min 10
- Max 5

Hope that helps:)

Perhaps this example will be of more help: EZScript-Examples-RelativeServo.EZB
#2  
Hello, thank you sir. I will try that

What I have done I change both min to 30 and max to 50.

I set it this way on both servos.
The only thing I can think of is....because one servo is inverted I should swap the min and max? Or leave the min at 1and max at 100 and just change the settings on the main servo.

knowwhatimsaying.
PRO
Synthiam
#3  
Max is always greater than min. Inverted or not:)