Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Question: Ez-B V4 Controller Cannot Stay Connected To Wifi

I purchased an Ez-b v4 controller about a month ago to mod an Omnibot 5402 I bought from Ebay. Everything went completely smoothly, with the controller connecting to wifi with no problem and maintaining a stable connection. The robot operated under daily use for the next couple of weeks without a hitch.

Now about a week ago, the controller suddenly began disconnecting sporadically from wifi, forcing a restart of the robot every time (with the robot usually continuing to perform the most recent command and running into a wall). The problem has become worse with every use, with the unit now disconnecting 100% of the time almost immediately after connecting. The robot can barely be used for a minute before disconnecting, and is now basically unusable.

My wifi router is an ASUS RT-N66U which no other device has trouble connecting to. It seems the controller will disconnect regardless of range. I've switched channels repeatedly, and have also several times scanned for channels and forced it to broadcast on one which no other nearby device is using, which doesn't affect the time-to-disconnect.

Nothing has changed with the robot itself since initial install. In addition to the two stock motors, the controller is only running a single hd servo for the head swivel, the v4 camera, and two ultra bright LEDs, powered by a brand new 6v omnibot replacement battery.

I should also mention I don't get any kind of vocal error response from the controller when this happens. The robot just suddenly stops responding to ARC commands and either runs into a wall or keeps spinning around in circles (whatever it was doing last).

Has anyone has this issue, or know what I can do to solve this? Is my controller faulty?

PRO
Synthiam
#1  
Sounds like you require more power. The ezb is browning out.
#2  
Just to expound on whay DJ said. Amps, not volts (probably). It is virtually always not enough amps...

You could eliminate the router from the equation to confirm by resetting the EZ-B to AP mode and directly connecting the computer, but I really do not think it is a network problem, I think it is a power problem.

Alan
#3  
Thanks for the super fast replies. I'll try AP mode to be sure.

The battery I'm using is a SLA 6v 4.5ah (listed as replacement for the original 5402 battery). If power is the concern as it seems it is, do I just need a different battery?

Thanks again
PRO
Synthiam
#4  
Different battery or don't power as much off the ezb. Or check your wiring to ensure there are no shorts.

Lastly, you can share your ARC project and we can look to see if there are any floods or error messages. Perhaps it's not disconnecting from wifi but disconnecting the connection.
#5  
Ok thanks I'll get the error logs on here as soon as I get home. Btw looking at my original post I'm realizing it wasn't clear, so I should mention when I said 'forcing a restart' I meant I have to physically go over to the robot and turn it off and then on again. The ez-b is not actually rebooting on its own, and in fact seems to continue to run as normal with the controller continuing its previous command(s) without interruption. It's just no longer receiving any signals from ARC.

I only mention because, from reading other posts here on the subject, I was under the impression the controller would reboot (evidenced from the chiming sound) in the event of a brown out or controller disconnection.

Is a SLA the best battery type to use for this project, or should I be using a LiPo? I should also mention this is my first foray into anything electronics related, so when it comes to power supplies, amps, aH, etc. I have no idea what I'm doing (except for what I've read in the tutorials here). I'm actually amazed I got any of this to work in the first place. So thanks again for you responsiveness and patience!
#6  
Ok no need to answer this! I ended up re-wiring everything between the battery and controller with higher quality wires and the problem now appears solved. No disconnects over the last 30 mins. of use. I think I must have opened and shut the robot so many times during building and testing that I must have gradually worked something loose on the cheap wiring I used initially so voltage began dropping intermittently.

Thanks again!