Welcome to Synthiam!

Program robots using technologies created by industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation, and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Pulling A Jpeg From Http Server Control Results In Not A Jpeg Error In Roborealm

I am using the read_HTTP module in Roborealm to pull the static image provided via the HTTP Server control in EZ-builder.

When I try Roborealm says it's not a valid JPEG image.


Troubleshooting done:

1. Using a browser I can access the image in EZ-Builder's HTTP server just fine.
2. Using a different website that provides an image the read_HTTP module in Roborealm works fine.


There is some kind of incompatibility between Roborealm and ARC and how the image is either being sent or read.


Since I do not know which application is the cause of the issue I am requesting assistance from both sites.

Any help would be appreciated.

AI Support Bot
Related Content
Synthiam
PRO
Synthiam
#1  
You might need to contact RoboRealm to understand why their software is not able to read a JPEG image over HTTP
#2  
After posting here I did some more testing with fiddler and like you stated ARC seems to be sending a plain old JPEG back so I contacted them and they are looking into it.

Thanks for your reply.
PRO
Synthiam
#3  
awesome ! Let me know the results of their findings. I'm always willing for integration between neat projects like roborealm