Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Asked — Edited

Only One Com Port On Bluetooth

While setting up my Bluetooth connection I noticed I'm only given one Com Port option to connect to. In all the instructions I read they say I'll see two choices. I've gone ahead and set everything up useing the one choice given (Com 3) and all seems to work nicely and has been for a couple weeks now. However I'm worried that may change if I dont address this differance now. Do I need to worry and get this fixed or can go on my happy way?

Thanks,Dave Schulpius


Upgrade to ARC Pro

Become a Synthiam ARC Pro subscriber to unleash the power of easy and powerful robot programming

Youre not using the native Bluetooth stack. If it works, don't worry:)
Hello, I am having the same issue of only one COM port. When I try to connect, it says I need a firmware update and would I like to read the manual. I click no, then it says it cannot connect to my device and would like to see the manual. I have also tried yes to the manual part with the same result. I have tried connecting on all of the com ports. 2 new ones are installed when I add the device, however in the BLuetooth properties, it only shows one, and that is the one it tries to connect to.

Any ideas?

Have you actually updated the firmware?
No. When I click to the next step to update it says it can't connect and drops back to the start
I had a similar issue and had to change the Bluetooth USB stick using a different manufacturer. Using a Toshiba laptop running Win 7 I had to delete the Toshiba bluetooth manager program, then just used the Windows bluetooth stack with a new Bluetooth class 1 USB stick from Targus.
You have to update using the ez-b firmware updater. As for bluetooth class the ez- uses class 2 bluetooth.
NM. Sometimes it helps re-RTFM. I was able to connect through the firmware updater and update the firmware.