Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Asked — Edited

Noticing Ping Radar Problem In Latest Version....

I downloaded the latest version 2012.04.07.01 about 30 minutes ago, and downloaded the latest firmware v15.3 I like the new, stronger PWM control for the H-Bridge, but I am now noticing a slight unwanted, uneven, motor pulsing, going forward while using ping radar to control the robots movement with the H-Bridge controller. Sometimes while using ping radar the robot starts to move forward, then stops. I haveto manual use the keys on the laptop to get the robot to move forward. If I pause the ping radar, and just control the robot with the arrow keys on my laptop, it drives forward smoothly, and strong, but if I use the ping radar, I notice the motors have a slight pulsing going on, not constant, and not evenly, or the robot will start to move, then stop. The radar is still scanning but something is not right. No matter what speed I put them in, it still does the same thing, while using ping radar. Not sure what is going on. I even tried different scan intervals, still the same thing. I also tried cycling the power on the EZ-B, and restarting the laptop, no change. Anyone have any ideas?-Thanks


ARC Pro

Upgrade to ARC Pro

Experience early access to the latest features and updates. You'll have everything that is needed to unleash your robot's potential.

#1  
@ chancestarwind,

Are you seeing differences between your higher and lower digital I/O ports? I think there is something going on with the higher number digital ports. There are a few threads addressing strange behavior. I have noticed the same thing..but only on ports D11 and higher.

v/r

Kevin
#2  
I changed my ping sensors to lower ports, just to find out, still the same thing. I also noticed the forward button in the motor control panel lights green as if the robot is moving forward, but it does not move, while ping radar is being used.
#3  
@Chancestarwind

Change the connections of the motors to the lower ports "D11 down to D0"

coljc85
#4  
I noticed I had my motor controller on higher ports, so I moved my H-bridge motor controller to lower ports, that was it, now the robot moves forward, smoothly, like it is suppose to with ping radar. I had my motor controller on ports 15-19 with 19 being the PWM port. I am now using ports 8-12, with 12 being the PWM port with no problems. Something is wrong with the higher ports, hope this helps.....
#5  
Thank you all for recommending to try lower ports, that worked.