Asked — Edited

No Camera After Updating To Lattest Version Of ARC For Windows?

Hello,

I successfully updated the ARC Software for Windows and successfully connected to the Adventure Robot in AP communication mode. All works except for camera. Hit start button in camera screens and it immediately changes to stop. No picture from camera in video window. Worked o.k. with previous version before update?

Odd thing about it is when I connect to my wifi network in the client mode, I can open the ARC App on my Samsung Galaxy S4 and opened the Adventure Bot app and successfully connected and the camera video appears in the video frame in app as expected. Seems to be a windows issue?

When I was connected in the client mode and turned my phone wifi off and tried to connect through my 4G connection on my phone it failed to connect to the Robot. I port forwarded the IP Address of the Robot like this:

192.168.0.11 Port 23 192.168.0.11 Port 24

I forwarded both port 23 and port 24 on my router but still not able to connect. The above IP Address is the address that I received when I did a scan of my network.

Thanks for your help in advance ! Rick


ARC Pro

Upgrade to ARC Pro

Take control of your robot's destiny by subscribing to Synthiam ARC Pro, and watch it evolve into a versatile and responsive machine.

PRO
Synthiam
#1  

There is no known issues with the camera in ARC. Check the network settings, address or syntax. This happens often, someone updates and their project didn't actually work before the update:) or something on the network changed, such as the ip

If you could check the syntax that you typed into the camera address.

Also, you did not provide any information about the syntax of the address. For example..

"192.168.0.11 Port 23" is not proper network syntax.

It should be, for the camera: EZB://192.168.0.11

The 192.168.0.11 part should match what is in your Connection control address.

#2  

Yes I put the proper ip address in the field for video device and camera shows just fine.

Once I have the robots ip address, it seems I should be able to port forward the ip address and ports 23 and 24 on my router and access the robot from my 4g cell connection. What am I missing ? Thanks for your great help !

#3  

Hello DJ,

I spoke too soon ! I just connected to my robot over cell phone 4G network successfully ! Thanks again for your awesome guidance and support ! Rick

PRO
Synthiam
#4  

:D Any time! Sometimes those pesky gremlins are hard to find