Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
United Kingdom
Asked — Edited

New Ez-B Same Question And More.

Hi, afraid I'm on here asking for help again since I'm still having issues:(

When I got my first EZ-B this happened...

my original connection issue

I just got the replacement in the post. Powered it up and ... no blue light. The little red one flashes and it still connected to bluetooth on the laptop. But again I can't get it to connect to ARC or the firmware update.

Again I've followed all the steps in my first post with the same results. Am I doing something wrong?

Peter

#1  
What power source are you using? Is it the same one you used with the other board?
United Kingdom
#2  
That's exactly what I was thinking. Check your power source, make sure it's at least 6v and fully charged, better yet use a mains adapter to check it (I use an old 12v router power supply for bench testing).
United Kingdom
#3  
Hi Peter have you gone through the hardware diagnostics again? and do you have a meter to check the power to the board? and on the pins as shown in the hardware diagnostic video it sounds like power or an unsoldered pin maybe. Give it a really good look over. A psu or fresh batteries may be needed another thing flashing blue led make take a couple of seconds to start up
United Kingdom
#4  
Thanks for the quick responsed. I'm using 6 fresh aa batteries in the supplied holder, showing just over 9v with a meter.

Been through the diagnostic resistance and voltage as in the video both check out ok

There is no voltage to the Blue LED as far as I can tell.

I'll have a good look over the board tomorrow with fresh eyes
United Kingdom
#5  
and a magnifier perhaps
United Kingdom
#6  
Hi All, I finally got a short reprieve from DIY and am back on the case.

I've found an old router supply (thanks for the tip @rich), plugged it in and the blue LED is now working. I'll have a good look at the battery pack, it's showing 9v+ but there must be something wrong with it maybe the screw terminal isn't making a good connection, that can wait for another day.

Most concerning is that I'm still having the connection problem. Latest debug report from the firmware updater...

EZ-Robot OS Updater Version: 2013.06.22.01
24/06/2013 21:04:46 - Begin

Attempting connection on COM14
Comm Err: The operation has timed out.
BbytesToExpect: 1

Received:
Disconnected
Connection Failed: System.Exception: Controller Not Responding
at EZ_B.EZB.Connect(String hostname, String tcpPassword, Int32 baudRate)
Disconnected
24/06/2013 21:04:52 - Connection attempt error

Available Ports:
- COM14
- COM15

So basically the same symptoms as my first board. No response from the EZ-B. Visually everything looks ok on the chip and the solder joints to the chip all look ok to my untrained eye. What am I doing wrong?

Incidentally the laptop is a Dell Inspiron 1110 11z, Windows 7, 64-bit. It's about a foot away from the EZ-B
United Kingdom
#7  
I would bet on it being that it's a Dell. Is it the onboard Bluetooth by any chance? And with the Dell software?

From the looks of the debug message the PC isn't listening to the EZ-B. It could be the bluetooth dongle on the PC but it's more likely to be the drivers Dell package with their PCs. I'm always a little hesitant to advise it since it may cause issues elsewhere with other hardware/software (although rare) but uninstalling any Dell bluetooth software and drivers and reinstalling the device with the Microsoft bluetooth stack should hopefully solve the connection issue.

Before doing that, is it possible to check it on a different PC with a bluetooth dongle?
United Kingdom
#8  
Thanks @Rich I was starting to get suspicious that it may be something like that. I tried uninstalling the bt hardware last time, everything looks windows-like as in the tutorial video.

Not sure if it help you to help me but in device manager under Bluetooth Radios I have...
Dell wireless 365 Bluetooth module, Manufacturer: Broadcom, with Broadcom driver, Location Port_#0003.Hub_#0008
Microsoft Bluetooth Enumerator, Manufacturer: Microsoft, Location: on Dell Wireless 365 Bluetooth Module

Both report device working properly

I'll pop over to my Dads when I get a chance and check out with his pc and USB Bluetooth dongle. If it works I'll disable the onboard Bluetooth on my laptop and borrow his usb dongle to try.
United Kingdom
#9  
It looks like you have Broadcom drivers which may be the problem. The other problem is, the PC will probably want to install those drivers if you uninstall and reinstall. You may be able to "swap" drivers if you choose "update driver" in the device manager but like I said, I'm always a bit cautious about doing that since there are occasions when it messes things up even more and I'd hate to be the one who told you to mess it all up.
United Kingdom
#10  
Found this on Wikipedia Bluetooth Stack, I know it isn't always the best source of accurate info but this is at least references to a Microsoft BT FAQ document...

"Which Bluetooth host controllers does Windows support?
With Windows, a Bluetooth radio can be packaged as an external dongle or embedded inside a computer but it must be connected to one of the computer's USB ports. The Bluetooth stack that is included with Windows 7 and Windows Vista does not support Bluetooth radio connections over PCI, I2C, serial, Secure Digital I/O (SDIO), CompactFlash, or PC Card interfaces. "

Unless I'm reading this wrong it means that unless I plug in a USB BT dongle to my laptop and disable the onboard BT module it's never going to be using the windows stack, which would explain a few things.
United Kingdom
#11  
I bought a usb bt adapter and disabled the onboard one. The USB device shows as Generic Bluetooth Radio and is using a Microsoft driver in place of the Dell one but I still can't establish a connection, tried both COM ports, debug report as below, same response from firmware update and ARC...

Attempting connection on COM16
Connection Failed: System.TimeoutException: The write timed out.
at System.IO.Ports.SerialStream.Write(Byte[] array, Int32 offset, Int32 count, Int32 timeout)
at System.IO.Ports.SerialPort.Write(Byte[] buffer, Int32 offset, Int32 count)
at EZ_B.EZB.Connect(String hostname, String tcpPassword, Int32 baudRate)
Disconnected
Attempting connection on COM7
Comm Err: The operation has timed out.
BbytesToExpect: 1

Received:
Disconnected
Connection Failed: System.Exception: Controller Not Responding
at EZ_B.EZB.Connect(String hostname, String tcpPassword, Int32 baudRate)
Disconnected


Have I got another defective board?
#12  
@Peter let's back things up again. Anytime we change something in the scenario we need to start from the beginning. Do you have several Bluetooth serial devices? Its unusual to have com ports that high unless there are many others. First make sure the Bluetooth is showing generic Bluetooth stack. Remove any saved bluetooth profiles, apply power to ezb and within 5 to 10 seconds search for devices , connect. It will be named linvor. Enter existing Pair code 1234. It will remember the connection and install. Next remove ezb power for a fee seconds and reconnect. Once both ezb lights are blinking attempt connection with the firmware updater. , choose the lowest of the two com ports assigned to ezb. If it gives an error and asks if you want to watch the tutorial click no and try to connect again. Sometimes background stuff takes a few seconds and varies from PC to PC. Try it a third time if needed. The Bluetooth on ezb stays discoverable for 30 seconds once active to make a connection. Please make sure once you have a connection and firmware is updating that you DO NOT remove the power. Doing so could leave the firmware only partially installed and unusable.
#13  
Did you manage to discover the EZ-B bluetooth ?
#14  
Take in mind it won't say "ezb Bluetooth" at first. It will just say Bluetooth device
United Kingdom
#15  
I agree with Josh but why comm ports 16 and 7? I would expect them to be sequential say 15&16 or 7&8 odd. You may have just been unlucky with the dongle you got?
United Kingdom
#16  
I would say the new dongle gave the EZ-B the higher number COM ports when it was re-paired. So 16 and 17. Use the lowest of the two, so COM16 should be the one to use. However, windows can decide to do whatever it likes and set it to anything, but chances are it's COM16 you need to use.

If it hasn't been re-paired, re-pair it. Go to your devices and printers. Right click on the EZ-B (or Linvor) and check which COM port it uses (in the Hardware tab).

One of my EZ-Bs is COM17 and the other EZ-B COM18, a high number is not always an indication of a problem. Neither is having COM ports that are not sequential.

If you still struggle, I can always take a look at it if you have TeamViewer installed. At least that will ensure it's not a configuration problem on the PC side of things. Just say the word and we can arrange a time suitable.
#17  
The port assignment is not from the dongle , its the PC. He can easily delete the Bluetooth profiles and drivers then allow windows to install the dongle from OEM Microsoft drivers. Don't worry about "loosing information" its very easy to pair a device in the future but its important to clear out profiles accociated with the old Bluetooth adapter. Having high port designations suggest there's lots saved from previous Bluetooth activity.