Asked — Edited
Resolved Resolved by thetechguru!

Network Question:

Ok, here is what I have:

The ports are: Router Desktop MagicJack EZB 4 (Sally)

I have everything going into the router and then going to the Internet.

I have two wifi connections. One is for the Internet and one is for the EZB. If I hook up for the EZB, I loose the other connection.

I guess my question is: How do I hook it up were they are BOTH connected?

The ports are conflicting.


Upgrade to ARC Pro

Experience early access to the latest features and updates. You'll have everything that is needed to unleash your robot's potential.


Do you have two WiFi (or one WiFi and one wired connector)? You can't be on two wifi networks from the same adapter.

Is your other network in the 10.x.x.x subnet, and if so, what is your subnet mask. You can't have two adapters on the same machine in the same subnet.



Hey, Alan. I am not a Network professional. All I know is that on the Sally robot, I can connect to the EZB4 Directly. If I hook the Desktop to the EZB-4 I can also connect up. But, when I try to hook up separately to the Main Network, it doesn't work until I disconnect the eZB4. So from the Networks listed I have TWO that are a concern for me. This network is needed to control the Sally robot.

Everything works fine on the Sally robot. But,I am running TightVNC which lets me use the desktop to control the tablet. Without the control, it is extremely difficult to operate the Sally robot.

I usually fire everything up and then use TightVNC to control Sally. Then I can operate from the Desktop without too many back aches and neck aches, etc.

I hope I explained that correctly.


So, from what you are saying, maybe I can install a second wifi adapter to the tablet?

Before I sold the EZB 4s, I hooked it all up and it worked fine and I had control of it. But, I must have done something different.


Let me back up. Are you still connecting directly to the EZ-B 's own nwetwork (where its address is or did you get it connected to your router so it gets a 10.0.0.x address? (preferably 0.4 but you will need to tell the router to assign that address).

To have both EZ-B and Internet access, the EZ-B must be connected to the router and your computer must be connected to the router.

Alternatly, yes you could have a second WiFi adapter and be connected to both (and with your router address being 10.0..0.1 you would avoid the shared address space conflict) but that should not be needed.

To find your computer IP address, open a command prompt and type ipconfig [enter]

(I am making the assumption your router only has one network. Many new ones have more than one. Mine has 4)



Another thing. If you decide you need to go the two adapter route, let me know. I have a spare WiFi dongle I can drop in the mail to you. They are cheap, but it will save you a few bucks.



I have a Home-972 regular internet wifi.

The address of it is: Port 3389 my router is The ports are: Router Desktop MagicJack EZB 4 (Sally)

Let me do an ipconfig


When I did an ipconfig with the Home-94F2 connected, it came back: and

Thanks for the wi-fi dongle, but I have got one.

and with the EZB4 plugged in:


What that tells me is that you don't have the EZ-B talking to the router yet. When connected to the EZ-B network, you need to open your web browser and connect to

From there you can tell the EZ-B your home network's SSID and password. It will reboot and connect to your network and get a 10.0.0.x address.

Then you can connect to your router with your PC. Log into it and find what address it assigned to the EZ-B and tell it to always assign to that MAC addess (instructions vary by router brand).

From then on, you will be set to have Internet and EZ-B on the same network.



OK, so I found a USB hub and an N type Broad-com WiFi adapter.

I hooked it all up and it installed the drivers. They all went in fine. I had to search for a place to tell it to hookup to WiFi.

When I connected up to it, It kicked off the other WiFi connector. And when I hooked the other up, it disconnected the previous WiFi.

My batteries are almost dead now, so It will be Monday before I can test it again. And do the procedure outlined above.

Thank You for all of your help.


MovieMaker, please don't create duplicate threads:) you have the same question asked yesterday here:

I answered your question in the other thread. Did you read the answer? Did you try what I suggested? What part of my response is giving you trouble?


I was talking about networking in the second thread. And I was talking about hooking up the V4 in the first thread. I did not realize it was asking the same question.

I went through the steps that you laid out and I got the V4 to work just fine with the V3 working also. But, I did not quite get the networking part of it with tightVNC.

Sorry. blush


Ok, I changed everything to client mode. But, I still cannot hook to the net while hooked to the ezb4.

I have my desktop going to the router and then to the internet. I have two wireless connections: Home-4F92 and EZ-Bv4 07C8. When I connect to the EZB connection everything works on the W3 tablet. But, I cannot use the Net. I have to change connections. The problem is, it is very hard to take the tablet off of the robot and make the change and then change it back again later.

I have it in client Mode.

Please, Help!


What colour is the led on the ezb4 when it boots up... Green or Blue?



I have tried the procedure 100s of times. I am trying to get into client mode. The ONLY way to do this is to turn off the internet.

It is an Xfinity router.


That's what I thought.... @Mel, blue means you're still in WP mode... You are NOT in Client mode... Client mode is indicated by a green LED... I would suggest going back to the videos that DJ posted and view them over again... Again follow the videos religiously.... Keep it simple, one step time... This is very, very simple if you just follow the videos....


At what point is the process failing for you? Are you able to bring up the ezb server in your web browser?... How far are you getting?


You don't need the internet to get the ezb into client mode.... Forget the internet for now... You'll get it back once you're in Client mode... Right now it's just your PC and the ezb...


I seem to have two modes. I have one that the internet if full speed ahead. That is where I can get the internet.

Then I have one that I hook up to the EZB. It works, but not internet.

It is failing me when I try to put it in Client Mode.

I pull up the wifi and hook it to the EZB. It says limited.

I have an SSD: for my router. I put that name in. Then I put in the password. Then I hit send or enter or whatever it says.

Then the EZB turns RED. It tells me it cannot hook up.

I manually log in to the router and it logs in just fine.

Routers SSD: home-4f92 IP address:

I am pretty much following the videos. But, when I try to get into client mode, it won't let me.



Ok, I will forget about internet and try to get it into client mode.


You don't need the internet to connect and change modes on your ezb... Once it is successfully in client mode you will be able to connect to the ezb and the internet at the same time.... What you are essentially doing is the same as adding any other wifi device to your network... like your cell phone or a wifi printer.... It's the same thing except it's your ezb and not a wifi printer your adding to your network....


It won't let me get into client mode unless I give it an SSD: and password.

It just reboots and turns RED.

I looked in the device manager and there were no problems there.


Client mode requires your router SSID and router password. That is how client mode works. Just like any other device you want to connect to your router.



@Mel so what's the problem?... give the ezb your router's password and name of your ssid... Why the hesitation? How is the ezb4 going to join your network if you don't give it the name of your network and the password? If you bought a new computer wouldn't you have to do the same in order to connect to your wifi network?

Forget the device manager... stay focused on what your doing...


I have just quit if for today. My brain is going in circles. But feel free to leave advice if you think of something.


I am STILL having problems!

On my wifi, there are many connections, but there are TWO connections that are of concern for me. When I hook up with the V4 I get the following:

First Off, the v4 hooks up to the Sally robot fine using the EZB wifi. But, no net.

The second connection is my router. When I connect to it, my tablet can get internet.

I can't get into client mode. I have did this EXACTLY like the videos show and When it get's to the point to enter in my SSD: and Password it WON'T connect. It is as simple as that.

I have tried a hundred times over the last two days.

D.J. or someone, Please Help!

Thanks in Advance Mel



Both SSIDs and Passwords are case sensitive. Make absolutely sure you are typing it correctly.



Are you actually entering your password and SSID or you just stopping there?... What happens when you enter your password and ssid and then click connect? What does the ezb say or do when you click connect? The ezb should reboot and now should flash a green LED... and state that it has successfully connected to your network Important make sure your password and name of your wifi network are correct


The ezb4 reboots and says it cannot connect to the network. I enter the ssd and password as I always do to get into the system.

I can connect in ADhoc Mode just fine. But, I need to have the internet in order to control the tablet from the Desktop with TigthVNC which had previously worked great. If you know a better VNC type program, I am happy to try it.

OOOoops! my wife is calling for her meds. I will be back THU. got to go give her her meds and take her to the doctor.

thanks guys!


Are your batteries fully charged? I sometimes can't get or hold a connection even before the low battery warning comes on, especially when I am using 6 NiMH AA batteries instead of a Lipo, particularly if I am an another room from my router.



Maybe I am not being clear enough.

The ezb3 works and the ezb4 works fine. I can connect to both of them at once.

I can only connect to the internet when I disconnect the ezb4 because there is some sort of conflict.

The problem is that I have the tablet built into Sally. In the past, I have used tightVNC to control Sally from my Desktop.

But, I cannot use tightVNC to control Sally because it uses, the same as the V4.

I need to change ONE of the ip addresses, but I don't know how.

Once I install the tablet back on to the Sally, it becomes much harder for me to get to and change things.

That about sums it up.

Thanks for all of the advice from you Wonderful People!


The symptom you are describing ("I can't connect to your network") does not match what you are saying here. That is not an address conflict, it is an incorrect SSID or password, or inability to reach the router.

That being said, if you want to specify an IP address for the EZ-B, you do that in your router through something called Address Reservation or Static DHCP or something similar (different names for different routers). You tell the router the MAC address of the EZB and the address you want it to have.

The MAC address of your EZ-B is 00-07-80-01-07-C8

Once is is on the network, you would use TightVNC to connect to the computer, not to the EZ-B at Also note: until you have a reserved IP in the router for the EZ-B, if you do not have the desktop connected to the router before you boot the EZ-B, the EZ-B will grab the lowest available address, so it will be trying for




"I can only connect to the internet when I disconnect the ezb4 because there is some sort of conflict."

No, the reason you can't connect to the internet and the ezb4 at the same time is because your ezb4 is still in WP mode.... As mentioned many times, once you get your ezb into Client mode you will be able to connect to the ezb4 and internet at the same time...


OK, I have made a step further. I have Uninstalled TightVNC on both Desktop and Tablet. It now tells me to connect to I tried both and without success. I give it the password,but it doesn't accept it. But, that IS a step forward.

My Network map shows:

router: Desktop: magic-Jack: 10.0.03 and Sally:

Do you think that Sally is conflicting? because she has . How would I change that?


I have tried Everything. .... I give up. I am going to let it set a while.