Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Myo Armband

Hi everyone,

I've been trying to connect the myo to my ez robot, JD and for some reason I can't get it to work. The myo is functioning properly on its own. It picks up on all the movement and gestures, however, when I'm using ez builder, the myo control panel barely picks up any of my gestures. It's picked up about 3 gestures over hundreds of tries. I've tried reinstalling ez builder, re-calibrating the myo, and resetting JD, but nothing seems to be working. I'm unsure what to do from here and any help would be great. Thanks!

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
PRO
Synthiam
#1  
The myo uses the same gestures as the the myo software because it uses the myo driver. There's nothing ezrobot software can do differently because it responds to the gestures that myo recognizes.

I can recommend checking the myo forum or their support for additional tweaks or tips of their software.

Ezrobot has no ability to modify the myo software or drivers. Nor can we support their project.

Hope that helps!
#2  
The myo is recognizing all my gestures even while in ARC. We've even pulled up the window after you have calibrated where it shows you the poses you are doing while in ARC. The myo is recognizing all our poses, but the myo control panel in ARC is not picking up these gestures.

I'm not sure what I would ask the myo forum because the myo is working as it should.
#5  
Yes, those are the standard poses for the myo I'm talking about. The myo recognizes those and works perfectly fine on it's own, however, as soon as its connected to ARC the myo control panel does not pick up those gestures. It only seems to recognize the rest pose. I've looked through the tutorials multiple times. I'm just trying to implement a simple script for opening and closing JD's claw using the spread hand and fist gestures. I've tested the scripts and I'm using exactly what the tutorial says to use.
PRO
USA
#6  
It's a wild guess but if you want to try...

1) Close ARC

2) Open explorer, go to the ARC folder e.g.
C:\Program Files (x86)\EZ-Robot Inc\EZ-Builder

3) backup the file myo32.dll

4) unzip the new myo32.dll i got it from the windows myo sdk 0.9.0

myo32.zip

4.1) unblock the file, file properties Unblock Button / Checkbox
4.2) copy to the ARC folder

5) Start ARC, test

5.1) If does not work, close ARC and replace the myo32.dll with your backup.
#7  
I tried what you recommended, but it didn't end up working. I posted in the myo forums to see if they have anything to say, but I honestly have no idea what's wrong with this. When I was using it today, the myo control panel recognized that I calibrated the myo and that it was on my right arm, but it would only pick up when my arm was at rest. It actually ran my spread fingers script when I wasn't even trying to do it!