Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Netherlands
Asked — Edited

My Kensington 2.1 Bluetooth Doesnt Connect.

Bought a Kensington 2.1 Bluetooth for it.

It shows a list of ports to select from, none of them work



Any help ?

#1  
Did you install Kensington BT drivers, or just let Windows install the Microsoft BT stack? (Windows 7 should recognize it without adding any drivers).

EZ-Robot only officially supports the Microsoft stack, and using it has solved virtually every BT problem I have seen reported here.

Alan
Netherlands
#2  
i have vista, and i had installed the Drivers coming with the Bluetooth at first.


Now i have Deinstalled those drivers, and have my standard windows drivers.

Still, no dice.

It wont work.


And do i have to 'link' with them ?

Cause if i see my Ezrobot. it asks me if i wantt to link.

And is my ezrobot called Linvor, or am i detecting other Bluetooth in my room ?
Netherlands
#3  
I have deinstalled all the Bluetooth drivers.
When i came back, it showd as empty,

But as soon as i put the USB Bluetooth inside the hole, one of the old UNINSTALLED drivers shows up.


How can i remove that forever?


I've never seen uninstalled drivers come back by itself..

is that whats wrong ?
User-inserted image
#4  
Windows will reinstall drivers for devices that are installed on your computer at each reboot I think. Just because you uninstall them in the Device section does not mean they are deleted. In the past I had to find the driver in the Windows folder or sub folders and manually delete them there. You can do a windows search also and delete it that way. Also another possibility would to see if the install program that came with your Bluetooth device has an Uninstall feature on it. Another possibility would be to look in the Program add/remove section of Windows Control Panel.

BTW, I love your picture and handle. Very cool!
#5  
To get rid of the Kensington drivers, you might want to do a system restore to a restore point from before you installed them. May or may not work, but rarely hurts anything (unless you have made a lot of other changes since then).

Alan
United Kingdom
#6  
Windows will reinstall drivers on restart or on "scan for hardware changes" if it thinks it's unknown.

You could try just disabling the RFCOM bluetooth and try that, leaving just the generic bluetooth radio and the microsoft bluetooth enumerator.

Then add device in devices and printers (power the ez-b, right click in the devices and printers window, add device, pick the EZ Robot, pair, code 1234)


Or, try to update drivers (from device manager) and pick from the list, pick the Microsoft ones if they show up.
United Kingdom
#7  
Sorry, just noticed you said you use Vista. I'm not sure if it's the same in vista but the idea is the same, options may be in another area of control panel.
Netherlands
#8  
Was fooling around with the Software installer.

Found somehing called 'toshiba bluetooth stack' there.


Uninstalled.

Thanks for that tip dschulpius, would have never looked there.



Im rebooting it now. seeing it it works now..
Netherlands
#9  
still no dice.

I have the Generic Bluetooth Radio, and the Generic Bluetooth Enumerator.
Netherlands
#10  
When i try to connect to one of the list of Com ports.

It pops up that it wants a password ?
Netherlands
#11  
i still have this error btw



Attempting connection to COM3
EZ-B reports EZ-B Firmware V8,5
Connected
Usending ping
Usending ping
Usending bootloader
Failed to load bootloader!
Have you selected the correct EZ-B COM port? Use the Help menu option to view the online help and watch a video demonstration




..
USENDING Ping?
United Kingdom
#12  
Are you sure you are using the correct com port? The "EZ Robot" device adds two ports, one for the ARC/EZ SDK program and the other for updating the firmware.

Try removing the EZ Robot device in devices & printers, then adding it again, pairing it with the code 1234.
Netherlands
#14  
its working now

thanks
United Kingdom
#15  
What was it in the end? (It'll help anyone else who searches with a similar problem)
Netherlands
#16  
It was the uninstalling of the drivers that came with it. (Cd of Toshiba drivers)

Then, i had to seek under the Software Installer for the 'toshiba bluetooth stack'

And deinstall that.

After that, i had to reboot windows.

And let the bluetooth be found again by windows.

After that, i also had to 'pair' the connection
And type in '1234' as code.

** like discribed in this Tutorial Page


..
And after that, no problems. could just opdate:)