Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Dunning-Kruger!

Maxbotix Question

I know that this sounds crazy, but . .

I removed six working maxbotix EZ0s from the LEAF robot that I disassembled. They were all working.

I wired them as directed (no brainer.)

None of them worked. I hooked them to the ADC ports. I tried all ports and all sensors.

I tried several ways of wiring them. No soap.

I even tried them on Digital.

I am beginning to think my ADC ports are not working.

Thanks!

#1  
The next logical thing to do is test your analog ports... Surely you have a sharp IR detector lying around to test them with? Maybe a potentiometer too?.... It is highly unlikely you have blown the analog ports... My guess is that you are still confused for some reason on how to use the EZ sensors.... Plugging them into the analog ports is just as easy as plugging in the sharp IR sensor.... 3 wires Mel that's all...
#2  
I had about 12 of the sharp sensors. But, I have threw them all away one at a time after testing them and they not working.

I need to regroup.
#3  
Look at the back of the EZ0..... put your glasses on... follow the steps below exactly...

1) See the pin that is labelled GND? Plug that into the ground pin on adc0
2) See the next pin +5? Plug that into the 5V pin on port adc0
3) See the pin labeled AN? Plug that into the last open analog pin on adc0

Open the read analog value control in ARC.... set it for analog port adc0... Now read the values
#4  
How did you possibly ruin 12 Sharp IR? I still have some that I used 15years ago when I was using the basic stamp that still work perfectly.... You know you probably threw out 12 perfectly good IR sensors....

Yes, good idea re-group.... Step back and think before you wire things up.... Wiring electronics seems to give you a lot of grief.... Just take your time and triple check your connections before applying power....
#6  
1) Do you have a potentiometer? or any other analog device?
2) Are you sure your ezb3 is connected to ARC? A flashing LED on your ezb means it is not connected to ARC
#7  
Cycle the power on your ezb3 and then re-connect to ARC....

I have 4 MaxBotix EZ1's, all of which work fine in analog mode...
#8  
I will do this as soon as I can. My wife is having some health issues and is taking up a lot of my time.

I should have a pot in my toolbox.

thanks,
Mel
#9  
How do I hook up the Pot to test the ADC port?
#10  
C'mon Mel what gives?.... You said you been doing robotics since the 70's.... What happened to all that knowledge? This is basic stuff dude.... No wonder you're so frustrated...
User-inserted image

User-inserted image

User-inserted image
#11  
You still haven't confirmed that your ezb is connected to ARC when you are trying to read the analog ports...
#12  
@Mel

Use a 100k pot...that'll give you a little bit over a 180 degree turn....if you're trying to replicate a servo...I use that to read the positioning on my dc wormgeared motor...
#13  
Thank You guys.

The way I know that the ezb is connected, I operate the unit with the movement panel. If it goes forward, I know it is connected.
#14  
Rich, I understand your not understanding me. I am pushing 70. I was an Engineer for 9.5 years, but I have been cut down by aging. Age and disease can knock a man down where he is not as strong physically or mentally. I would say after doing this for 41 years, I am back to almost Entry Level.

sorry.
#15  
I wonder since these boards have traces on both sides, And I soldered the wires to the pads on ONE side, could it be that I needed to place the leads inside of the holes and let the wire be soldered on both sides?