Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
United Kingdom
Asked — Edited

Laptop Connection Questions

I am on a hp laptop running windows 7 with avast disabled.
When I turn on my EZB it says that it has successfully connected to my network and when i try to connect to my EZB in client mode it connects and then disconnects after a few seconds, I then get this message:

EZB 0:
EZB 1:
EZB 2:
EZB 3:
EZB 4:
Attempting connection on 192.168.1.1:23
Connection Failed: System.TimeoutException: The operation has timed out.
at EZ_B.EZB.Connect(String hostname, Int32 baudRate)
Disconnected
Attempting connection on 192.168.1.5:23
Comm Err: System.IO.IOException: Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
--- End of inner exception stack trace ---
at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
at System.IO.Stream.ReadByte()
at EZ_B.EZB.drdP31fe7H(Int32 , Byte[] cmdData)
BbytesToExpect: 1
U
Received:
Disconnected
Connection Failed: System.Exception: Controller Not Responding
at EZ_B.EZB.g0KPD37NHh()
at EZ_B.EZB.Connect(String hostname, Int32 baudRate)
Disconnected

The EZB can connect when I try it on my dad's computer.

Any help would be great.

AI Support Bot
Related Content
Synthiam
#45  
Turn on your robot ,What ever your network is go and disconnect it , then connect the one that says some thing like ez-bv4 then after that, go into ez robot press the connect that says zero and it should connect.
#46  
Why is V4 showing up on Wireshark as a DHCP server?

Other devices are (ie. I phones) are getting ip address with no gateways.


User-inserted image


I need to be able to turn this off.

I have my router set to fix IPs based on Mac addresses but this is also a problem connecting 2 V4s on same project.

This is a real disruption to network, especially when connecting phones and tablets.
#48  
It needs to be fixed if you want the V4s to be connected to local network or any network.

When these V4 units are on line and another device comes up and is looking for an IP address, the V4s are providing DHCP services to that device, assigning an IP to that device. This happen especially if you have multiple V4s on line or same robot.

This is no good and needs to be corrected, not just from the stand point of multiple V4s but all other devices.

When it does provides DHCP to the network the gateway is not assigned properly and the other devices cannot get out to the internet. Devices are designed to find the first DHCP and get the assignment.

I was having a hard time figuring out what the problem was until I used Wireshark to find all DHCP servers on the network and the results are in my first reply.

The InMoov robot I am creating uses 2 V4s and I was having difficult time keeping same IP even though I was setting the Mac addresses on the router to the V4s so they would always have the same IP.

We cannot get fixed IPs on V4s I think this is the only way.

There needs to a solution so that I can keep the V4s running constantly with screwing up the network.
#49  
@jackphillips1953

The new com board that is coming out soon uses a totally different WiFi chip and should not have this problem. (price and release date not announced yet, but DJ did say we would be able to upgrade existing EZ-B's and not need to buy new ones to get the new board). If the price of that is too high, possibly changing your router to one that responds faster to DHCP requests could be an option. The EZ-B only responds if it doesn't see another response on the network before it's timeout. EZ-Robot never saw the issue using D-Link routers which is why it was so hard for me to convince them of the issue. I do see it on TP-Link routers, which I otherwise love.

3rd option is the programmer that DJ discussed in that thread. I haven't had a chance to try it yet, but I believe you can use it to turn the feature off, or even give the EZ-B's static IP addresses on the network.

If I have time to get it figured out, I might set up a service for USA customers (don't want to deal with international shipping) to reprogram their EZ-Bs, but I'll say now that my time is very short so I don't know when I'll get around to it.

Until I got my new router (I upgraded to higher speed FiOS and Verizon replaced my router with one that responds very fast) I made sure to assign my EZ-B's the lowest available octets on the network and always started them in the same order. That solved the issue with the EZ-Bs not getign the expected addresses but did not help with other devices on the network starting after the EZ-Bs. Not satisfied with that, I got a cheap travel router (again a TP-Link that had the same slow response issue, but this was before I realized it was timing related) and plugged it into one of the LAN ports on my other router, so I was able to give the EZ-B's their own network on a different subnet. The routers handled passing traffic from PCs on the home network to the EZ-Bs on the robot network.

Alan
#51  
What has to happen is the when attached to network the DHCP server on the V4 must be turned off. No reason for it to on unless in AP mode.

I have 4 of these units plus 3 V3 and not going to replace these units.

I have done the static already using Mac address on router and no good.
#52  
So, only way to do that with the current chip is to get the PIK programmer described in the other thread and here: http://synthiam.com/Products/ARC and make a firmware that turns off DHCP. It can't be done from ARC or through a remote firmware updater.

The PIK programmer was really cheap (I think it cost me $16 shipped). I just haven't had time to work with it yet.

I may try and find some time this week. It is pretty much just you and me that are experiencing this issue, and I solved it when Verizon replaced my router, but it would still be an issue if I take my robots somewhere and use my travel router.

Alan
#54  
BTW - I cannot believe other not having same issue. They probably just keep rebooting V4 and reset IP.

My equipment here is not that old and I may want to place this on a work network and cannot afford to have blow up DHCP on that network.

Thanks again.
PRO
Synthiam
#55  
Jack - it's a silly implementation of the dhcp on that module. It really isn't something that we're proud of, but it was the only capable module at the time available when the ez-b v4 was designed. The upcoming ez.b v4.x/2 will be available as an upgrade, which is an entire new communication board replacement. It is faster, has an up-gradable firmware and was custom created by ez-robot entirely rather than depending on a third party product.

In the meantime, if you wish to remove the dhcp completely from that module, the latest firmware is available in the Software section of this website - labelled OpenIoT. As alan mentioned, it requires a piece of hardware, which is less than $20. The links and all necessary information is provided to you with a step by step instruction.

Simply click on Software and the Open IoT link to get started.
#56  
Everything works great with my set up... and I use a cheap $40 Dlink router to boot... No rebooting needed... I assign all my ezbs static IPs and Bob's your uncle... Works great...:)
PRO
Synthiam
#57  
Yeah - it's just some routers. The module does adhere to the dhcp rfc, but many network hardware does not - so some people like Jack run into this problem. Thankfully they released a new firmware that is available for download in the Software section of this website under the Open IoT link.
#58  
It seems no one with a dlink router has the issue. It all has to do with how fast the router responds to a dhcp request. If the ezb doesn't see a response fast enough, it responds itself. Would not be bad unless you want static ips, but it also doesn't supply the dns, so other essentially lose their internet access (they would still work for ip routing, but no name resolution).

DJ, are you saying the new firmware on the IoT page already fixes the issue so I just need to load it and don't need to modify it? I'll test that tonight. I may try to play around with some modifications too.

Alan
#59  
OK, I got the PIK programmer working.

Note to anyone else, the header supplied with mine did not fit tightly in the holes in the EZ-B. I had to hold onto it and push it to the side to make sure it had a solid connection to the EZ-B throughout the programming time. A little scary, since I imagine it would be easy to brick if it failed part way through).

I changed the SSID, and also figured out that it changes the MAC address and figured out how to change it back.

I haven't figured out how to turn off DHCP (either in client or AP mode) yet, and I haven't tested to see if the new firmware already fixes the issue in client mode. I need to reconfigure some things on my network to test that and my wife is using the Internet tonight, so I can't do that testing until tomorrow at the earliest.

I do see from the Blue-giga documentation that I can add a switch to the web config page to turn DHCP on and off, so if it isn't fixed and I can't figure out how to force it off just in client mode, I can add the switch to the web page, just need to figure out how the current page it written (and I am hardly an HTML wizard unfortunately) to add a check box to turn it on and off.

I think it is probably possible to do static IPs on your network with the SSID and password pre-configured, but I haven't quite figured that out either.

Alan
#60  
Would help if I read the changelog.

Quote:


2015-10-31-00
-------------
- Totally disable DHCP when in station mode.


So, looks like just loading the new code does the trick.

@jackphilips1953, it was pretty easy to do, and the programmer is cheap, but if you want some help, send me an email so we can discuss details offline (my email is in my profile). I am thinking you could mail me your EZ-Bs (either one at a time or all at once) and I could program them for you and mail them back. Alternatively, I can loan you my PIK once I am done with it if you are up to doing it yourself.

@DJ, Recommendation for the instructions.txt would be to also change the MAC address, not just the SSID. Otherwise users with multiple EZ-Bs could have a new problem. It was fairly obvious to me where and how to change it, but it might not be to everyone.

Alan
#61  
Thanks for the help. I will look into reprogramming as per you details above.

This is something should have had been addressed when introduced.

Especially when you have 2 or more V4s on the same wireless network that is not used for a router to the internet.

My modem and router in basement and I have to have a Access point with DHCP turned OFF for me to able to use throughout the house located above ground.

Of coarse when the V4s come up and 2 are on the same wireless they will go to the first DHCP they find which is probably the one on the wireless.

Also hopefully this will be addressed in the update for the V4 and included in the V5s.
#62  
@jackphillips1953 1 or 2 people who suffer from this is hardly a need for a redesign.... but @DJ being the consummate, accommodating guy that he is decided to do something about it anyway.... If it were me with your problem I would not waste any energy complaining about it but instead do something about it myself... That's just me though... To me it is such a minor issue in that it is easily solved by a cheap router update (dlink) (instead of fumbling with reprogramming and risking "bricking" your wifi chip)... just my opinion, however...
#63  
It wasn't addressed on release because EZ-Robots didn't know it was happening. It doesn't happen with their Dlink routers because their DHCP servers respond faster than the EZ-B.. If you look at the other thread, I had a knock-down/drag-out with DJ to get him to see that it was actually happening, and then it took months for Blue-Giga (the chip vendor) to get back to him with the root cause. (similar to what you did, I used wireshark to figure out what was going on).

This is kind of typical for first release consumer electronics. You don't know what you don't know, but you learn and make it better. The new comm board currently being developed uses a different chip and doesn't have this issue.

Alan
#64  
Hi,

Thank techguru for response. I can understand that have manufactured and sold products in the past. You really do not know sometimes until you get in the field some problems.

Hey Richard .. is probably a bigger problem than you think and I am not knocking down anyone. I was not wasting y energy and I found out I was not alone and what I discovered was true. If these problem are not brought up then how can they be fixed?

It has absolutely nothing to do with Linksys or Dlink routers so stop that. I also swapped 3 different Access points with the same results.

I have over 20 other devices on this network with absolutely no issues connecting.

No ones whining just trying to determine how to handle a complex issue.

BTW- If EZ wants this to go big time with industrial applications possibly, instead working with just toys, a problem like this need to be addressed properly. Since this is the way they want to handle issues on a community board and it bothers you, talk to them.

I would have had preferred to keep this private anyway.

Good luck with your project.