Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Rich!

I Think I Am Being Thick Headed:)

Ok, so I've been having problem after problem with my project... I finally got my dynamixels working correctly again. The bad news is that I am completely confused as to *why* let alone *how* its working. Maybe someone can explain it to me. I'm pretty sure I am just being dense.

I have a string of Dynamixels (read: fancy servos). In the past they worked well but this weekend they all stopped. I presumed it was due to the recent dynamixel related bug that's been discussed here.

A few minutes ago, I wanted to clean up some of the wiring, I removed all sources of power and disconnected everything.

I added a servo/dynamixel breakout board/splitter that has a common external power bus (seperate input power), ground and signal line which is shared by all ports. This just allows me to connect multiple strings of dynamixels.

I applied 12V of power to the breakout board, and tested pwr/gnd was the same across all dynamixel connectors. It is! I confirmed theres a lower voltage and continuity across all signal pins, confirming that they are shared.

With that tested, I removed power, connected my string of dynamixels to the breakout board.

Here's where it gets weird (or it exceeds my understanding)... I connected a 3 wire cable from the breakout board to the EZB4... Now, you all might be saying, whoaaaaaaa, stooop! The EZB4 lit up, booted, started fine. It's important to remember that the EZB4 was not connected to its own battery or power source at this point. I quickly unplugged. Wasn't my mistake that I should have clipd power/grnd before connecting that cable to the EZB4 because it only needs to drive the signal portion? Right? I thought it over, called myself an idiot for a few minutes..... But then I thought, wait a minute, 12V is fine for the EZB4, and I already had all my 5V Servos disconnected (along with everything else), and these darn Dynamixels haven't been working, so lets do a test. I plugged it back in and what do you know, the Dynamixels worked perfectly for me. No fiddling with servo-speed, nothing.

My questions are:

I was a little shocked that I could apply power to the EZB4 via output pins. Maybe this is normal but it did surprise me.

If I had, had the battery plugged in and connected the breakout board, what would my voltage have been? 7V (ezb4 battery), 12V (breakout board), 19V (combined total)?

Why would this setup allow the dynamixels to work whereas a more typical configuration caused quite a few dynamixel related issues.


Upgrade to ARC Pro

Your robot can be more than a simple automated machine with the power of ARC Pro!

United Kingdom
I know very little about dynamixels so can't answer those questions. However, I can answer the voltage one.

7V battery powering the EZ-B + 12V supply fed through the digital ports Vcc and Ground would be the two batteries in parallel.

Parallel batteries don't increase the voltage but increase the capacity. Series batteries increase the voltage.

So you would have 7V and 12V batteries in parallel. The voltage is total voltage divided by number of batteries. So in this case, (7+12) / 2 = 19 / 2 = 9.5v
It's because the power pins on the ezb v4 are directly connected to the input power pin.
Thanks Gents!

The best explanation for the dynamixels is likely that there was a poorly seated connection and that redoing everything fixed it:)

Still got get the ezb camera sorted, but things are looking up!