Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Hifive - Good Things Come In Two's

Well, HiFive has been repaired. Firmware 15.3 is available for download again.

The bug was between the two different bluetooth modules from the two versions between 3.1 and 3.0. The differences are minor, and not many can recognize them. But there is a strangeness with the bluetooth communication that we discovered today:)

The great thing about the 15.3 binary is the file size. It's 22,200... So as the chinese say, good things come in 2's:D ... Let's hope this is the one! I think you'll be very happy with this new firmware.

If you had been a victim of the buggy 15.3, it'll be a bit of trouble. You'll need to recycle the power quickly once to receive a pulsating LED, rather than the steady LED.

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
#2  
YaaaaHooooooooooooooooooooooooooooooooooooooooo! I finally got "High Five " update to my ARC!!!!!!!!! Looks Like I'm ready to go. I will be trying out all the new features today. THANKS DJ!
#3  
@ DJ. New problem. I plugged in my older board and got the firmware update message. That board is on COM 3 (and COM8) when the update window opens it shows COM 31 instead of COM3. I tried highlighting it to correct the COM number and it won't let me do it. How do I change the COM port number in the update window?
Thanks
#4  
D.J.

I was impressed with you before. But, even more after. The way you had the confidence to say I am going to fix this Today!

Amazing!

I hate to rain on your parade. But, I still have to use to trick to connect. My board connects up about every 5 to 20 times randomly.

Really Sorry to give you that news. You must've had more than two types of bluetooth adapters.

Thank You for all your hard work.

Mel
PRO
Synthiam
#5  
Thank u everyone:)

Lloyd that's a know bug with windows. You'll need to delete the eZb from your Bluetooth devices. Reboot the computer and re add the eZb.

It's frustrating but windows can sometimes be a jerk:)
#6  
D.J., I think the answer for me is going to have to get the software loaded and ready to connect and then power up and connect imediately. I have a much better sucess rate that way. If I wait 30-60 secs, the white light starts pulsing and it does not connect. But, if I connect right when I turn on the power it seems to work. So, I guess this is working.

Thanks again for all of your help. You are a Gentleman and a Scholar and you have earned my Respect.

Mel
PRO
Synthiam
#7  
@MovieMaker is that with the buggy 15.3 or the latest 15.3?
#8  
It is with the Latest. But, I can work around it, I guess.
#10  
Hi DJ,

I have the buggy 15.3. I am not sure what you mean about cycling power quickly..when does that need to happen?...and will this be needed everytime? On powerup I have pulsing heartbeat....but when I connect, BT only stays connected for about 5 seconds..then disconnects. I have also removed and re-added the BT adapter and re-paired...no luck.

v/r

Kevin
#11  
I don't want to tell you what to do. But, I will tell you what works for me. You plug the power in and then out and then back in again. This could be dangerous to your cpu. Then try to connect as soon as possible. I get the software all ready where I can just hit a connect button. A percentage of the time, it will connect. If it doesn't repeat the procedure. This is only a temporary fix, but it does connect eventually. I have had to do this between three and twenty times.

Hope that this helped.

Mel
#12  
@ MovieMaker,

Are you saying to do this with the Firmware Update software?

It is not clear from the forums if the firmware or the sofware was buggy..or both?

I did the power cycle to try to reload the firmware...when i do I get the following:

Connected
Your EZ-B has the latest firmware. There is no need to update.

I click the upgrade button and get this:


sending ping
sending ping
?sending bootloader
Starting Boot Loader...

Failed to load bootloader!
Have you selected the correct EZ-B COM port? Use the Help menu option to view the online help and watch a video demonstration.


Now when I try to launch ARC (the fixed one) I get the follwoing:
Invalid Firmware Version. Please Upgrade.
EZ-B Reports v1. This copy of ARC requires v15.3

Any ideas?

v/r

Kevin
#13  
@ DJ
Thank you DJ , you solved my problem. You are just a whiz !!!!!!! Everything is running great ( he says with fingers crossed). All the improvements are GREAT! At least the ones I've tried thus far. Thank you !!!!!!!
PRO
USA
#14  
I know you are busy, any chance of a revised manual or some videos of the new features?

Will
#15  
@KKEAST,

I installed new ARC and ALSO firmware. I think it was the FirmWare that was Buggy.

I think you need to run the program EZB Firmware Update. This can be found in the Startup Menu under Programs/ ARC. this will update your firmware. But, it has to hookup to the right com port. Most of our ports have changed. ie; my port was on Port#3 but now is on #5.

Hope that this helped you Kevin.

Mel
#16  
@Mel,

Yes it does and confirms what I did. Thanks! I finally got it to update I believe. I am experiencing problems with some of the digital ports and there are several others reporting this as well. It appears the higher number ports D14 and up will sporadically toggle high. We shall see how this works out...but it currently makes my H Bridge on my bot not work correctly. I have no doubt DJ and his crew will be looking at this.

v/r

Kevin
PRO
Synthiam
#18  
I can reproduce the sporadic high ports. I've been working on it all day and night. I have a few ideas on how to fix it. I'm still trying to figure out how it's even happening.

We'll know more tomorrow
#19  
DJ,s code is making a life of its own!:)
PRO
Synthiam
#20  
@ww321q LOL:)

I have a new firmware fix for this bug. Sorry about that! It is such a strange issue - it took me nearly 20 hours to diagnose and fix.

With the result of fixing, i've increased the servo speed resolution also. My brain feels like it has melted.

We are heading out for lunch. I'll post the update when I return and we've ran a few more tests:)

I'm a bit sad to have released my first firmware bug:(
#21  
I wouldn't feel to bad DJ. Its hard to catch everything when its so complex. Look at the bright side. At least you didn't send a probe to mars with the soft ware running in to different different forms of measurement:)