Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Gps

DJ, Do you have any tutorials for using the GPS functions?
I have a Bluetooth GPS that works fine on the PC. I can see the GPS data streaming in Hyperterminal. But ARC doesn't show any data. It says it's connected to COM 3, but no data.

AI Support Bot
Related Content
Synthiam
#1  
Mine is also connected into ARC but I have the same problem with my project. A tutorial would be great. I know someone here has it working
#3  
Thanks for the link. Hyperterminal shows the GPS is sending NMEA data streams. Baud Rate defaults to 2400, but I was able to change it to 9600 and still receive the data. It just doesn't show in ARC. I will have more time this weekend to work on it
United Kingdom
#4  
Well just tried Hyperterminal and it auto detects the GPS data on the bluetooth com port at
2400 8 N 1 and its an RMC sentence type apparently

Hope this helps
#5  
Same sentence, different speed.

$GPGSV,3,1,10,22,59,347,,18,57,086,,14,49,313,33,31,31,212,*7B
$GPGSV,3,2,10,21,30,175,,25,26,130,,12,21,084,,09,18,037,*73
$GPGSV,3,3,10,27,03,037,,06,00,244,*7E
$GPRMC,131429.949,V,,,,,,,020612,,*20
$GPGGA,131430.945,,,,,0,00,,,M,0.0,M,,0000*5A
$GPGSA,A,1,,,,,,,,,,,,,,,*1E
$GPRMC,131430.945,V,,,,,,,020612,,*24
$GPGGA,131431.949,,,,,0,00,,,M,0.0,M,,0000*57
$GPGSA,A,1,,,,,,,,,,,,,,,*1E
$GPRMC,131431.949,V,,,,,,,020612,,*29
$GPGGA,131432.949,,,,,0,00,,,M,0.0,M,,0000*54
$GPGSA,A,1,,,,,,,,,,,,,,,*1E
$GPRMC,131432.949,V,,,,,,,020612,,*2A
$GPGGA,131433.949,,,,,0,00,,,M,0.0,M,,0000*55
$GPGSA,A,1,,,,,,,,,,,,,,,*1E
$GPRMC,131433.949,V,,,,,,,020612,,*2B
$GPGGA,131434.945,,,,,0,00,,,M,0.0,M,,0000*5E
$GPGSA,A,1,,,,,,,,,,,,,,,*1E
United Kingdom
#6  
Do you see these sentences on the ARC raw data tab? or is it from Hyperterminal? Whats your actual lat lon location as the line in your data beginning GPRMC should show your Lattitude & Long looks possibly corrupt the data stream needs to be 2400 8 bits No Parity 1 stop bit

I think ARC just looks for the $GPRMC line?? Maybe $GPGGA as well for accuracy information

What was the question?? This is actually really interesting I didn't understand how these things interfaced until I looked into it
#7  
No data shows on the Raw data tab. but once in a while when I turn off the GPS I do see information on the Details Tab.
The data I have here abd previous were from hyperterminal.

$GPRMC,223658.000,A,2433.5607,N,08145.1343,W,0.00,124.45,020612,,*17
$GPRMC,223657.000,A,2433.5607,N,08145.1343,W,0.00,124.45,020612,,*18
$GPRMC,223656.000,A,2433.5607,N,08145.1343,W,0.00,124.45,020612,,*19

Google Earth and EasyGPS both see the GPS.
United Kingdom
#8  
Realised the data you had previously was from an unlocked GPS with no signal

Well I couldn't get EasyGps to work or Google Earth with my Bluetooth GPS They wouldn't connect to the correct COM port which was dissapointing. You must have a Garmin or Magellan unit

I downloaded a simple app called GPSutility and that worked with the com port my GPS Bluetooth is connected to and GPSutility set to NMEA protocol. Download this and see if it helps you looks like a non proprietry GPS maybe needed?
#9  
I have a TomTom MkII. I got Google Earth and EasyGPS to work by resetting all other USB comports so that the Tomtom is the lowest port (Com 3). For EasyGPS, I told it that the GPS was a Garmin Etrex (Serial).