Asked — Edited
Resolved Resolved by Dunning-Kruger!

Ezb3 Won'T Connect

Well, because of financial and health issues, I haven't hooked my EZBs up in a long long time. I went to connect them and they won't connect.

It told me I needed v16.6 version and that I had v16.0 firmware.

So, I updated the firmware. It connected up fine.

I recycled the EZB.

I tried to connect a it won't. So far, I have tried 9600, 115k, 57k, and 38k.

It just won't connect.

Advice, please. Thank You.


Upgrade to ARC Pro

ARC Pro is your passport to a world of endless possibilities in robot programming, waiting for you to explore.


Before you (not repair) it to your computers Bluetooth... Pay attention what comm port the new pairing and windows sets for you... Then open ARC, select the new comm port and try and connect again....

P.s. There is no reason to adjust the baud rate on the port let windows handle that


Rich, I forgot how to do that. I know how to do that with the router. I will try that.


It's Richard Mel, but thanks for the compliment...;) Isn't your router wifi? Try shutting everything down and reboot... Chances are you're still going to have to re-pair the ezb with your computer


yes, my router is wi-fi. But, I am trying to attach to bluetooth. I used to be setup already, but somehow it changed. Also, I used to be a GURU at this stuff when I was younger,but I can not remember now.


The ports are already setup. They have a name Sunshine=com10 and Sunshine2=com11.

What baud rate should I set them. It is defaulting to 9600.


I am confused... How many EZB3s do you have? The ezb3 pairs with your PC, not the router.... For the one board that is not connecting, go into your Bluetooth settings on your PC... Scan for new Bluetooth devices (delete the old ez robot pairing first, the one you can't connect to) .... When Windows finds your ezb it will prompt you to add your pairing code (which is 1234).... select ok... that should be it.... Again, no need to touch any settings like baud rate...


ok, I will have to destroy my old setup.


OK, here is what happened.

I have successfully updated my firmware on Sunshine1 and Sunshine2 to v16.6. I have also paired both ezb3s. I have also installed the H-Bridge.

I had the whole robot on top of the kitchen table. It took two people to put it there. I had the gears disengaged so the robot could in theory run the motors without making the robot move.

Well, I installed the controller in the software and hit forward and BANG! The robot drove off of the table and hit the cabinet with extreme force. It tore up some of the scalping that I had setup. But, the EZB was not harmed.

Wow! it runs at full speed. What I need is a little slider to adjust the speed. Or, hopefully have a speed control in scripting. I have a small apartment and there is not much room for it to go full speed.

I can't believe that is the second time that has happened. This time, I had the little clutch disengaged. But, the sabertooth gave it no consideration. It just plowed forward.


OH, BTW, I have two EZBs and I am waiting to add an EZB4 to the robot. I have paired the first one. But, I am having trouble on the second one. It does not ask me for the password.

United Kingdom

The default is 9600 baud. I haven't tried my EZB V3 for awhile so will check later when I get home. Sounds like you are sorted though


It is all working now. I had to delete everything and start over and let the windows machine find it. Thanks!