Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Ezb V3 Can't Connect

Sorry to be such a pest.

I cant connect my Windows 7 notebook to my ez-b v3. I was able to add (pair) ez-b as a bluetooth device to Windows. but in the device and settings it shows with good status but disconnected.

When I try to click right to use 'connect with' as some online thread mentioned, that option doesn't exist.

Can't find a tutorial either on ez-robot.com or anywhere online that clarifies how to use either the 'EZB Connection' control or the 'EZ-B v3 Configuration' control.

I am confused by how or even if I need to manually either add or configure a port either in Windows or EZ-Builder... :(

frustrated ...




Upgrade to ARC Pro

Harnessing the power of ARC Pro, your robot can be more than just a simple automated machine.

When you paired the EZB two com ports were built. Using the Connection button at the top left of the EZB screen clicking on the IP address should show the com ports. Pick the lower numbered port and click the connect button.
This is soooo frustrating. Some of the EZB interface is very intuitive, some assumes knowledge I don't have.

I had watched the above video and read the ezb manual (ok, maybe I ready it after trying first... ) I dont remember reading or seeing to click on the box showing the ip address to select the port (no drop down arrow on that bos so I didnt know that). I did know to select the lower port number but only after initially failing to connect multiple times. I may have connected to the higher port. When I initially installed the EZB v3, ports were created and I didnt pay attention to them.

Now, I can see ports com4 and com5 when I click in the box where the ip address shows up. Cant connect to eithe one. I think the ezb times out in 90 seconds?

I tried removing the bluetooth controller on the notebook and relinstalling it and the ezb but it still comes up on the dsame port. I tried to delete the ports and let them reinstall but I cant see them in the device manager even trying to show them ("set devmgr_show_nonpresent_devices=1). I am definitely operating beyond my knowledge level here.

When I tried to connect to the ezb again, it says cannot comnnect. The little console comes up but I cant even read the messages because the 'always show' box is unclickable because of the pop up message . Very frustrating

Im going out to but some components to make electronics switches... Need to get away from this thing for a while... *mad*
ok I connected but its connected to com5 (the box where the ip shows up by default showed an ip address, com4 and com5) But without knowing how to view the console that pops up Im not sure if Im connected correctly since it connected to the higher of the listed ports and I have no idea what Im doing.

I guess its time to switch the sabertooth over from RC control to the ezb and see if I can make it do anything....

So how do I set the message box that pops up at the bottom to 'always show' at least until I learn more...

Thanks *confused*
OMG, when I click on the ezb in Windows devices and printers it still shows disconnected! What am I connected to on com5? OMG

Going out shopping... lol
If the flashing led on the ezb stops flashing, then you are connected... If you're connected on com 5, be happy, don't overthink it... You won't hurt anything so do worry... You will use that port all the time now for your EZB... Sometimes you may have to cycle the power on your ezb or reboot your PC to get a connection... It's the fun of Bluetooth... :)

If you have the sabertooth set up for serial, you can load the sabertooth control in ARC to test it out... Provided you have it wired correctly you should be able to control your motors...
I'll post later when I get some time to rewire the sabertooth and check it out... Tx

Be careful wiring up the sabertooth.... If you do it wrong you might release the mysterious blue smoke that for some reason seems to stop electronics from working...:P
Do not trust windows telling you it's disconnected. The ezb has a led that flashes when disconnected - so you can tell. Also the software won't let you connect to anything else.

The windows devices section is making things confusing for you and is unnecessary place to be:)

The drop down in ARC shows an IP address because it's default setup ezb v4 users. There are many thousands times more v4 users than the discontinued old v3, so we configure for the status quo, as you would expect

Sounds like you are connected great!

As for the sabertooth's connection, are you pressing the ? Button on the sabertooth's control and reading the help page? When you load ARC, there is a window that tells you to press the ? Buttons for help. Would it help if the window was bigger? We used to have it flash, but that was too ugly.

Not sure what we can so to help ppl use the help. Suggestions welcomed:)

As for help with the v3 - there is an entire section dedicated for the v3. It's in the LEARN section. LEARN is a menu option on the website. Press the learn and look at the sub menu. You will see a v3 support link. There's information about your v3 in there
Feedback from each of you has helped fill in my knowledge gaps.

Things are looking good so far. I can connect reliably now (more or less - Bluetooth...)

The whole Windows thing WAS just confusing me - '...it does that you know'.

I really haven't spent much time yet learning how to add controls and build routines in ARC yet as I'm still rewiring the lower half of the G-Bot (adding a few upgrades and fabricating a few switch circuits etc.).

Thanks for all the continued help guys.