Australia
Asked — Edited

Ez-B Soundboard

I seem to be having some trouble with the ends of sound files being cut off when played via the EZB Soundboard. Doesn't happen every time though. I have my files playing out through the un-amplified terminal on the EZB, through an external amplifier to a larger speaker. Has anybody else had this issue? I did try adding a couple of seconds silence to the end of the files in the program "Audacity" which does seem fix the problem but that doesn't explain why the problem exists in the first place. Any Thoughts?

Steve


ARC Pro

Upgrade to ARC Pro

Get access to the latest features and updates before they're released. You'll have everything that's needed to unleash your robot's potential!

United Kingdom
#1  

Im not really going to be much help, but I haven't had any trouble with the soundboards, EZ-B or PC, cutting off the ends of files like what you're experiencing. I did have a similar issue when using a Ivona voice where the end of a sentence would be cut off, but Cepstral voices are fine.

Sorry that I haven't got anything to add to help you in regards to the soundboard issue.

#2  

@Steve, While poking around in the ARC Preference section I found a Audio Tab. In it you can set the Audio Pre-Buffer size and the Audio Packet size. The little question mark next to each entry says this will prevent skipping but may cause a slight delay in playing the audio. Maybe this setting will help with the problem of our sound files being clipped at the end. Don't really know and I can't test this out right now. My Robot is taken apart right now while I work on my B9 Arm. Maybe if you have time you could play around with this setting to see if it helps.

Look at the top of ARC under the Options tab. You'll see a Preference tab you need to click on. When that box opens up you'll then see an Audio tab. Click on that and a box will finally open that will let you adjust these two setting.

Let me know how this works out for you if you get a chance.

United Kingdom
#3  

No problem. Thanks Dave. I'll see if I can get some time to play about with it tomorrow. Can't think why Steve N is having problems with the soundboard though. Strange.

#4  

I'm having the same issues. Sometime a file being played it will be clipped of just at the end. I've had this issue since I received my 1st V4 EZB and I was one of the first people to get one when they were first released. I've never had the time to play around trying to fixing it. This issue was mentioned on the forum back then and I think DJ said it had something to do with system resources. I think he said he was going to try to work on whatever witchcraft happens in the background of ARC to try to keep this from happening. I'm not sure if he ever got around to it or if this Audio preference setting I mentioned above was his solution. ;)

Australia
#5  

Hi Dave,

I haven't had much of a chance to play around with the Soundboard yet. Busy keeping the missus happy cleaning out the shed and building new shelves. Did try changing the settings on the "Audio Pre Buffering" though. The default setting is 20,000 bytes and I tried to set it up to half a meg but it wouldn't let me. The highest I could get it was 32,767 bytes. I,ll hopefully have a chance to try it out tomorrow night to see if it helps.

Still been trying to sort out why the sound files played through the EZB are at a lower volume than the files played directly from the CF Sound unit. Haven't had much luck with that yet. stress I will keep plugging away at that when I get a chance in the next few days

Steve

#6  

@Steve, as far as your volume issue; Do you have an external volume control attached to your system or are you using the CF unit for main volume control? I have all my sound system devices running through a pot at the robot's front torso knob. This allows me to adjust each device with it's own volume control to get a balance between them. These would be the sound slider on in the ARC Soundboard control, the MS Windows sound mixer controls, the EZB break out sound hack and the CF Sound System on the robot itself. I run this all through the torso know pot. I then can use the pot at the torso knob for volume control over the entire system. I did have one device (a bluetooth receiver) that I couldn't bring the volume up to the level of the other devices and I had to run this through a line leveler to get it balanced (I've since removed that device).

Hope this helps.

Australia
#7  

I have the un-amplified audio connected to the LINE IN of the CF Sound unit, the LINE OUT to the Input of the external voice amplifier, and the output of the amplifier to the main voice speaker. I have the volume of the CF unit up full and set the volume of the volume of the amplifier to the desired level. If I play a file from the CF unit the sound is at the desired level and if I play a file from the EZB the level is lower. I tried turning down the volume on the CF unit, but the volume of the EZB files went down with it, so still a difference in volume between the two devices. Some files played from the EZB are better, (louder) than others however, strange as they all came from the IB9 software. Some files are taken directly from the IB9 data file, and others have been joined together in Audacity. The joined files are fine played from the CF unit. I still have to figure out if that has anything to do with the volume levels on the files played from the EZB. Doesn't seem to be a pattern to it. I need to spend more time on it, but I'm a bit time poor at the moment.

Anyhow, must head off for work, running late eek

Steve

#8  

I'm resurrecting this thread because I've been working on this issue. I've made progress.

Recapped; The main issue is that sound files coming from the EZB (useing the sound breakout mod that taps in the sound system of the EZB before it's on-board amp) and channeled through the CF3 or CF4 sound system are played at a lower volume level then the files the CF plays from it's on board Compact Flash Card. The connection in on the CF system is through it's Aux In sound input port.

OK, with that said; I was having the same issue as Steve a while back and installed a volume booster in line between the EZB and the CF. I also had a bunch of other complicated equipment installed that I decided to take out to make more room for other things and un-complicate things. This was the perfect opportunity to reproduce Steve's issue without the other sound devices in the mix.

After I removed all this crap including the booster I simply ran a 3.5 mm sound cable between the EZB's sound mod port and the CF's Aux In port. When I triggered a sound file in ARC I was able to confirm that like Steve I got a noticeably softer volume level then when I triggered a file played stright from one of the files on the CF's CF card. I also was getting bad sound file clipping.

I then wired in the volume booster from outside the robot and after turning it's adjusting knob up fill was able to have equal volume from files in each location. Also I was now getting full file playback with very quick responce. All seemed well and I was happy. :)

Conclusion; The issue is with the CF unit's Aux In port not leveling incoming sound signals to it's own playing level. Sources coming into this port need to be leveled somehow. EZB is working as it should and this is an outside issue.

So, that brings us to today and Murphy's Law pops up (If something can go wrong, it will. ). eyeroll After installing the volume booster back into my robot and permanently attaching it to my electrical system a new problem "popped" up. LOL. Now each time a file plays from the EZB through the CF's Aux In port (first using the booster to raise the signal) I get a loud "POP" at the start and end of the file. I'm not really sure why this is happening but is sounds like an electrical issue to me. I'm unsure why I wouldn't have this issue when it was laying outside of the robot but once wired into it I get this popping. All things are equal except I attached power and ground in a different location in the robots electrical system each time and the wiring is now all inside the robot instead of hanging loose on the outside. I'll run a few tests and rewire today and see what happens.

I really don't have a lot of experience and knowledge about sound systems. Has anyone else seen this happen in any other sound installation or setup?

If anyone is curious here's the volume booster I'm using: Technolink TC-780i Mobile iPod / MP3 Input Booster

User-inserted image

#9  

I've spent a lot of time troubleshooting this popping today and did a little research. I didn't get it fixed but I did find out what is not causing it.

First, I tried different ground points and power feed points, different power supplies. No change. I still got the pop at the start and end of the sound file. Conclusion; No power or ground issues.

Two, I bypassed the CF3 completely and and ran a cable directly from the EZB to the amp (which then go directly to the speakers). No change. I still got the pop at the start and end of the sound file. Conclusion; CF Sound system, booster, wiring are not the cause.

Then, Started up the EZB's web interface (I'm running in client mode) and went into the diagnosis section. I tried playing the built in sounds and they sounded beautiful. No popping at all. Conclusion; Sound coming from the EZB is clean. EZB is not the issue.

That's where I'm at now. This leaves me with the WiFi connection, my computer, the sound files and ARC.

I did a little research to see if there is anything on something like this. I read a few posts like this: "This is a fairly common problem caused by cuts being placed at points that aren't exactly zero crossing points in the waveform. The solution is to add a short, three to four frames, 0dB fade at the beginning and end of each clip."

I don't know if this is the same issue I'm seeing but it's my next step. More to follow.

PRO
Synthiam
#10  

Can you share some of your sound files with me? I will take a look.

PRO
Synthiam
#12  

There's a lot of noise on the floor of the audio - i suspect from sampling. This can be altered with audicity, by selecting parts of the audio where it's just a floor and silencing it. As for the click at the start, there was a lengthy start delay of "silence" which is the noisy floor. So i removed the silence at the beginning and used a fade-in as well so the voice isn't abrupt.

try this: BeAdvised-B9NeverDonedj2.zip

#13  

Thanks DJ, Thanks for the help. I took a look at your edit in Audicity. I see exactly what your talking about. This is really more help then you know. I'll plug it in tomorrow to see if it works. :D

PRO
Synthiam
#14  

excellent - there's a new version of ARC tomorrow as well which includes a few audio performance enhancements. I don't see how they could help with the click, but they will lower cpu usage a few points while playing audio and the audio play should be quicker and more responsive.

#15  

Thanks Dj for the audio update. In the Spring Madame Ninndo will be coming out to the farm store, with some audio updates. These enhancements should also help.

Ron R

#16  

Outstanding DJ. Proformance enhancement is always a good thing. I'm looking forward to getting home tonight and seeing if this sound file edit fixes this click problem. I have high hopes that this is going to work. I'm not looking forward to editing every sound file though. However if that's what it takes. .......

Hopefully the update will be released also so I can try that out also. I'm going to wait to see the results of the file edit first before I update. Just to keep the testing environment unchanged. ;)

Australia
#17  

I can hardly wait for you to try this too Dave. I'm holding high hopes .....and my breath sick

#18  

OK, Good news. I'll call this issue resolved. However, the file editing did not do a thing. The fix was something else. Skip to the end if you cant stand the suspense.:P

Remember, I had a loud pop at both the start and end of each sound file played (almost the same volume as the sound it's self). Sometimes the starting pop would bleed into the sound it's self.

Just to show my environment; I'm useing an older Dell laptop upgraded to Windows 10. I have a very strong WiFi signal from an access point attached to a new router.

I tried DJ's "fixed" file and had no change. The pop was still there. In fact the audio quality was degraded. I edited a couple files of my own and tried them. No change. I even tried a few generic MP3 sound files and a song in MP3 format. No change. Still had a loud pop at start and end.

I then uploaded my project to a newer and faster computer to see if there were any differences. After attaching to the same network with this newer and faster laptop I found that the pop was now sporadic. The pops would happen at start or end or not at all. However they happened often. I'd say about 75% of the time.

I was a little discouraged. tired

Next I found that the update DJ mentioned was ready to download. After installing it on the older Dell laptop I loaded my project, connected to the EZB and played a sound file. I was not supersized when I heard the pop at the start of the file. However it was now very quiet! Then when the file stopped there was NO POP! Wow! OK, my shaking finger clicked a different file on the control's list. NO POP! The file stopped. NO POP! I tried this again and again with different files and found each has a clean and clear start and finish. In fact I'd go as far as saying that the sound files even sounded better. However that could have been because I was so happy that even a good fart would have sounded wonderful.

OK, Now was this just an anomaly? I shut down both the laptop and robot and rebooted both. I found the same behavior. The very first file played has a faint pop at the start but as long as I remain connected to ARC there are no other pops when I play any of the files. The only time I hear any distortion is when I play several files very fast and sometimes start one before the other ends. Then sometimes I'll hear that faint pop between files but what else could I expect under such torture.

So, My conclusion; I'm not sure why but something with my newer computer improved the popping issue about 25%. Then Something in DJ's ARC update enabled files to be played without the pop at all "After" the first file is played. The first file played after ARC is started and connected always has a faint pop at the start of the file. After that no pops will be heard. If I disconnect ARC, close it, then restart and connect to the robot the first file played will always have that first faint pop. I can live with this and am very happy. I now see this as a non-issue. Fixed. Thanks DJ for the voodoo you do so well. :P

Australia
#19  

EUREKA!

Dave, you sir, are da man! We are not worthy. ;) The effort you put into solving a problem is nothing short of remarkable. It seems nothing is too hard or out of the question. Many others would have thrown in the towel long ago. I cant thank you enough for all your work. I cant wait to get a line leveler, update ARC and try this out, and fingers crossed, I should get matched sound volume, no clipping, and especially no pops :D

And of course, thanks also to DJ and the EZ Robot team for all their tireless work in providing a first class product.

Steve :D

#20  

DJ's sound enhancement is what did the trick I think. Odd how this upgrade popped up just when we really needed it. Just goes to show you how on top of things DJ and ez robot are. Either that or the universe is total sync with our needs. :) On their own my troubleshooting steps may not have fixed anything. I'm still not really sure about that. In the end, I'm pleased and I also learned something. ;)

United Kingdom
#21  

Glad it's all sorted Dave. If only the universe WAS in sync with our needs... maybe a lottery win could be on the cards, lol.

#22  

Lol Steve. Who's to say. Maybe the universe thinks what we need is "not" to win the lottery. Dam universe. :(

Australia
#23  

Update:-

I bought a Line Leveler, installed it, Updated to the latest ARC and all is good. I was able to match the sound from the EZB to the CF sound system, I had no clipping and no pops. Life is wonderful :D

I then sorted out, after much head scratching, how to monitor ADC ports via contacts in the CF sound system, so I could pause and un-pause the Personality Generator and the Voice Activation controls in my project so when I pulled out the robots "Power Pack" he would "appear" dead. Life is Wonderful Still :D

Today, Life stopped being so wonderful. I installed a small Audio amplifier in parallel to the main voice amplifier to separately control the level of volume feeding the interface that controls the flashing of the chest neon regardless of the volume of the main Amp. I don't even have the neon connected to the small amp yet. I was just mounting it and wired the 12 volt feed to it and the un-amplified audio to it. later when retesting and tweaking the power pack pull scripts, I had a problem with the audio files played from the EZB Soundboard, for want of a better word, "Stuttering". It would play a file for a bit then jump back a bit replay the word or two or three, jump further up the file and back again and sometimes it would even play a small piece of another file that shouldn't be plying at all. Seems to happen more with the longer files. I cant imagine that it has anything to do with the new amp. Its like the file is sent garbled from my laptop. The files played from the CF sound system play fine, its only the EZB soundboard file that are affected. This is so weird as everything has been working fine. I thought the scripts that loop and watch the ADC ports may be overwhelming the EZB, but I only have two of them and they each have a 1 second sleep before looping back to the start. I made up leads for connection from the EZB to the AUX contacts on the CF sound system with 10k pull down resistors built in and I connected all 8 ADC ports to the normally open contacts on the CF sound. At this point only two of them are in use by the EZB.

User-inserted image

User-inserted image

Does anyone have any idea what might be causing this "stuttering"

Nothing is easy tired

Steve

#24  

Yes, this has happened to me in the past. Same hellish loop. I really don't know what caused it but here are a few things I did and haven't had a problem since:

I found a running ARC ADC port monitoring control I had installed that I had forgotten about. It was hidden behind some other controls on in my cluttered project. It was watching one of the ADC ports I was using in the same way you are (with the same pull down resistors that should be making things more stable). I clicked the pause box and saved the project. I then turned off both the robot and laptop and let it sit for a little and then rebooted the laptop.

After Windows 10 loaded I let everything finish loading and settle down. I then disabled my virus program, checked I had a good strong Wifi signal that was connected to the network I usually use and then started the robot. After the robot and his EZB's were up and running and connected to the network I then started ARC and connected it to the robot's EZB's. Everything was better.

The only causes I can think of could have been any or all of these; a bad wifi connection, cluttered comm channel between the laptop and ezb or something running on the laptop that was chopping up the delivery of the sound file or slowing down it's system. The issue could have also been enhanced by the Aux input of the CF sound system. It has a sensor that opens and closes (for want of a better understanding of how it works) when it scenes a signal coming in. Could be the signal was caught in a buffer and only parts were let through (wild guess).

Anyway, I haven't really had the robot running and using the sound functions a lot since I did the testing and work above. I have not installed the latest ARC upgrade. There has been one more with Audio Enhancements since I did this work and you may be running if you upgraded within the last couple days.

I do not have this extra amp installed in my system for the neon and I don't know if this could be a problem. I do know that sometimes adding extra equipment in a sound system sometimes causes problems. You can introduce polarity, timing, level and signal problems. I'm no expert in that stuff and I always need to study and ask questions when I want to modify my sound systems.

Till now my fix was to make sure nothing was running that would suck down system performance like virus software, unneeded computer software, ARC ADC monitoring, strong and clean Wifi connection, and a fresh reboot of all systems. Good luck and keep me posted. :)

PRO
Synthiam
#25  

steve,

  1. ensure you are running the latest ARC. there have been significant audio performance increases over the last few releases. the most recent release should be used

  2. use the benchmark utility and tweak the Data Channel Flood Protection value in the Connection Control if you are performing many read commands to the EZ-B v4.x/0 or EZ-B v4.x/1

Australia
#26  

Dave, I will have to give all that a go and I will try removing the small amp to see if that changes anything. I also have some suspicions about my laptop. I have been using my work laptop for ARC but I have been having some problems with it recently. If I have to reboot it, I get an error saying it cant load windows explorer and then it goes blank and then gives me the same message then goes blank and so on. The only way I can get it working is to restore it back to an earlier date, but then I have to update ARC again. I hate computers some times. I tried downloading ARC onto my wife's laptop but hers but it won't download. Her laptop is a HP running windows 8 but for the life of me I couldn't get it to download ARC. I even tried turning of the windows firewall. I'm thinking about buying a separate laptop just for ARC and nothing else.

DJ, I am using the latest ARC. What is and where do I find the benchmark utility? I haven't heard of that one.

#27  

Steve, Yes, make sure you have a trouble free laptop. When you have ARC installed on it, load your project and go to the top menu bar. Click on Project and then Add Control. Then on the General tab you'll see the Benchmark control.

Australia
#28  

Okay, I have done a little more testing and found something strange. I had two "ADC value" controls in my project monitoring and displaying the voltage change on the two ADC ports I am using for the Power Pack pull animation. I paused them and found that the files played almost perfectly. I then deleted them and haven't had a problem since.....Not sure what to make of this. I am still considering buying a Laptop for exclusive use for ARC though.

PRO
Synthiam
#29  

steve,

  1. ensure you are running the latest ARC. there have been significant audio performance increases over the last few releases. the most recent release should be used

  2. use the benchmark utility and tweak the Data Channel Flood Protection value in the Connection Control settings if you are performing many read commands to the EZ-B v4.x/0 or EZ-B v4.x/1

#30  

@steve.neal I was wondering, if you increased the "Interval" value in the ADC Value controls to 1000 ms, does it help the situation? The default 500 ms should be fine, but you never know. It's odd that putting them in pause didn't clear it up just doing that. Apparently there is still something going on with them even when paused.

Also, do you have other controls like that going as well? The combination of several controls of that type could cause problems, since they all run all the time, and by getting rid of a couple, you took just enough load off the computer to smooth things out for now.

And like DJ says, you really need to the run the latest and greatest version of ARC.

Oh, and one more thing. Do you have other programs running on the laptop at the same time you are running ARC? Sorry if that's already been asked.

#31  

WB, He's saying that when he paused the controls and then deleted them all is working perfectly.

I mentioned a few posts above that you should look for these controls and pause them. I've been experiencing this same thing and commenting on it for years now. It's not new and not odd. The ADC reads from these monitors are overwhelming your system and flooding the comm signal. I've never been able to have one running all the time and not have it drag down my performance.

WB is correct however, you can go into the control and adjust how often the thing reads the adc port. I've done this a few times and it helps. The latest updates as DJ just stated has gone a long way to aid in this issue. Hopefully the new EZB coming soon will also help this issue.

As long as you don't have these monitors running you should be OK.

Australia
#32  

Hi DJ,

I am using the latest ARC. I had a look at the "Benchmark Utility" but I couldn't figure out what to do with it. I clicked the ADC button and changed the figure at the top but I wasn't sure what it was telling me. Sorry I'm terrible with this stuff :(

WBS00001,

I had already changed the Sleep value to 1000ms when I was experiencing these problems. I dont have any other scripts looping other than the two monitoring ADC0 and ADC1. As far as I'm aware, I didn't have any other programs running at the time, I might double check that though to make sure there wasn't something running in the background.

I'm still leaning towards the suspicion there is an issue with my laptop. Its definitely not right at the moment and I'm thinking it may be causing or at least amplifying this problem. although the problem seems to have gone away since I deleted the ADC Value controls.

PRO
Synthiam
#33  
  1. load ARC
  2. start a new blank project
  3. connect ARC to your robot
  4. add the Bench Mark Utility
  5. Leave the value of 30 in the benchmark utility and press the READ ADC button
  6. Write down the number that it presents (X Number Pr Second)
  7. Now click on the CONNECTION Control GEAR to open the settings
  8. Change the EZ-B Board #1 Throttle Setting to a 1
  9. Go to #6 and repeat

Here's a link to the benchmark utility manual page: https://synthiam.com/Tutorials/Help.aspx?id=144

There are question marks to assist. Hover your mouse over the question mark in the connection control settings of the flood control to find out what it is does.