Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Ez Builder Stops Working

i did averthing like in the video.but i get an error,dont know what it is.
need help.what does this mean?


User-inserted image

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
PRO
Belgium
#23  
nope the link is for 64 bit while the video says 32 bit.
PRO
USA
#24  
Please Check again
PRO
Synthiam
#25  
The library link is in the plugin description, with instructions in video. If this discussion is regarding Cognitive Vision, all relevant installation details, including library links and step-by-step instructions can be found here: https://synthiam.com/redirect/legacy?table=plugin&id=180

1) Uninstall your previous libraries if they're giving you an issue

2) I doubt this works with Windows 7, as it's been discontinued by Microsoft
PRO
Belgium
#26  
dj

am on win8 .ok i uninstall all.
PRO
Belgium
#27  
nope doesn work.i uninstall all and redowload.
typical for belgium nothing works here.
thanks guys,
#28  
I'm getting the same application error and close message as Nomad with the latest plugin for Cogitative Vision. I have Windows 10, latest versions of everything and the x86 redistributable.
#29  
And I have the same values as Nomad when running the cmd command to get the version, mine come back as 14.0.24212 and also like Nomad I don't have that 3rd option for the "debug" version. I did download from the link in the instructions and installed without known errors. I did follow the direction.

The Cognitive Emotion work fine. And right before the application error the Cognitive Vision window will load the image from the camera and say "working..." then the error pops up.

Any idea what else I can check?
PRO
USA
#30  
@DJ,

I debugged the exception and the exception is:

Code:


{ "statusCode": 401, "message": "Access denied due to invalid subscription key. Make sure to provide a valid key for an active subscription." }


we can't see the exception because is inside multiple (nested) async calls, and is not captured, and the result is an application error.

i found the cause.

your plugin code calls the following constructor:

Code:


public VisionServiceClient(string subscriptionKey)


to pass the vision api key, but there is a second constructor:

Code:


public VisionServiceClient(string subscriptionKey, string apiRoot)


to pass the endpoint. The default apiRoot (endpoint) is:
"https://westus.api.cognitive.microsoft.com/vision/v1.0";

BUT !

Microsoft API keys are geolocated based on user input, and a specific Azure datacenter is assigned.

if the client key is registered for the westus.api.cognitive.microsoft.com endpoint
it will work as expected.

mine:
User-inserted image


my key only works for:
https://westcentralus.api.cognitive.microsoft.com/vision/v1.0

To summarize:
The plugin needs to ask for the endpoint url.
#31  
mine works for a bit then crashes i checked and I have set it up using the video instructions that were just posted the other day. windows 10 creators update with all patches and mine shows the correct version of the Microsoft Visual C++.
#32  
I ran the c++ install from the website instead of downloading then running and now the command line returns version 14.0.24215 like ptp, but it sounds like that may not have mattered. The same error occurs. From ptp's explanation that sounds like it would be expected.
PRO
USA
#33  
Justin,

Can you post a snip screen of your endpoint and keys (erase the numbers)

I dont't understand why 2 keys.
#34  
I believe the 2 keys is to allow simultaneous queries from 2 devices, which should be enough for a hobbyist or developer.

Alan
PRO
USA
#37  
Is working for me.

@Nomad:
does it work for you too ?

@DJ:
Thanks
#38  
Vision Cognition works great now! Thank you DJ!

However, now the Cognitive Emotion plugin (which I did Update and read the directions and copied in the key and end point correctly) now shows a red X across the picture window where it would normally show the image it reviewed. It still works otherwise, it reads my emotion just fine.
PRO
Belgium
#39  
hi it works but he says only i see?
PRO
Belgium
#40  
ok he sees the pic now but dont say what it is.
#41  
Did you create the script to utilize what the robot sees like the video and directions for the plugin show?
PRO
Belgium
#42  
yes i did just as in the video