Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Netherlands
Asked — Edited

EZ-B WIFI Connect

Hi There DJ sures,

I'd gave myself a present the Wifi module TLG10UA03.

Yesterday it came with the postal:)

I just configured it gave it my wifi ssid and password and a static ip.
Tested it and connected it to the EZ-B.

Powered up the EZ-B and wanted to connect the EZ-Builder.

But ehm.... ehm... ohh.

How can I connect:)

AI Support Bot
Related Content
Synthiam
#12  
@orwnic82

Ok maybe i can help.....sounds like you installed the TTL driver ...this is not a virtual driver...it is the physical driver for the USB TTL device....the virtual driver comes later when you try to connect EZB to the wifi board via a TCP/Serial driver.

Make sure you have the right driver..you want the Prolific PL2303 driver

PL2303 Driver Installer

Sounds like you did that.

When you plug in the USB adapter does windows acknowledge something is plugged in? Go to Device Manager to confirm you have the prolific driver installed. You should see the com port number in Device Manger (take note of that). (from your post above..it sounds like this is where you are stuck).

Connect the wires from the USB TTL to the WIFI card...Make sure you have the wires between the USB TTL and the WIFI board correct. I am trying to remember...but I think you want RX to TX and TX to RX for the wired 'crossover' or null modem connection. As long as you dont mess up the Vcc and GND you are fine if you happen to tie TX to RX and vice versa...only one way works...

Run the UART-Wifi software....change to the com port you have in device manager.

you should see the wifi device come up then......once you get the device on your network you can use the web interface to work with it from there.

Hopefully this helps. Now if i could only get the EZB connection going...

v/r

Kevin
#13  
@kkeast

Everything seems hooked up correct but the device is not being found when I search for it.

error:

Com invalid. Device is not supported.
#14  
The only thing I can think of is perhaps driving pin4(Nreset) low to see if that helps correct the issue
#15  
I am in chat right now if you want to discuss
#16  
Welp no such luck getting the TLG out of auto mode so I can configure it, I sent the AT controls tried the manual resets and just about everything I could review through the manual that could allow me to configure it to my router. Tried Hyperterminal however theres never a response from the TLG if you send AT+ should respond with ok+ but nothing any idea how to get the TLG into a different mode.
#17  
Model for.the ideal battery is UB645 6v lead acid battery 4.5 ah. It handles higher current than AA batteries and longer runtimes , search by model on eBay they are 10th dollars.
User-inserted image
#18  
a battery has nothing to do with this issue jstarne1, I've contacted the manufactor hopefully they have a solution. Don't understand why it isn't responding to AT commands or why I received it in auto mode.
#19  
Great news got the device configured now to get the virtual com port. Also it looks like my 2cell 910mAh battery won't supply enough current for the TLG to run off the EZ-B.
#20  
@orwinc82!

That is great! I was taking a break from it....hopefully will start back up on it....I don't know what virtual com driver to use on the host PC......The one I am using opens one but no luck with EZB connection yet.......good luck on getting your power issue sorted. I am suprised as right now I am powering the EZB board and the TLG with only 5 AAA batteries...seems to work fine..do you have other things on?

v/r

Kevin
#21  
@KKEAST

Nope but it seems a bit fishy I plug it to a power supply I created along time ago and connect it to the 12V rails and sum times the TLG turns on and sum times not. There shouldn't be a problem current wise with the power supply so maybe its my connections I have running to TX,RX,GND and 3.3V. Perhaps we can get Pabi!o to upload the drivers that were included with his for the virtual com port. I'll probably look into getting another 2 cell and paralleling it just for current incase future reasons.
#22  
@orwnic82,

That does seem odd. I noticed that even if i have the RX and TX backward, the TLG won't even power up. Definitely don't want to get the Vcc and Ground mixed ....so I watch that very carefully of course.

That would be cool if Pabi!o could post the virtual driver he has....!

Kevin
#23  
@kkeast

humm Mine turns on whenever I apply power to it from the usb regardless if the rx and tx are backwards however it wont if the rx and tx aren't connected. I almost applied the 5v to the TLG, forgot the V+ was 5V instead of 3.3V but I caught that before I powered up.

Hopefully He can upload them for us.
Netherlands
#24  
Hi there i used the follow documents and software to configure my wifi-module.

I bought mine from ebay
Ebay-link


On that page there is a section download there you can find al the info and software.

Hope it helps:)
#25  
@kkeast

Yea its a current issue. Since I have a day and some time before my local hobby shop opens I thought I'd do a little amperage measuring. The USB to TTL puts out roughly 324mA to the TLG. I measured the amperage of three different power supplies I hooked up to the EZ-B: my 12V power supply, my 7.4V 910mAh LiPo and my 11.1V 3Ah LiPo. All of these power supplies allowed for 210mA to 220mA. The manual for the TLG states the operating current to be around 300mA. So there I go reason for it turning on sometimes and not working others. I'll just grab another 7.4V LiPo and parallel them.
#26  
@Pabi!o

Thats elechouse same company and everything I just don't see any drivers for creating a virtual com port out of the Wifi TLG. DJ said it installs its own drivers but the only drivers installed from those documents are for the usb to ttl controller. I must be missing something.
Netherlands
#27  
I did it if i remember correctly with the following steps

connect the wifi module with te serial usb.
install the drivers and it assigned a serial port you can see in the device manager ( windows )

connect with the program "uart-wifi" to that com port.
That did it for me.

don't forget to restart ARC
#28  
@Pabi!o,

Are you saying that uart-wifi installed a comport on your system that ARC sees. I have my TLG configured and it is in auto work mode. I can get to the web page on the device and make any changes. My problem is that I don't have a virtual com port on the host. If you go into device manager in windows...you must have another comm port there that came from somewhere. I don't have it. All I have is the prolific drivers I used to communicate with the TTL device?

Do you have to keep the uart wifi program running?

Glad you got it running....like orwnic82...I am also missing something.

v/r

Kevin
#29  
@Pabi!o,

How did you get the TLG to run off the 3.3V line I tried my 2Cell LiPo and it draws 206mA which is a hair short of 300mA for the TLG to run, So I paralleled in a 2nd and it still draws the same amount of current.
#30  
Hi Pabi!o

I am running mine off the 5 AA battery pack right now. The TLG works with either the 3.3 V or the 5V with no problems. I did notice that if I ground it to the TTL header ground it does not work (as there is something going on there as the light on the TLG glows very faintly and does not connect to my Access Point.

I am still having problems with this device. I cannot even get the TTL to connect up the board direct using the USB. I have the latest firmware but still not able to connect to ARC....how is yours working out?

Also, how did you get yours out of auto mode? When I try to turn it off in the web page it does not save and stays enabled. Hope this helps you with your troubleshooting.

v/r

Kevin
#31  
Kevin

Yea I sent over the command +++ for some reason I had to use the arduino software terminal to send the command, Hyperterminal and c# application didn't work, weird. I'll see about changing the gnd but other than that it is a current issue. I've waited for another LiPo to see if it would increase the current by paralleling them but the current stayed the same. I haven't got to check if I can connect through a virtual com port yet though trying to get the module working off the ez-b power source.