Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Canada
Asked — Edited
Resolved Resolved by Steve G!

Connection Question

I have had 2 EZB4's connected to my robot for some time now and connecting to them has never been a problem. Tonight, however, I can't connect to the second one. I have one setup in client mode (which connects no problem) and the one I am having problems connecting to has always been in AP mode. I have checked out all the basics to trouble shoot the problems , reset it a couple of times and replaced the EZB with another one which is brand new. Can't connect to it either.

I get this message in the debug window,
8/3/2015 9:49 PM - Disconnected
8/3/2015 9:57 PM - Attempting connection on 192.168.1.1:23
8/3/2015 9:57 PM - Connected to 192.168.1.1:23
8/3/2015 9:57 PM - EZ-B reports EZ-Robot OS v25.5
8/3/2015 9:57 PM - Connection Failed: System.Exception: This device is not an EZ-B. Please follow the online tutorials on the EZ-Robot website.
at EZ_B.EZB.Connect(String hostname, Int32 baudRate)
8/3/2015 9:57 PM - Disconnected

and this window has popped up a couple of times

User-inserted image


I have looked at the firmware update video - it seems to be old as I don't have an "update Firmware" in my EZ Builder or do I and I'm not looking in the right place.
I am running the latest version of EZ Builder.

Your help is always appreciated - Thanks

Edit; So now I tried to connect to 4 different EZB's in AP mode and I can't connect to any of them.

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
United Kingdom
#1  
The firmware update only applies to the old v3 board as the v4 doesn't have firmware updates (at least not yet). I know you said you have the latest ARC version and tried the basic troubleshooting methods... was reinstalling ARC one of them?
#2  
Thanks Steve, I ran the "repair/reinstall" download shortly after posting my problem and it seems to have fixed the problem. I wanted to try it a few times to make sure - it's working OK now.
Thanks for your help.
United Kingdom
#3  
your welcome. Glad you got it sorted.