Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Australia
Asked — Edited

Connection Issue - Newbie Question

Hi all.

I saw the video of the 'real walle' and decided that I needed one!!

So last christmas I bought myself a Wall-E and a EzB kit. And as a newbie it took me months before I pulled Wall-E apart. It took me a while longer to order all my parts - cos I needed ALL of my parts before I began;) (did i mention i'm a newbie?! lols!)

In the last month I've tried to connect my board to my laptop (its only taken me 4 months to finally do it!) - I'm running Windows 7 with a bluetooth adapter. The board pairs with the laptop fine but when I start the program and press connect, it connects for like 2 seconds then a pop up windows comes up telling me its not connected and the small light goes back to blinking at me. *stress*

And I'm completely clueless... *help*

I've tried to rechargeable batteries first then loaded newly bought batteries. The BF then told me to use a power supply (only 2amp - have no idea if that's enough? - the fuse didn't blow so I assume that's good sign.).
I've tried two other computers/laptops and same results?

Any suggestions to what I'm doing wrong? (I thought this would be an easy project but I can't even get it connected *stress* )

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
United Kingdom
#1  
Have you updated the Firmware on the board?

If yes did the firmware updater work ok?

If no then try updating it.

Then report back welcome to the forum btw. No doubt someone else will jump in with some other suggestions we are a very helpful community here.
#2  
I had the same issue with my board and it was because it was "browning out". Too many things pulling too much current. I took care of it by powering my servos directly from the battery (the regular size servos that is - the mini servos remain attached to the board). And Welcome to the Community!!!
Australia
#3  
Thanks for the quick responses!

So... I can't update the board cos it won't connect long enough to do anything... it won't connect at all (except for like 2 secs!). FYI, I get this error:

Attempting connection to COM5
Comm Err: The operation has timed out.
BbytesToExpect: 1

Received:
Disconnected
Connection Failed: System.Exception: Controller Not Responding
at EZ_B.EZB.Connect(String portName)
Disconnected

There's nothing connected to my board at all... no servos, nothing.

I've been trying to connect it to the program first before I start attaching things to it and I can't even seem to do that...

Any chance in the world that I have a dud board? *stress*
Netherlands
#4  
Hi PriNceSs.Try connecting something to your board first like a ping sensor. I've noticed that my board has connection problems too when nothing is connected to it. As soon as I add something to the ports it connects fine. I hope you get it to work, allthough theres always a chance that things might be faulty or dead, one can assume that it is not. Keep trying, I'm sure youll figure it out. ;)
PRO
Synthiam
#5  
Princess, can you verify against the tutorial videos that your bluetooth software is the same as the videos?

People with third party bluetooth software always experience connection issues. It's a bug in their software, so there is nothing we can do about it - other than tell you to uninstall.

You should have two COM ports detected. If you don't, then you do not have the native Microsoft Windows Bluetooth Stack. There is info about it in the Tutorial section under Adding Bluetooth.
Australia
#6  
Yeps, can confirm that it is the native software... and yes, I get the two com ports (com5 and com7) but can't connect to either one of them. I've tried with two different laptops (one with a bt adapter and the other is built-in).

Okidey- have tried to have something connected but no luck. The BT light stays on for 4 seconds instead of two seconds - not that it helps?
Ecuador
#7  
Maybe you will need to Re install windows.... format everything....

I have 2 computers... the 2 computers has windows 7... One of the computers I have not formatted for a long time!! maybe 2 years...... and when I try to connect my Ez-Board... I can pair the Ez-Board with the computer... but I can not connect the Ez-Board with ARC... Is because something is wrong with windows...

But I have my new netbook.... Acer Aspire one 722 (The same that Dj:) jaja) and Ez-Board works Perfectly!!! With out problems!! and with a generic Bluetooth!!

try it!!
Good luck!
Australia
#9  
:D

So I watched the diagnostics video and in your video you say check the second pin in if you have a 6 pin board... and check the first pin if its a 4 pin board. I have a 4 pin board - can i assume I'm checking the first pin from the bottom if my board if its in the same position as yours??

I ask this cos i get nothing if I touch this first one... but I get something if I touch the top one/last one on the other end?

And if I do the sixth pin test then it does connect up to the next pin from the top though.

And edison2, I have formatted my laptop and the other laptop was running Linux so I had to do a new windows install on that just to try to connect my board up! Hmms.. maybe this is a new excuse to get a new acer laptop... I'm sure the hubby wouldn't notice a dent on his c/c. :)
Gibraltar
#10  
I've got same problem as the pwincess,
watched and followed diagnostic vid and got same results as DJ
but still can't get things going,
i'm tryed on an xp pc and 7 laptop.
would a new bt dongle be advised ?
United Kingdom
#11  
I have a 4 pin BT module EZ-B board and can confirm that I get the same results as @PriNceSs does and my board works fine BTW. So pin 5 to top pin BT module marked R and pin 6 to next pin down marked T. Basically the data send and receive lines

As DJ says there should also be no shorts to any of the other pins on the BT board
PRO
Synthiam
#12  
Check the photos on the Diagnostic page for your EZ-B version: http://www.ez-robot.com/Tutorials/Diagnostics.aspx

The pins are all going to be the same, but some won't be soldered, some will, and some have an adapter.

@winstn60 i removed your photo because it was for the prototype 3, which there are only 5 of and were never sold.

We have no problem warrantying unused boards:) Most of the boards we receive are not damaged, and it's an issue on the host computer. As Princess says, her computer is a new install - so perhaps the EZ-B is damaged. The boards go through a complete test before shipping, but sometimes vibratations or static during the shipping process can effect something.

So check for shorts. If there are no shorts, all the power lights flash normally, the bluetooth stack is Microsoft Windows, and you are not running in a Virtual Machine, then we'll need to replace the EZ-B:)
United Kingdom
#13  
Well just trying to help didn't realise I had a prototype? Which I purchased through Solarbotics strange you say they were never sold.
PRO
Synthiam
#14  
@winstn60 you have a green board EZ-B?
Gibraltar
#15  
@DJ Sures you mentioned vibrations during shipping
my bt module dosn't sit fermly it wobbles could that affect conectivety
United Kingdom
#16  
@DJ ahh now its clearer! no I have a blue board. I copied the pic from the manual with a 4 pin BT module so understand now why you thought it was a prototype

@bborastero My BT module is stuck very securely to the main IC with double sided tape and doesn't have a plastic sleeve if it wobbles it definitely won't help
PRO
Synthiam
#17  
@bborastero it shouldn't, but you can stick it with a peice of double sided tape from Staples or any office supply store.

If you're receiving lots of trouble with the connection, feel free to send it to me. I'll take a look and verify everything is in order:)
Gibraltar
#18  
@DJ thanks i might take you up on that,
i'm waiting for a new chip from Amy if no luck i'll ask her for details.
again thanks
Ben