Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by CochranRobotics!

Connection

Hey guys. I just got my ez-b v4 today and I'm having trouble connecting a couple of desktops (win7 home premium 64-bit) to it, even with windows firewall turned off. my laptop (win7 pro 32-bit) connects fine. Do you have any suggestions, pointers, directions, etc. I could follow to resolve the issue? I really appreciate any feedback you can give. Thanks! rb

#1  
Your firewall on the pc's wont need to be turned off.

Are you connecting in AP mode (like the v4 came) or have you put the V4 on your wifi network?
#2  
Can you be more specific? Are you having trouble connecting in ARC itself or are you having trouble connecting to your EZB via Wifi (AP mode...) on your pc?
#3  
I see EZ-B on my wifi list and when I click connect it says it can't. No problem on my lap top but neither of my desk tops will connect.
#4  
What make and model are the desktops ? What WiFi hardware is installed?
#5  
One is a Gateway DX4860-US20P with built in WIFI. Windows 7 home premium 64 bit. The other is a ZT what ever that is and running Windows 7 home premium 64 bit. This one has a WIFI adapter.
#6  
And other WiFi connections can be accomplished on the two desktops ?
#8  
From your posts it seems that your trying to connect through your home network router? Is that correct? If not are you trying to connect using the default AP mode? If through your home network router. Have you tried to assign a static IP address to your EZB and all your computers in your router's setup menu? This may not help with your problem as it does sound like you can connect your one laptop to EZB but it will allow the router to find all your computers much more efficiently and quickly.

I'm no router expert and there are others here that know that realm better then I but I had to buy a newer home network router to get my connections to stick. I also had to assign static IP's to all my devices to make things work flawlessly. Right now I have two EZB v4's in my robot and they connect through my home network router to ARC every time with no disconnects. Also in your router menu have you tried to release and/or renew your IP list? Give that a try.

Here's a thread from when I was setting up my multi V4 EZB robot which hopefully might help:

Connecting To Two V4 Ezb's
#9  
I think he is trying to connect in AP mode.

I would advise to connect to the EZ-B with the computer that works and then use a web browser to connect to the EZ-B on 192.168.1.1. At that point, give the EZ-B your networks SSID and Password. This will allow it to get onto you network. You will hear the EZ-B say "I am connected to your network" when you have a connection. Next, you need to know what IP address was assigned to the EZ-B. Connect to your router's IP address next with a computer connected to your network. You will probably be prompted with a username and password. Enter this information for you router. In your router configuration, you should see an option that shows connected devices. This may be under a heading called DHCP. Look for the EZ-B. Get the IP Address assigned to your EZ-B and then use that in the connection options in ARC. Be sure to include the :23 on the end of it.

I suspect what is happening is that one of the wifi cards works great with the EZ-B. The other two are probably older and having issues. The wifi cards that are not connecting, but can connect to your network will then be able to use your network to connect to the EZ-B unless you have an old WIFI access point, which then you would probably want to replace that anyway.
#10  
You can also find the IP address of the EZ-B once on the network by using the network scan tool from within ARC.
#11  
Thanks guys! I am indisposed at the moment but I will give it another go on Monday.
#12  
I managed to get it on. I mean the EZ-B. Buster Junior will live because of your efforts. Many thanks from Jr. and the bookmaker.
#13  
@bookmaker32, What did you do that ended up working for you? Please share so others can learn from your good fortune! :)
#15  
@Dave Schulpius , I followed @d.cochran advise and all went smoothly. I am now connected to my router and when I power up my EZ-Bv4 it instantly connects. Also with this method my computer stays connected to the internet. Life is good!
#16  
Yeah, @d.cochran is a pretty smart guy. He helped me out a lot when I was having my connection issues. We're lucky to have him here on this forum. :)