Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Resolved Resolved by AI Support Bot!

Connecting To EZB Web Interface If Connected Through USB And Comm Port Problem

OK, I used to know this but can't dig it out of my brain. Can't find the answer on EZ Robot's site either. 

I'm connecting ARC to three EZB v4's through USB on an onboard Rock Pi x.

How do you log into the EZB's web portal if I'm connected that way? I really don't want to push the reset button and get to it over WIFI (which I do know how to do). 

I've had this setup working well for a year now. Yesterday I started having problems getting ARC to connect to the third EZB that is in the #2 connection slot. I accidentally kicked the robot's power cord out of the wall and the robot shut down without me doing a proper windows shutdown. Sence then that EZB will not connect to ARC. I'd like to get into the EZB's interface to check that everything looks right in there. At the very least make sure I can connect. 

I've had this problem every once in a while in the past, but a reboot of the system always fixes the issue and the third EZB connects through the comport. Now it never does. Ugh. 

Things I've tried already:
- Refreshed the connection window and tried different com ports
- Deleted the offending com port in Windows Device Manager and restarted. The Com port was reinstalled. No luck
- Unplugged the USB/TTl cable of the offending EZB and checked Device Manager. It was gone. I repluged the cable and the com reappeared in DM. Windows DM sees the cable plugged in. 
- Moved the USB/TTL cables around and relogged in with them in the new positions. Had to change com port settings in the connection control. The problem stayed with the EZB that won't connect.  

Any help is welcomed. Thanks in advance..

Related Hardware EZ-B v4
Related Control EZ-B Connections


Upgrade to ARC Pro

Your robot can be more than a simple automated machine with the power of ARC Pro!

AI Support Bot
Related Content
OK, I found how to log into the interface. Even though I'm hooked up through UDB I can still get to it over wifi. I have to attach like in AP mode. I connect my laptop wifi to the EZB I want in the network list. Then I can enter into a web browser and get into it. 

I still haven't resolved the com port problem.
I went ahead and reset the EZB in question. I had to set it up again to run over USB through it's web interface. Still no luck connecting to the third EZB. I made sure the baud rate is set the same in ARC's connection tool as it is in the EZB. Here is the debug error message in ARC:


ZB 0:
EZB 1:
EZB 2:
EZB 3:
EZB 4:
Windows version: Microsoft Windows NT 10.0.19044.0
Synthiam account: dschulpius@gmail.com
Screen Resolution: 1360x768 (96x96 dpi)
ARC (Early Access) Version: 2022.11.28.00
Speech Recognition Culture: en-US
Loaded speech recognition successfully
Attempting connection on COM5
Comm Err: The operation has timed out.
BbytesToExpect: 1
Connection Failed: Controller Not Responding
Port Connection Error:There was an error connecting to COM5. Check the debug log for more information.

Would you like to view the diagnostic manual for connecting to USB EZB devices?

I had also sent this question to EZ Robot incase this turned out to be a EZB related issue. They got back to me very quickly and Zac was trying to be very helpful. However the question I sent describing my problem must have been unclear and I seemed to confuse him with it. I guess I made it sound like I was trying to connect my three EZB's in a combination of WIFI and Direct to USB connections. That is not the case. However I am making progress and have narrowed the problem down to the bottom board of the EZB. I'm going to replace this EZB with a new one and all should be fine. In the mean time here's my reply to EZ Robot letting Zac know what I did.:

Thanks Zac for the quick reply. I'm sorry if I caused any confusion. Actually I'm not trying to connect my 3 EZB's in both WIFI and USB at the same time. For the past year I've had them all connected to the same robot and SBC using USB/TTL direct connections. All has been working great but the #3 EZB would periodically not connect to ARC. A system reboot would fix the problem. A couple days ago this EZB simply stopped connecting. During troubleshooting I removed the other 2 EZB's and was using a new bare ARC project to try to connect to the offending EZB. No luck last night

I've been doing more troubleshooting today. I have a new EZB here and have been able to connect it to ARC. I've successfully been able to connect it in both WIFI AP mode and direct USB/ttl mode. When connecting through the USB I've been using the same cable and USB port on the SBC as I was with the failed EZB. This led me to believe the EZB was at fault.

I swapped around the upper and lower boards in both the new and old EZB's (Both are v4's) and determined that the bottom board of the old EZB is bad.

So, no further action is needed. I'll just use the new EZB and all should be well.
I wonder how the board was damaged? that's too bad but great that you got it working
The only thing that I can think of that might have caused damage is this: "I accidentally kicked the robot's power cord out of the wall".
lol, so don't turn the power off to an ezb? hehe:D
I would recommend using fingers to turn off a robot instead of feet:) 

Less chance of a high-voltage spark or short circuit condition:D
Update; OK, I've got all my EZB's connecting to the Rock Pi x through USB and working properly in ARC again. Wahoo! LOL. 

That was the problem. The bottom board went bad somehow. 

@DJ, It could have been anything or everything. I have had intermittent problems with this board connecting through USB this past year. Not a lot but spotty. This was one of the first V4 boards you guys came out with years ago. In fact it shipped to me with a 3D printed case. Then a while later I bought the upgraded V4/2 upper board when you first started offering them. So, the bottom board is old and has been through a lot with me. LOL. 

The issue showed up a couple days ago when I accidently tripped on the power cord for the robot and it partially pulled out of the outlet. The contacts in the cord to the wall outlet flickered a bunch of times trying to pick up the load of the robot. Everything was flashing on and off on the robot trying to power up. Ugh. Maybe that did it.


When I first got this EZB years ago I got rid of the power connection pin that sticks out of the bottom of the lower board and soldered on a pigtail to connect for power. Added to that, I also did the sound break out mod where I soldered on some wires and a 3.5 stereo jack to by pass it's tiny speaker to add a full sized amp and speakers. I did this last mod twice because I didn't like the first one I did. LOL.

Everything added up probably stressed out this bottom board and it gave up the ghost. I'm just happy I was able to figure it all out and the B9 is back up and running. He looked really broken.
#9   — Edited
Yep, Dave this is the kind of situation electronics don't like:)


The issue showed up a couple days ago when I accidently tripped on the power cord for the robot and it partially pulled out of the outlet. The contacts in the cord to the wall outlet flickered a bunch of times trying to pick up the load of the robot. Everything was flashing on and off on the robot trying to power up. Ugh. Maybe that did it.
*Edit: Intermittent brownout conditions are how many electronics let out the magic smoke:D
#10   — Edited
LOL. @DJ and @Jeremie, you guys are a scream!xD

I'm with Jeremie on this one. My fault for kicking the power out of the wall part way. 

I've got a new way to turn him on and off now that is really neat! I bought a Alexa compatible plug and have the robot plugged into that. With the Robot's power switch always on all I have to do now it say," Alexa, turn on the Robot" and he automatically powers up. Same to turn him off. However before I shut him down I have a script that I can run in ARC that will automatically exit ARC and then shut down windows. After a few seconds I can then safely tell Alexa to power down the whole robot.
I'll bet there is a way to get Alexa to execute your ARC shutdown script too.  Probably several ways to do it actually......  Here is a very old thread about using IFTTT to execute ARC scripts, and IFTTT can be triggered by Alexa.   Probably more straightforward way to do it by now (thread was from 2016, and I still haven't learned C# to write the plugin I was talking about:(
Wow, if that's possible that would really make things easier. I'd live to find some way to automate the whole shut down process. Thanks! I'll look at this.