Welcome to Synthiam!

Program robots using technologies created by industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation, and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Geoff!

Connecting To Ez-B In Ez Builder.

I'm new to EZ and have built other projects, mainly Arduino based.
I was finally able to add the device and update the firmware on com 6. When I try to connect to com 6 in the EZ builder the red led stays lit and after a few moments it goes back to blinking and the message "could not connect to the EZ-B" and offers to send me to a tutorial. Fresh batteries, windows 7 home, service pack 1. What to do *confused*
Any and all help would be welcomed as I can't even get started.

I got the following diagnostic after I tried to connect
"Received:
Disconnected
Connection Failed: System.Exception: Controller Not Responding
at EZ_B.EZB.Connect(String hostname, String tcpPassword, Int32 baudRate)
Disconnected"
does that help?
UncleMike

#1  
Hello and welcome,
Someone may have a better answer but, I'll offer my $.02.

What version of the dot net (.net) framework do you have installed? Try updating it. Let us know how it goes.
Someone will get you up and running if that isn't it. I just know that was one of the issues I had at one point. Hope it helps:)
#2  
Disconnect the power and reconnect right before you try to connect to ARC. The ezb has a brief window it can connect. Depending on your computer you may try a few times. Usually after the initial connection things are smoother from there. Second be sure to use Microsoft native Bluetooth stack.
#3  
@jstarne1 Would he have been able to update the firmware if he wasn't using the MS BT stack?
#4  
He could. I was able to using Asus drivers but not connect to ezb.
United Kingdom
#6  
You say fresh batteries, have you tried another set of fresh batteries or better yet a different power source?

What is plugged in to the EZ-B (if anything)?

From the description it's connecting but near immediately dropping the connection. I had this happen on one of mine the other day. The solution for me was to remove the power, reboot the PC and try again.
#7  
Yes fresh batteries voltage verified. Nothing else plugged in to the EZ-B, @jstarne1 yes tried many restarts with off time vareying from a from sec to many min. @Antron007 not sure which ver.
EZ Build ver 2013.07.10. On rebooting this morning I get
"Invalid OS version. Please upgrade
EZ-B reports v.15.7. Thos copy of ARC requires v16"
I have checked for updates and it reports that I have the most recent ver.
I will uninstall EZ-Build and do a fresh reinstall.
Later
Reinstalled ver (2013.07,10) same message.
United Kingdom
#8  
Check for cold solder points on the board and also check the bluetooth module is firmly connected.
#9  
@Rich did that. also tried to reupdate the EZ-B OS fermware and the program reports
"Attempting connection to COM6
EZ-B reports EZ-B Firmware V15.7
Connected
Your EZ-B has the latest firmware. There is no need to update."
#10  
Sounds like your one or more batteries are low. Do you have a 5 volt -17 volt DC power adapter laying around? Something that can handle at least I amp
Canada
#11  
Hey,

I see that you said:

"EZ-B reports EZ-B Firmware V15.7"

With the current version of ARC the EZ-B Firmware should be V16. I see that you already said you installed the newest version of ARC, but let's try uninstalling everything first.

Then re-installing ARC, which should give you the newest EZ-B Firmware updater. After all that is done, try updating the firmware again and EZ-B should report EZ-B Firmware V16. After that try to connect the EZ-B in ARC. Let us know if this works out for you :)
#12  
I am now running EZ Board ver 2012.04.23.02 and now am connected to the board and starting to play with adding servos etc. New problem, I seem to have a bad modified servo as it wont run no matter which port i put it on will test it tomorrow on its own to see if there are bad joints at the plug.
thanks for all the help guys, now on to bigger and better things. Will keep you all updated on my project a tank toy I am modifying for this. G'night all
Unclemike
User-inserted image

Originally an Arduino projecr now EZ-B
United Kingdom
#13  
You should update the firmware to V16 and update ARC to the latest version.

If you upgrade to the latest version you will find that all servo ports need to be set again, surely it's better to upgrade before you add all of these controls?

Just download and install the latest release, run the EZ-B Firmware Update tool and follow the on screen instructions. Then run ARC and take advantage of the whole host of new features and functions it now offers from way back in April 2012.
Canada
#14  
Rich is completely right. The latest version will be your friend not the enemy

Get the all the latest greatest going and you will be in better shape. Be sure to keep us posted on the tank. That will be awesome!
#15  
Marked "resolved" but it doesn't let me credit all the posters, so thanks Geoff, Ralph, Jstarne1 and Antron007.
thanks for the help and warm welcome.
UncleMike