Asked — Edited

Comm Err: The Operation Has Timed Out

my ez-b was working for 3 days, now when i try i get this...

Attempting connection on COM3 Comm Err: The operation has timed out. BbytesToExpect: 1

Received: Disconnected Connection Failed: System.Exception: Controller Not Responding at EZ_B.EZB.Connect(String hostname, String tcpPassword, Int32 baudRate) Disconnected

Skip to comments


Upgrade to ARC Pro

Discover the limitless potential of robot programming with Synthiam ARC Pro – where innovation and creativity meet seamlessly.


Try removing the Bluetooth device and then re-discover it.


I have tryed that. And I tryed 2 laptops


Still get the thing. This sucks. My 1st ez-b had a bad regulator. Killed the ez-b. And this one just worked for a few days... any one have this much bad luck? I can't spend this much every few days. Man...


What lights are flashing when you apply power? Disconnect anything you have connected. There's no reason an EZ-B should just "break". Electrical components only break when they are shorted or get too hot. What do you have connected to it? What power source are you using? Etc:)

United Kingdom

The computer isn't seeing the EZ-B.

Follow the diagnostics process detailed in the tutorials. If that still does not help then use the Contact Us page to get in touch with EZ-Robots, explain the problem and they should be able to give you some advice.

It's rare that the EZ-Bs are bad however like any electronics they wont all be perfect.

When the same person is receiving multiple bad boards (or anything for that matter) it always makes me think that it could be user error more than faulty stock, you would be very unlucky to receive two faulty boards. The failure rate on these boards is extremely low.


I have nothing hooked up to it. Both lights flash. The blue is pulsing. And the red will flash till I try to connect to it with blue tooth. Then the light will stay on. For a few sec. The flash. And says all that was in my 1st post... I try and double check everything before I ever apply power.


And my 1st kit had a broken sorvo from getting shoved into the box it comes in. But I don't care about that to much. It still works. Just broke off the the screw holes and I can see the gears. What I do care about is how this one. Has been working for a few days. Then I just cant connect.


Attempting connection on COM3 Comm Err: The operation has timed out. BbytesToExpect: 1

Received: Disconnected Connection Failed: System.Exception: Controller Not Responding at EZ_B.EZB.Connect(String hostname, String tcpPassword, Int32 baudRate) Disconnected


and it is a EZ-B Version 3.1a

United Kingdom

The connection is timing out, which means that the PC is not seeing the EZ-B.

Is the red light on the bluetooth module flashing when you try connecting? Is the EZ-B receiving enough power? Check batteries or try on a bench supply.

Is a third party bluetooth stack being used, or third part bluetooth software. Check you are using the correct COM port.

It might pay to check if the EZ-B is detected by another device if the red light is flashing. While it's not usable you could always turn on bluetooth on your phone and search for devices to see if it can find the EZ-B, that could rule out the PC being the problem.



First, he said he tried to connect to it on 2 different pc's. Second, he said it connects for a few seconds then disconnects(going by the Bluetooth light)


i got the usb bluetooth for the shop. like the on on this site, and i have used my bench top power supply set at 9v. still same thing, i can see the ez-b with my galaxy S2. hmmm. i dont know. and i have done it all, reset, uninstall, re install and i am about to formatt and re install windows 7 on my laptop. my desk top is windows 7. and my girlfriends laptop is windows vista. same thing.


yea, that is what it is doing, it will connects for a few seconds then disconnects(going by the Bluetooth light). i can do it. every thing looks and acts as it did when it was working, lights do the same thing, it just seem to disconnects.

United Kingdom

If it is connecting then disconnecting after a few seconds check your power supply is good enough, it could be a brownout causing it. What do you have plugged in? How many amps is the supply? If you have a high torque servo connected that can pull 3A but your power supply is only 1A it will brown out and disconnect. Also, if your accessories total is more than the regulators can handle (5A from memory) it will brown out.

If the power supply is good then;

Unplug everything from the EZ-B. Connect the EZ-B to the PC Does it disconnect?

Plug in a servo to any of the Digital ports Add a servo control Move the servo Does it disconnect?

Plug in another accessory Add the control & use it Does it disconnect?

Repeat until everything is connected back to the EZ-B or until the disconnect happens.

If the disconnect happens then check the accessory which was last connected.


It is a 15 amp desktop power supply. And the amp meter is reading next to noting with just the ez-b. And still. Like I have said before. It not connect for a sec. Then it will disconnect . Lights still flash. Like it should work.


Try removing the bluetooth chip from the EZ-B then check that all 4 pins are straight, use a small pocket knife blade and lightly scrape the 4 metal prongs sticking down from the Bluetooth then re-insert and test.


Still the same thing.


Is there a way to hook up the ez-b to the PC over sireal cable to the com port just to see if it is the ez-b or Bluetooth?


If you have a comm program like Realterm or Teraterm you can test the connection to the bluetooth that is powered by your EZ-B without using the EZ-B program. Just make sure the bluetooth led is flashing red, attempt a connection and watch for the led to switch to steady green.


I used Realterm and the light on the Bluetooth will stay on. so. any ideas? and thanks the everyone for the help


There is evidently something failing on the EZ-B itself since the bluetooth works. You might try removing the bluetooth then carefully remove the dual inline chip and check for debris between the pins or even bent pins. If nothing is found I'm sure you can get a replacement board.


I hope so. But I will check and see. Thanks... I set a letter to support. Just have to see what they say. I have placed a order for another ez-robot kit. Maybe that would send out a replacement ez-b too. Any one have any more ideas? Or have we hit the end?


You might flip your board over and look for a cold solder joint (poor connection) on one of the pins that the bluetooth plugs into. Looking closely at the Tx Rx pins, maybe use a flashlight and look down into the 4 pin header that the bluetooth plugs into for a damaged connector.


I can't seem to see any. I'll hit every spot with my iron just to make sure.


OK. I did all you said. And still no dice


Ya, I can't think of any other things to test or check so it is time for a replacement board.


OK. Thanks everyone for the help. Is there any way to order just the Ez-B Chip and Bluetooth chip?


Just go to the Support selection at the top of the page.


What part of the support section? Its just about getting started and so on.


Go to "EZ-B Diagnostics" scroll down on the right side until you see "Contact Us" in blue.


Did you find any solution? I didn't.