Asked — Edited

Can'T Connect To Bluetooth

Fresh batteries, connects through bluetooth config (ports 4 and 5), however, when I launch ARC and select port 5 (or port 4, seems to not matter), no dice.

I've uninstalled the device and reinstalled, I've power cycled, etc. No dice.

Any ideas? stress


Upgrade to ARC Pro

Experience early access to the latest features and updates. You'll have everything that is needed to unleash your robot's potential.


OK, So if I select the lower COM port (4) instead of 5 in ARC, I get steady lights. However, when I dismiss the "Welcome to EZ-Robot...", the bluetooth light starts to flash again.

For kicks, I left the dialog up and ran the firmware upgrade utility, selected the lower COM port (4) and this is what I get:

Attempting connection to COM4 Connection Failed: System.UnauthorizedAccessException: Access to the port 'COM4' is denied. at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str) at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace) at System.IO.Ports.SerialPort.Open() at EZ_B.EZB.Connect(String portName) Disconnected



So, dismissed "welcome..." dialog in ARC. Red light flashes, says not connected. Ran Firmaware anyway, selected lower COM port (4), hit connect. Wha lah. Connected, firmware upgraded...


Rough day.


Yeah that sounds a little frustrating. Glad you got it worked out.



If you read the entire message, it will ask if you need to view the upgrade procedure:) by clicking yes, you are directed to a tutorial page with a video on how to do it. The tutorial section is your friend. :)



Yup, read that, tried, got many failed attempts to connect in the firmware update app. Went back and forth many times. There was also a reference in one of the tutorials to choose the bottom, or larger numbered COM port. As it turns out, that information was incorrect, and it was the smaller number COM port that I needed to select. (that being said, I still had a heck of a time getting it all talking to one another.)

It's all good. Learned a lot about the communications systems of the platform.


Strange! Well glad it's working. I believe all references from ez-robot will state to use the lower com. If you see otherwise, let us know so I can change it and prevent others from having trouble. The most difficult support question is Bluetooth connectivity. It's because windows can do some strange things, specifically is not using the standard Bluetooth stack. Every connectivity issue has been resolved by rebooting, or changing to Microsoft Bluetooth stack. :)

now let the robot fun begin! :D


I think this is where I got confused...

In this tutorial: (:50 sec in) Connect to bluetooth

It refers to the second COM port as the one to connect to. In this case, it's a higher value than the first entry.

In my setup, the second entry is a LOWER COM port value.

I thought the reference was to the VALUE not PLACE.

Live and learn :P


Fantastic! Thank u:) Ez-community rocks!