Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Canada
Asked — Edited
Resolved Resolved by Steve G!

Camera From The Ezrobot Developer Kit Will Not Work

I've tried connecting the Ezb camera that came with the developer kit and it worked when I first connected it but it went blank and each time I try to restart it I get the following.

Camera Initialized: EZB://192.168.0.113:24 @ 320x240
EZ-B v4 Camera Error: System.Exception: Client disconnected
at EZ_B.EZBv4Video.BEr2DfF4cs(Int32 , Object )
Camera Disabled

I can search and it finds it and I've tried changing the resolution but each time I try to start the camera I get the above error.

Is the camera bad?

Any asistance would be greatly appreciated.

AI Support Bot
Related Content
Synthiam
United Kingdom
#1  
The debug error says the camera is not connected, so try re-seating the camera cables at both ends and make sure the lights on the camera light up.

I take it from the IP address that your EZ-B is in Client mode. One thing to try in the camera device control is to change the cameras up address from...

EZB://192.168.0.113:24

To

EZB://192.168.0.113

Basically make sure the EZ-B’s IP address in the connection window and camera ip address are the same, but without the : symbol and the last 2 digits (in your case... :24) in the camera control. Power up the EZ-B, connect it to ARC and click start on the camera control. Give it a try and report back.
#2  
I checked the cable at both ends and it was fine. I changed the IP and got the same thing. There are lights that flash when I first boot up but nothing after that. I believe there is suppose to be a solid blue light. I'm pretty sure that the camera is not functioning
PRO
Synthiam
#3  
1) I would start by loading the most recent copy of ARC. Your version is a few months old... Given the errors i can see from the log, it appears the version of ARC you have has a bug and requires an update. You can download ARC here: https://www.ez-robot.com/EZ-Builder

(Do not ignore updating ARC)

2) I would recommend using the EZ-B and Camera in AP Mode to rule out any network issues. You can do this by pressing the RESET button on the EZ-B. And connect with a NEW EMPTY project to the EZ-B's access point. Add the camera and test with a NEW EMPTY project. Here is instructions to reset EZ-B: https://www.ez-robot.com/Tutorials/Lesson/16?courseId=5

If your camera cycles through different colors on bootup - does the LED turn OFF after?
#4  
Hi DJ, I actually updated the ARC to ver. 2018.03.06 earlier today. But I uninstalled and then re-installed ARC ver 2018.03.06.

I then reset the EZ-B as you advised and setup the camera in a new project. Got the same thing.

I get some quick flashing lights on the camera board at boot up and then no light. The LED is off.
United Kingdom
#5  
With no LED illuminated after the start up cycle, it sounds like the camera is faulty as you should see a blue LED. Unless DJ has any other suggestions, I’d say to use the Contact Us link and submit a warranty claim and see if you’re eligible for a replacement.
#7  
Resolved - a replacement camera was received