Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Bing Vr Start Button

I'm having an issue with starting Bing to listen right after EZ Builder starts. I cant start it listening by clicking the Start Recording button or starting it from an EZ Script with the start listening command.

The only way I can get the control to start recording is to go into it's settings page and click on the Save button. Then when I exit back to the front of the control everything is working right. The control will continue to work correctly until I restart EZ Builder. Then I need to do the above all over again.

Any ideas what may be going on here? I turned my Windows Defender off but nothing changed. I have no other antivirus running.

I'v attached a Youtube vid of what is happening.

Thanks!

Australia
#1  
I think it may have something to do with the way the api keys are being stored after one of the recent updates, I've noticed a similar thing with the cognitive vision plugin,
- on first start of ARC it comes up that theres no api key
- open settings key is there
- click save and everything works fine until ARC is shutdown and restarted
#2  
Hey Dave,

Check to make sure the api keys are set again as nick777 mentioned. I think the update that DJ pushed removed the keys due to them now being stored differently. This will happen on the cognitive recognition stuff and on API.AI also. Once this is done it should fix the issue for you for good. I noticed that they stopped working on Spock after the update to these plugins but haven't looked into it yet.

Let me know if nick777's suggestions work out for you. I think that they will.
#3  
OK, thanks guys. However I installed,started using Bing and set the Key "after" the update. I'll give this a try. I'm sure if you fixed your issue like this, it will work for me.

Interesting though, I did delete the control at one time before this issue started up and reinstalled it. I remember seeing my key already inserted on the new control. After hearing your explanation I'm sure this caused it.

So, when you say "set the key" do you mean delete the old one and reenter the new and save?

Thanks again! :)
#4  
Sorry to say this did not help me.

I cleared the Key box in the control. Shut down ARC and rebooted windows 10. I then went back in the Bing control and reentered my key and saved.

Everything was working again until I restarted ARC. Same issue as before, Cant start the Bing control until I go into settings and click on save. *confused*

I went back in and clicked Save again bit the issue stays.
#5  
I've spent some time on this problem and have not resolved anthing. I still can't get the Bing control to start recording until I go into the control, click save. Once I can see the front of the control again I can click on the start button and the control will start listening. You can see this in the video attached above.

Here's what I tried:
Deleated the ARC Voice Rec control
Deleated the Bing control and reinstalled it.
Started a new project with only the Bing control installed.
Compleatly uninstalled ARC and then reinstalled the latest version.
Started a new project on a new computer with only the Bing control installed.

Each time in the above stepts I deleated the KEY in the control and reset it. I then exited the project and then restarted the project (several times).

Only thing left is to some how uninstall the Bing plugin from ARC and reinstall it. How do I do that? I noticed that I always have the Bing plugin in the Add To project section even after I reinstalled ARC.

Help please. Any other ideas? Anyone else stillhaving this issue? *confused*
#6  
Try this. open the project.
click the gear on the bing speech plugin
click OK on the window that opens up
see if you can use the plugin.

This is what I have to do to use it. I am curious if you are having the same issue.
#7  
Hi David, I don't have an OK button. Just a Save and Cancel button.
#9  
Ah, Ok.

When I first start ARC, the Start Recording button on the plugin control is unresponsive. I then click on the Gear Icon and after the settings page opens I click on Save. After this action has been done the control works great. However the next time I start ARC after it's been shut down for the day, I have to again click on the Gear Icon, then after the settings page opens, I again have to click on Save to get it to record again. This continuously happens each time I start a new session by opening ARC for the first time.
#10  
I have found this to be the case on the plugins that were changed to store the API keys outside of the project. These include API.AI, Microsoft Cognitive Vision, Microsoft Cognitive Emotion and the Bing Speech Recognition plugins.
#12  
Thanks for your help Dave. I'm starting to see that also. It's just another step to get the VR to start working by manually clicking a couple buttons. However if you have an onboard computer that's hard to get at this could be a real pain. Until DJ finds a way around this I'm going to have to use the mouse plugin. With that this process of clicking Save to get Bing to start recording will be automated in INT script.

Thanks again.
#14  
@Dave & David,
I too have seen this, I'm late to this so I may have missed something.
Question, do you have to login to Microsoft's API site for this API to work? I've noticed if am not logged into that site I get a transport and login failed in the bing speech window of ezb. After I login it works fine. Am I doing something wrong?

Thanks,
#15  
Mike,

You shouldn't have to login to Microsofts API site for these to work. The API key is kind your login.

DJ has published updates to these plugins. I won't have time to check them out until tonight or tomorrow. I assume that these updates were to address this issue. If nobody else checks them out before I can, I will post an update letting people know if the issue is resolved.
#16  
I've been able too use the Bing plugin without being logged into Microsoft's API site. Only having the start recording issue I've mentioned here.
#17  
Ok thanks Dave, I will dig deeper and install the updates to see. I get 2 keys from Microsoft and I'm using key 1, going to try key 2 and see if it makes a difference . Thanks again Dave.
#18  
Merne, I already tried the 2nd key. No change. MS provides the 2nd one so you can change it for security reasons without service Interruptions.
#19  
Dave, I install the updates and everything is working now I'm not sure if it was just me? Might have been as some of this is just too techie for me. Thanks again!

And of course thanks to Dj for the updates!
#20  
OK Great! My Bing Start Recording button is working properly now. Now more need to click the Save Button after each ARC restart. Many thanks DJ for the plugin update. :D